aboutsummaryrefslogtreecommitdiff
path: root/sysutils/munin-master
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
commit17e550ca2fd180b150f6645ced5f3bb45bc32292 (patch)
treee856fa025c5b15bbef21f621e347c51780662a47 /sysutils/munin-master
parentb4599e3d63c3a94b17026b18d1f8ac27faac53fc (diff)
downloadports-17e550ca2fd180b150f6645ced5f3bb45bc32292.tar.gz
ports-17e550ca2fd180b150f6645ced5f3bb45bc32292.zip
Notes
Diffstat (limited to 'sysutils/munin-master')
-rw-r--r--sysutils/munin-master/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index d525ac566eb4..47049db20b0c 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -7,6 +7,7 @@
PORTNAME= munin
PORTVERSION= 1.4.5
+PORTREVISION= 1
CATEGORIES= sysutils perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
PKGNAMESUFFIX= -master
@@ -16,7 +17,6 @@ COMMENT= Collector part of Munin
BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/converters/p5-Storable-AMF \
@@ -27,7 +27,6 @@ BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced
RUN_DEPENDS= ${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/converters/p5-Storable-AMF \
${SITE_PERL}/DateTime/HiRes.pm:${PORTSDIR}/devel/p5-DateTime-HiRes \
@@ -67,6 +66,13 @@ MAN8= munin-cron.8 \
PLIST_SUB= DBDIR=${DBDIR}
SUB_FILES= pkg-message
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+BUILD_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
pre-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGDIR}/pkg-install ${PKGNAME} PRE-INSTALL
@@ -88,4 +94,4 @@ post-install:
${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>