aboutsummaryrefslogtreecommitdiff
path: root/sysutils/munin-node
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-06 22:50:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-06 22:50:50 +0000
commit2946e4e824c75a6f60cae2b39936845657c0b10d (patch)
tree2a35e708fe599e86801e2c8a9e72d33e7f78609f /sysutils/munin-node
parent94b229537b496aebba0dddcdc72796c7b612a07d (diff)
downloadports-2946e4e824c75a6f60cae2b39936845657c0b10d.tar.gz
ports-2946e4e824c75a6f60cae2b39936845657c0b10d.zip
Notes
Diffstat (limited to 'sysutils/munin-node')
-rw-r--r--sysutils/munin-node/Makefile5
-rw-r--r--sysutils/munin-node/distinfo6
-rw-r--r--sysutils/munin-node/files/patch-Makefile.config4
-rw-r--r--sysutils/munin-node/pkg-deinstall10
-rw-r--r--sysutils/munin-node/pkg-install10
-rw-r--r--sysutils/munin-node/pkg-plist9
6 files changed, 25 insertions, 19 deletions
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index f9596250aa78..90833815d0aa 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= munin
-PORTVERSION= 1.2.4
-PORTREVISION= 2
+PORTVERSION= 1.2.5
CATEGORIES= sysutils perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= munin
@@ -35,7 +34,7 @@ PATCH_STRIP= -p1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.r/rc/}
PKGMESSAGE= ${WRKDIR}/pkg-message
ALL_TARGET= DATADIR=${DATADIR} PERL=${PERL} build build-man
-INSTALL_TARGET= DATADIR=${DATADIR} PERL=${PERL} install-node install-node-plugins
+INSTALL_TARGET= DATADIR=${DATADIR} PERL=${PERL} SITE_PERL_REL=$(SITE_PERL_REL) install-node install-node-plugins
MAKE_ENV= LANG=C
MAN5= munin-node.conf.5
diff --git a/sysutils/munin-node/distinfo b/sysutils/munin-node/distinfo
index 5f2333009a43..f587b9252397 100644
--- a/sysutils/munin-node/distinfo
+++ b/sysutils/munin-node/distinfo
@@ -1,3 +1,3 @@
-MD5 (munin_1.2.4.tar.gz) = f91f5d96c01d8527db1d2f4b3f0f4cc5
-SHA256 (munin_1.2.4.tar.gz) = 23a6404ad84776446b7af0c4d27c57f8a06ab74602f4304e0745c35621ae7f7c
-SIZE (munin_1.2.4.tar.gz) = 345821
+MD5 (munin_1.2.5.tar.gz) = e863d11693c02bde1c593a6c701e64fd
+SHA256 (munin_1.2.5.tar.gz) = 2d1ea4aa3f0eaf11a5beb0b90f9bbee63e184249e06274fcc9d4c17b70b47a5e
+SIZE (munin_1.2.5.tar.gz) = 353005
diff --git a/sysutils/munin-node/files/patch-Makefile.config b/sysutils/munin-node/files/patch-Makefile.config
index 467aeffbc597..3707764900c3 100644
--- a/sysutils/munin-node/files/patch-Makefile.config
+++ b/sysutils/munin-node/files/patch-Makefile.config
@@ -38,7 +38,7 @@
# Server only - Output directory
-HTMLDIR = $(PREFIX)/var/www
-CGIDIR = $(HTMLDIR)/cgi
-+HTMLDIR = $(PREFIX)/www/data/munin
++HTMLDIR = $(PREFIX)/www/munin
+CGIDIR = $(PREFIX)/www/cgi-bin
# Client only - Where to put RRD files and other intenal data
@@ -67,7 +67,7 @@
# Server only - Where to install the perl libraries
-PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d= -f2 | sed "s/[\';]//g")
-+PERLLIB = $(shell $(PERL) -V:sitelib | cut -d= -f2 | sed "s/[\';]//g")
++PERLLIB = $(PREFIX)/$(SITE_PERL_REL)
# Client only - Install plugins for this architecture
OSTYPE = $(shell uname | tr '[A-Z]' '[a-z]')
diff --git a/sysutils/munin-node/pkg-deinstall b/sysutils/munin-node/pkg-deinstall
index 3bf91c5a0e5b..4a3410cd306f 100644
--- a/sysutils/munin-node/pkg-deinstall
+++ b/sysutils/munin-node/pkg-deinstall
@@ -5,7 +5,7 @@ ask() {
question=$1
default=$2
- if [ -z "${PACKAGE_BUILDING}" ]; then
+ if [ -z "${PACKAGE_BUILDING}" -a -z "${BATCH}" ]; then
read -p "${question} [${default}]? " answer
fi
if [ x${answer} = x ]; then
@@ -83,9 +83,11 @@ Do you want me to delete it?" y; then
case $2 in
DEINSTALL)
- delete_crontab_entries ${PKG_PREFIX}/bin/munin-node-revive
- stop_process
- newsyslog
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ delete_crontab_entries ${PKG_PREFIX}/bin/munin-node-revive
+ stop_process
+ newsyslog
+ fi
;;
POST-DEINSTALL)
delete_group munin
diff --git a/sysutils/munin-node/pkg-install b/sysutils/munin-node/pkg-install
index 6a085e0c8773..06c2187aa44e 100644
--- a/sysutils/munin-node/pkg-install
+++ b/sysutils/munin-node/pkg-install
@@ -5,7 +5,7 @@ ask() {
question=$1
default=$2
- if [ -z "${PACKAGE_BUILDING}" ]; then
+ if [ -z "${PACKAGE_BUILDING}" -a -z "${BATCH}" ]; then
read -p "${question} [${default}]? " answer
fi
if [ x${answer} = x ]; then
@@ -112,8 +112,10 @@ case $2 in
make_group munin
;;
POST-INSTALL)
- init_plugins
- ${PKG_PREFIX}/etc/rc.d/munin-node.sh start
- newsyslog
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ init_plugins
+ ${PKG_PREFIX}/etc/rc.d/munin-node.sh start
+ newsyslog
+ fi
;;
esac
diff --git a/sysutils/munin-node/pkg-plist b/sysutils/munin-node/pkg-plist
index 62a14c300c96..0201c44fb7cf 100644
--- a/sysutils/munin-node/pkg-plist
+++ b/sysutils/munin-node/pkg-plist
@@ -2,7 +2,7 @@
@exec mkdir -p %D/etc/munin/plugin-conf.d && chmod 755 %D/etc/munin/plugin-conf.d
@exec mkdir -p %D/var/munin/plugin-state && chgrp munin %D/var/munin/plugin-state && chmod 775 %D/var/munin/plugin-state
@unexec rm %D/bin/munin-node-revive 2>/dev/null || true
-@comment etc/munin/VERSION.node must remain for upgrade version check
+@unexec if [ -n "$PACKAGE_BUILDING" ]; then rm -f %D/etc/munin/VERSION.node; fi
@unexec if cmp -s %D/etc/munin/munin-node.conf %D/etc/munin/munin-node.conf.sample; then rm -f %D/etc/munin/munin-node.conf; fi
etc/munin/munin-node.conf.sample
@unexec if cmp -s %D/etc/munin/plugin-conf.d/plugins.conf %D/etc/munin/plugin-conf.d/plugins.conf.sample; then rm -f %D/etc/munin/plugin-conf.d/plugins.conf; fi
@@ -113,9 +113,12 @@ sbin/munin-run
@dirrmtry %%DATADIR%%/plugins
@dirrmtry %%DATADIR%%
@dirrmtry etc/munin/plugin-conf.d
+@dirrmtry etc/munin/plugins
@dirrmtry etc/munin
-@unexec rmdir %%LOCALBASE%%/%%SITE_PERL%%/Munin/Plugin 2>/dev/null || true
-@unexec rmdir %%LOCALBASE%%/%%SITE_PERL%%/Munin 2>/dev/null || true
+@unexec echo remove %%SITE_PERL%%/Munin/Plugin
+@unexec echo remove %%SITE_PERL%%/Munin
+@dirrmtry %%SITE_PERL%%/Munin/Plugin
+@dirrmtry %%SITE_PERL%%/Munin
@unexec echo
@unexec echo '********************************************************************'
@unexec echo "If you want to *completely* remove munin-node, you have to"