aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nautilus-cd-burner
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
commit58406bee8938178fc317574c4236434b0dd11a25 (patch)
treeb4fa34eca69e23769c548b4436cbf65d765e5fe2 /sysutils/nautilus-cd-burner
parent98eb5c95a29c8dd1a76435744e5316092835f696 (diff)
downloadports-58406bee8938178fc317574c4236434b0dd11a25.tar.gz
ports-58406bee8938178fc317574c4236434b0dd11a25.zip
Notes
Diffstat (limited to 'sysutils/nautilus-cd-burner')
-rw-r--r--sysutils/nautilus-cd-burner/Makefile17
-rw-r--r--sysutils/nautilus-cd-burner/distinfo4
-rw-r--r--sysutils/nautilus-cd-burner/files/patch-bacon-cd-selection.c15
-rw-r--r--sysutils/nautilus-cd-burner/files/patch-cd-drive.c218
-rw-r--r--sysutils/nautilus-cd-burner/files/patch-configure27
-rw-r--r--sysutils/nautilus-cd-burner/files/patch-nautilus-cd-burner.c33
-rw-r--r--sysutils/nautilus-cd-burner/pkg-plist19
7 files changed, 320 insertions, 13 deletions
diff --git a/sysutils/nautilus-cd-burner/Makefile b/sysutils/nautilus-cd-burner/Makefile
index d797995a06d6..41f1a5d3afef 100644
--- a/sysutils/nautilus-cd-burner/Makefile
+++ b/sysutils/nautilus-cd-burner/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= nautilus-cd-burner
-PORTVERSION= 2.6.1
-PORTREVISION= 1
+PORTVERSION= 2.8.5
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.6
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.8
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -23,13 +22,21 @@ USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack intlhack lthack nautilus2
-USE_INC_LIBTOOL_VER=13
+USE_GNOME= gnomeprefix gnomehack intlhack nautilus2
+USE_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+GCONF_SCHEMAS= ncb.schemas
+
.include <bsd.port.pre.mk>
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
+.undef WITHOUT_DVD
+WITH_DVD= yes
+.endif
+
.if exists(${LOCALBASE}/bin/growisofs)
WITH_DVD= yes
.endif
diff --git a/sysutils/nautilus-cd-burner/distinfo b/sysutils/nautilus-cd-burner/distinfo
index 52439e08a10e..6b36ce4a810a 100644
--- a/sysutils/nautilus-cd-burner/distinfo
+++ b/sysutils/nautilus-cd-burner/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/nautilus-cd-burner-2.6.1.tar.bz2) = 7998cbe011e9e0a22d9362a2430d578b
-SIZE (gnome2/nautilus-cd-burner-2.6.1.tar.bz2) = 455965
+MD5 (gnome2/nautilus-cd-burner-2.8.5.tar.bz2) = 970173a3f93270950ca9fd247bdf07a7
+SIZE (gnome2/nautilus-cd-burner-2.8.5.tar.bz2) = 529099
diff --git a/sysutils/nautilus-cd-burner/files/patch-bacon-cd-selection.c b/sysutils/nautilus-cd-burner/files/patch-bacon-cd-selection.c
new file mode 100644
index 000000000000..a684ac82a0de
--- /dev/null
+++ b/sysutils/nautilus-cd-burner/files/patch-bacon-cd-selection.c
@@ -0,0 +1,15 @@
+--- bacon-cd-selection.c.orig Thu Nov 4 00:25:43 2004
++++ bacon-cd-selection.c Thu Nov 4 00:25:57 2004
+@@ -177,10 +177,10 @@
+ static void
+ bacon_cd_selection_init (BaconCdSelection *bcs)
+ {
+- bcs->priv = g_new0 (BaconCdSelectionPrivate, 1);
+-
+ GtkCellRenderer *cell;
+ GtkListStore *store;
++ bcs->priv = g_new0 (BaconCdSelectionPrivate, 1);
++
+
+ store = gtk_list_store_new (1, G_TYPE_STRING);
+ gtk_combo_box_set_model (GTK_COMBO_BOX (bcs),
diff --git a/sysutils/nautilus-cd-burner/files/patch-cd-drive.c b/sysutils/nautilus-cd-burner/files/patch-cd-drive.c
new file mode 100644
index 000000000000..1bcf94f3e29b
--- /dev/null
+++ b/sysutils/nautilus-cd-burner/files/patch-cd-drive.c
@@ -0,0 +1,218 @@
+--- cd-drive.c.orig Wed Sep 22 09:20:04 2004
++++ cd-drive.c Mon Oct 4 02:20:47 2004
+@@ -270,9 +270,21 @@
+ {
+ int fd;
+ int mmc_profile;
++#ifdef __FreeBSD__
++ struct cam_device *cam;
++#endif
+
+ g_return_val_if_fail (device != NULL, CD_MEDIA_TYPE_ERROR);
+
++#ifdef __FreeBSD__
++ cam = cam_open_device (device, O_RDWR);
++ if (cam == NULL) {
++ return CD_MEDIA_TYPE_ERROR;
++ }
++
++ fd = cam->fd;
++#else
++
+ fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
+ if (fd < 0) {
+ if (errno == EBUSY) {
+@@ -280,6 +292,7 @@
+ }
+ return CD_MEDIA_TYPE_ERROR;
+ }
++#endif
+
+ mmc_profile = get_mmc_profile (fd);
+
+@@ -307,7 +320,11 @@
+ }
+ }
+
++#ifdef __FreeBSD__
++ cam_close_device (cam);
++#else
+ close (fd);
++#endif
+
+ switch (mmc_profile) {
+ case -1:
+@@ -442,10 +459,21 @@
+ int secs;
+ int mmc_profile;
+ gint64 size;
++#ifdef __FreeBSD__
++ struct cam_device *cam;
++#endif
+
+ g_return_val_if_fail (device != NULL, CD_MEDIA_SIZE_UNKNOWN);
+
+ secs = 0;
++#ifdef __FreeBSD__
++ cam = cam_open_device (device, O_RDWR);
++ if (cam == NULL) {
++ return CD_MEDIA_SIZE_UNKNOWN;
++ }
++
++ fd = cam->fd;
++#else
+
+ fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
+ if (fd < 0) {
+@@ -454,6 +482,7 @@
+ }
+ return CD_MEDIA_SIZE_UNKNOWN;
+ }
++#endif
+
+ mmc_profile = get_mmc_profile (fd);
+
+@@ -476,7 +505,11 @@
+ size = CD_MEDIA_SIZE_NA;
+ }
+
++#ifdef __FreeBSD__
++ cam_close_device (cam);
++#else
+ close (fd);
++#endif
+
+ return size;
+ }
+@@ -595,9 +628,81 @@
+ #endif /* USE_HAL */
+
+ #if defined(__linux__) || defined(__FreeBSD__)
++static int
++get_device_max_write_speed (char *device)
++{
++ int fd;
++ int max_speed;
++ int read_speed, write_speed;
++#ifdef __FreeBSD__
++ struct cam_device *cam;
++#endif
++
++ max_speed = -1;
++#ifdef __FreeBSD__
++ cam = cam_open_device (device, O_RDWR);
++ if (cam == NULL) {
++ return -1;
++ }
++
++ fd = cam->fd;
++#else
++
++ fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
++ if (fd < 0) {
++ return -1;
++ }
++#endif
+
++ get_read_write_speed (fd, &read_speed, &write_speed);
++#ifdef __FreeBSD__
++ cam_close_device (cam);
++#else
++ close (fd);
++#endif
++ max_speed = (int)floor (write_speed) / CD_ROM_SPEED;
+
++ return max_speed;
++}
+
++#if !defined(__linux)
++static int
++get_device_max_read_speed (char *device)
++{
++ int fd;
++ int max_speed;
++ int read_speed, write_speed;
++#ifdef __FreeBSD__
++ struct cam_device *cam;
++#endif
++
++ max_speed = -1;
++#ifdef __FreeBSD__
++ cam = cam_open_device (device, O_RDWR);
++ if (cam == NULL) {
++ return -1;
++ }
++
++ fd = cam->fd;
++#else
++
++ fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
++ if (fd < 0) {
++ return -1;
++ }
++#endif
++
++ get_read_write_speed (fd, &read_speed, &write_speed);
++#ifdef __FreeBSD__
++ cam_close_device (cam);
++#else
++ close (fd);
++#endif
++ max_speed = (int)floor (read_speed) / CD_ROM_SPEED;
++
++ return max_speed;
++}
++#endif
+ #endif /* __linux__ || __FreeBSD__ */
+
+ #if defined (__linux__)
+@@ -800,49 +905,7 @@
+ return NULL;
+ }
+
+-#if !defined(__linux)
+-static int
+-get_device_max_read_speed (char *device)
+-{
+- int fd;
+- int max_speed;
+- int read_speed, write_speed;
+
+- max_speed = -1;
+-
+- fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
+- if (fd < 0) {
+- return -1;
+- }
+-
+- get_read_write_speed (fd, &read_speed, &write_speed);
+- close (fd);
+- max_speed = (int)floor (read_speed) / CD_ROM_SPEED;
+-
+- return max_speed;
+-}
+-#endif
+-
+-static int
+-get_device_max_write_speed (char *device)
+-{
+- int fd;
+- int max_speed;
+- int read_speed, write_speed;
+-
+- max_speed = -1;
+-
+- fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
+- if (fd < 0) {
+- return -1;
+- }
+-
+- get_read_write_speed (fd, &read_speed, &write_speed);
+- close (fd);
+- max_speed = (int)floor (write_speed) / CD_ROM_SPEED;
+-
+- return max_speed;
+-}
+
+ static char *
+ get_scsi_cd_name (int bus, int id, int lun, const char *dev,
diff --git a/sysutils/nautilus-cd-burner/files/patch-configure b/sysutils/nautilus-cd-burner/files/patch-configure
new file mode 100644
index 000000000000..e8dbb4a5b891
--- /dev/null
+++ b/sysutils/nautilus-cd-burner/files/patch-configure
@@ -0,0 +1,27 @@
+--- configure.orig Thu Jul 22 10:27:35 2004
++++ configure Thu Jul 22 10:29:32 2004
+@@ -21015,6 +21015,8 @@
+ if eval "test \"\${$as_ac_var+set}\" = set"; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
++ ac_check_lib_save_LIBS=$LIBS
++ LIBS="-lintl $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -21097,6 +21099,7 @@
+ fi
+ rm -f conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
++ LIBS=$ac_check_lib_save_LIBS
+ fi
+ echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_var'}'`" >&5
+ echo "${ECHO_T}`eval echo '${'$as_ac_var'}'`" >&6
+@@ -21104,6 +21107,7 @@
+ cat >>confdefs.h <<_ACEOF
+ #define `echo "HAVE_$ac_func" | $as_tr_cpp` 1
+ _ACEOF
++LIBS="-lintl $LIBS"
+
+ fi
+ done
diff --git a/sysutils/nautilus-cd-burner/files/patch-nautilus-cd-burner.c b/sysutils/nautilus-cd-burner/files/patch-nautilus-cd-burner.c
new file mode 100644
index 000000000000..3b8b07293043
--- /dev/null
+++ b/sysutils/nautilus-cd-burner/files/patch-nautilus-cd-burner.c
@@ -0,0 +1,33 @@
+--- nautilus-cd-burner.c.orig Sun Sep 19 18:44:15 2004
++++ nautilus-cd-burner.c Sun Oct 31 13:06:08 2004
+@@ -21,6 +21,8 @@
+
+ Authors: Alexander Larsson <alexl@redhat.com>
+ */
++#include <sys/types.h>
++#include <sys/stat.h>
+ #include <gtk/gtk.h>
+ #include <gtk/gtkfilesel.h>
+ #include <gtk/gtkseparatormenuitem.h>
+@@ -632,8 +634,19 @@
+ }
+
+ if (res == RESULT_RETRY) {
+- g_free (filename);
+- filename = g_build_filename (g_get_tmp_dir (), "image.iso.XXXXXX", NULL);
++ gchar *path1;
++
++ path1 = g_strdup_printf ("%s/.ncb", g_get_home_dir());
++
++ if (!g_file_test (path1, G_FILE_TEST_EXISTS)) {
++ mkdir (path1, 0700);
++ }
++
++ if (filename != NULL) {
++ g_free (filename);
++ }
++ filename = g_build_filename (path1, "image.iso.XXXXXX", NULL);
++ g_free (path1);
+ fd = g_mkstemp(filename);
+ close (fd);
+
diff --git a/sysutils/nautilus-cd-burner/pkg-plist b/sysutils/nautilus-cd-burner/pkg-plist
index c568590ce43b..c73c94fd94d0 100644
--- a/sysutils/nautilus-cd-burner/pkg-plist
+++ b/sysutils/nautilus-cd-burner/pkg-plist
@@ -1,12 +1,14 @@
bin/nautilus-cd-burner
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/ncb.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/ncb.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/ncb.schemas > /dev/null || /usr/bin/true
etc/gnome-vfs-2.0/modules/mapping-modules.conf
+include/libnautilus-burn/bacon-cd-selection.h
+include/libnautilus-burn/cd-drive.h
+include/libnautilus-burn/cd-recorder.h
lib/gnome-vfs-2.0/modules/libmapping.so
-lib/nautilus/extensions-1.0/libnautilus-burn.a
-lib/nautilus/extensions-1.0/libnautilus-burn.so
-lib/nautilus/extensions-1.0/libnautilus-burn.so.0
+lib/libnautilus-burn.a
+lib/libnautilus-burn.so
+lib/libnautilus-burn.so.0
+lib/nautilus/extensions-1.0/libnautilus-burn-extension.so
+libdata/pkgconfig/libnautilus-burn.pc
libexec/mapping-daemon
share/gnome/nautilus-cd-burner/cdburn.glade
share/gnome/nautilus-cd-burner/cdspin1.png
@@ -23,6 +25,7 @@ share/locale/az/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/be/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/bg/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/bn/LC_MESSAGES/nautilus-cd-burner.mo
+share/locale/bs/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/ca/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/cs/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/cy/LC_MESSAGES/nautilus-cd-burner.mo
@@ -44,6 +47,7 @@ share/locale/hi/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/hr/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/hu/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/id/LC_MESSAGES/nautilus-cd-burner.mo
+share/locale/is/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/it/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/ja/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/ko/LC_MESSAGES/nautilus-cd-burner.mo
@@ -51,8 +55,10 @@ share/locale/lt/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/lv/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/mn/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/ms/LC_MESSAGES/nautilus-cd-burner.mo
+share/locale/nb/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/nl/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/no/LC_MESSAGES/nautilus-cd-burner.mo
+share/locale/or/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/pa/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/pl/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/pt/LC_MESSAGES/nautilus-cd-burner.mo
@@ -72,3 +78,4 @@ share/locale/vi/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/zh_CN/LC_MESSAGES/nautilus-cd-burner.mo
share/locale/zh_TW/LC_MESSAGES/nautilus-cd-burner.mo
@dirrm share/gnome/nautilus-cd-burner
+@dirrm include/libnautilus-burn