aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ndir/Makefile
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2001-07-22 08:41:28 +0000
committerMark Pulford <markp@FreeBSD.org>2001-07-22 08:41:28 +0000
commit93c06df5b9ede88c5fc8290f23d62b64c3b10479 (patch)
tree2e55f9ac4de630720edae0f616fe2f49d410f051 /sysutils/ndir/Makefile
parent46ea14e18e9e8ed8b29de6efcd7136d890a2ee37 (diff)
downloadports-93c06df5b9ede88c5fc8290f23d62b64c3b10479.tar.gz
ports-93c06df5b9ede88c5fc8290f23d62b64c3b10479.zip
Notes
Diffstat (limited to 'sysutils/ndir/Makefile')
-rw-r--r--sysutils/ndir/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/ndir/Makefile b/sysutils/ndir/Makefile
new file mode 100644
index 000000000000..448a111b97b8
--- /dev/null
+++ b/sysutils/ndir/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ndir
+# Date created: Jun 16, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ndir
+PORTVERSION= 0.8.5
+CATEGORIES= sysutils
+MASTER_SITES= http://www.Informatik.Uni-Oldenburg.DE/~mw/software/
+DISTNAME= NDir-${PORTVERSION}
+EXTRACT_SUFX= -1.tar.gz
+
+MAINTAINER= markp@FreeBSD.org
+
+USE_GMAKE= yes
+ALL_TARGET= compile
+CFLAGS+= -DNO_THOUSANDS_GROUPING
+MAN1= ndir.1
+MLINKS= ndir.1 lv.1 ndir.1 lw.1
+
+post-patch:
+ @${PERL} -pi -e "s/^export GLOBAL.+//g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ndir ${PREFIX}/bin
+ ${LN} -sf ndir ${PREFIX}/bin/lw
+ ${LN} -sf ndir ${PREFIX}/bin/lv
+ ${INSTALL_MAN} ${WRKSRC}/ndir.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>