aboutsummaryrefslogtreecommitdiff
path: root/sysutils/netident
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-05-29 01:42:32 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-05-29 01:42:32 +0000
commit936b3ddebd1475084e16444303b65af12889caf7 (patch)
tree2c73b5e06efd8c391df8350a71fe5284e1245baf /sysutils/netident
parent11e8b231a6a7eb45acb3240ae61dafd9f5cc78fa (diff)
downloadports-936b3ddebd1475084e16444303b65af12889caf7.tar.gz
ports-936b3ddebd1475084e16444303b65af12889caf7.zip
Notes
Diffstat (limited to 'sysutils/netident')
-rw-r--r--sysutils/netident/Makefile48
-rw-r--r--sysutils/netident/distinfo3
-rw-r--r--sysutils/netident/pkg-descr1
3 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/netident/Makefile b/sysutils/netident/Makefile
new file mode 100644
index 000000000000..1a58470d2081
--- /dev/null
+++ b/sysutils/netident/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: netident
+# Date created: 11 March 2008
+# Whom: Zane C. Bowers
+#
+# $FreeBSD$
+#
+
+PORTNAME= netident
+PORTVERSION= 0.1.0
+CATEGORIES= sysutils deskutils
+MASTER_SITES= http://cpan.org/authors/id/V/VV/VVELOX/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.pl
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= A tool for helping identify what network a machine is on
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IO/Interface.pm:${PORTSDIR}/net/p5-IO-Interface \
+ ${SITE_PERL}/Net/CIDR/Lite.pm:${PORTSDIR}/net/p5-Net-CIDR-Lite
+
+USE_PERL5_RUN= yes
+USE_PERL5_BUILD=yes
+NO_WRKSUBDIR= yes
+
+MAN1= ${PORTNAME}.1
+
+PLIST_FILES= bin/${PORTNAME}
+PLIST_DIRS= etc/netident
+
+post-extract:
+ @${CP} -v ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+#nothing to configure
+#do-configure:
+# @${ECHO} -n
+
+do-build:
+ @${EXEC} pod2man --section=1 --release=${PORTVERSION} --name=${PORTNAME} --center=${PORTNAME}" user guide" ${WRKSRC}/${DISTNAME} ${WRKSRC}/${PORTNAME}.1
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${PREFIX}/man/man1/${PORTNAME}.1
+ @${CHMOD} +x ${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} /var/db/netident/
+ @${MKDIR} ${PREFIX}/etc/netident/
+
+.include <bsd.port.mk>
diff --git a/sysutils/netident/distinfo b/sysutils/netident/distinfo
new file mode 100644
index 000000000000..b5ce56300d94
--- /dev/null
+++ b/sysutils/netident/distinfo
@@ -0,0 +1,3 @@
+MD5 (netident-0.1.0.pl) = 74f3a2bd9fbda35bf834e2f372b3b98c
+SHA256 (netident-0.1.0.pl) = ffdc5a533ae1d37dce2b5e8e6bc21e93df3f2980578532e6c43d8b8d24dc2088
+SIZE (netident-0.1.0.pl) = 12158
diff --git a/sysutils/netident/pkg-descr b/sysutils/netident/pkg-descr
new file mode 100644
index 000000000000..0f6f95dc8c12
--- /dev/null
+++ b/sysutils/netident/pkg-descr
@@ -0,0 +1 @@
+A tool for helping identify what network a machine is on.