aboutsummaryrefslogtreecommitdiff
path: root/sysutils/node_exporter
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2020-06-17 16:05:57 +0000
committerMikael Urankar <mikael@FreeBSD.org>2020-06-17 16:05:57 +0000
commit876a404647b4fa150bc28c65d6f532e3e9be318f (patch)
tree2c66bc9eb628b04418182f607dc322b1936f2eb4 /sysutils/node_exporter
parentc6d1d3f1380edbabf02ca6e0b802f612decf9e99 (diff)
downloadports-876a404647b4fa150bc28c65d6f532e3e9be318f.tar.gz
ports-876a404647b4fa150bc28c65d6f532e3e9be318f.zip
Notes
Diffstat (limited to 'sysutils/node_exporter')
-rw-r--r--sysutils/node_exporter/Makefile10
-rw-r--r--sysutils/node_exporter/distinfo6
-rw-r--r--sysutils/node_exporter/files/node_exporter.in2
-rw-r--r--sysutils/node_exporter/pkg-message24
-rw-r--r--sysutils/node_exporter/pkg-plist30
5 files changed, 43 insertions, 29 deletions
diff --git a/sysutils/node_exporter/Makefile b/sysutils/node_exporter/Makefile
index fcfbbff44b2e..164dbd636570 100644
--- a/sysutils/node_exporter/Makefile
+++ b/sysutils/node_exporter/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= node_exporter
-PORTVERSION= 0.18.1
+PORTVERSION= 1.0.1
DISTVERSIONPREFIX=v
CATEGORIES= sysutils
-MAINTAINER= ports@ecadlabs.com
+MAINTAINER= dor.bsd@xm0.uk
COMMENT= Prometheus exporter for machine metrics
LICENSE= APACHE20
@@ -40,7 +40,7 @@ LD_FLAG_STRING= -s \
${LD_FLAG_X_PREFIX}.BuildUser=${BUILD_USER}
GO_BUILDFLAGS= -v -ldflags "${LD_FLAG_STRING}"
-OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE= DOCS
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
@@ -48,10 +48,6 @@ post-install-DOCS-on:
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
-post-install-EXAMPLES-on:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/text_collector_examples
- cd ${WRKSRC} && ${COPYTREE_SHARE} ./text_collector_examples ${STAGEDIR}${EXAMPLESDIR}
-
# TestFileDescriptorLeak is being skipped at the moment because procfs(5) is
# not properly detected.
pre-test:
diff --git a/sysutils/node_exporter/distinfo b/sysutils/node_exporter/distinfo
index 9c06b8a9b122..5f033f78ba35 100644
--- a/sysutils/node_exporter/distinfo
+++ b/sysutils/node_exporter/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1560802738
-SHA256 (prometheus-node_exporter-v0.18.1_GH0.tar.gz) = 9ddf187c462f2681ab4516410ada0e6f0f03097db6986686795559ea71a07694
-SIZE (prometheus-node_exporter-v0.18.1_GH0.tar.gz) = 2110072
+TIMESTAMP = 1592327241
+SHA256 (prometheus-node_exporter-v1.0.1_GH0.tar.gz) = a841bf3e236376840be9e1d8e6c4a38196be6f3957b0982d1c7970a5e416b0ad
+SIZE (prometheus-node_exporter-v1.0.1_GH0.tar.gz) = 2792033
diff --git a/sysutils/node_exporter/files/node_exporter.in b/sysutils/node_exporter/files/node_exporter.in
index 7cf841da5d46..b6e452dd3780 100644
--- a/sysutils/node_exporter/files/node_exporter.in
+++ b/sysutils/node_exporter/files/node_exporter.in
@@ -38,7 +38,7 @@ load_rc_config $name
pidfile=/var/run/node_exporter.pid
command="/usr/sbin/daemon"
procname="%%PREFIX%%/bin/node_exporter"
-command_args="-p ${pidfile} -T ${name} \
+command_args="-f -p ${pidfile} -T ${name} \
/usr/bin/env ${procname} \
--web.listen-address=${node_exporter_listen_address} \
--collector.textfile.directory=${node_exporter_textfile_dir} \
diff --git a/sysutils/node_exporter/pkg-message b/sysutils/node_exporter/pkg-message
index a46508a954f3..2cbb956d42a1 100644
--- a/sysutils/node_exporter/pkg-message
+++ b/sysutils/node_exporter/pkg-message
@@ -1,5 +1,27 @@
[
-{ type: install
+{
+ type: upgrade
+ message: <<EOM
+Text collector examples have been moved to a new repository at
+https://github.com/prometheus-community/node-exporter-textfile-collector-scripts.
+
+The netdev collector CLI argument `--collector.netdev.ignored-devices` was
+renamed to `--collector.netdev.device-blacklist`.
+
+Additional label `mountaddr` added to NFS device metrics to distinguish mounts
+from the same URL, but different IP addresses.
+
+Metrics `node_cpu_scaling_frequency_min_hrts` and
+`node_cpu_scaling_frequency_max_hrts` of the cpufreq collector were renamed to
+`node_cpu_scaling_frequency_min_hertz` and
+`node_cpu_scaling_frequency_max_hertz`.
+
+Collectors that are enabled, but are unable to find data to collect, now return
+`0` for `node_scrape_collector_success`.
+EOM
+}
+{
+ type: install
message: <<EOM
If upgrading from a version of node_exporter <0.15.0 you'll need to update any
custom command line flags that you may have set as it now requires a
diff --git a/sysutils/node_exporter/pkg-plist b/sysutils/node_exporter/pkg-plist
index 214da5be9af7..2c7fb385ffcf 100644
--- a/sysutils/node_exporter/pkg-plist
+++ b/sysutils/node_exporter/pkg-plist
@@ -6,20 +6,16 @@ bin/node_exporter
%%PORTDOCS%%%%DOCSDIR%%/example-16-compatibility-rules.yml
%%PORTDOCS%%%%DOCSDIR%%/example-17-compatibility-rules-new-to-old.yml
%%PORTDOCS%%%%DOCSDIR%%/example-17-compatibility-rules.yml
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/README.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/apt.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/btrfs_stats.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/deleted_libraries.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/directory-size.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/inotify-instances
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/ipmitool
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/md_info.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/md_info_detail.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/mellanox_hca_temp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/ntpd_metrics.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/nvme_metrics.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/pacman.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/smartmon.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/smartmon.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/storcli.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text_collector_examples/yum.sh
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/Makefile
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/README.md
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/alerts.jsonnet
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/alerts/alerts.libsonnet
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/config.libsonnet
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/dashboards.jsonnet
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/dashboards/dashboards.libsonnet
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/dashboards/node.libsonnet
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/dashboards/use.libsonnet
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/jsonnetfile.json
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/mixin.libsonnet
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/rules.jsonnet
+%%PORTDOCS%%%%DOCSDIR%%/node-mixin/rules/rules.libsonnet