aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nomad-pot-driver/Makefile
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2019-09-23 21:32:44 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2019-09-23 21:32:44 +0000
commit6a7960997e5f57e9b1f1f2c817082fcfafcce962 (patch)
tree2ea42e7d45cb2cc4f7af49fc4d04a8ba50d71842 /sysutils/nomad-pot-driver/Makefile
parent84c1354aaba7677ddd9b7509aea756a26b2d39b6 (diff)
downloadports-6a7960997e5f57e9b1f1f2c817082fcfafcce962.tar.gz
ports-6a7960997e5f57e9b1f1f2c817082fcfafcce962.zip
Notes
Diffstat (limited to 'sysutils/nomad-pot-driver/Makefile')
-rw-r--r--sysutils/nomad-pot-driver/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/nomad-pot-driver/Makefile b/sysutils/nomad-pot-driver/Makefile
new file mode 100644
index 000000000000..be820f6e85ca
--- /dev/null
+++ b/sysutils/nomad-pot-driver/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= nomad-pot-driver
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2
+DISTVERSIONSUFFIX= -9-g5b02965
+CATEGORIES= sysutils
+
+MAINTAINER= pizzamig@FreeBSD.org
+COMMENT= Nomad driver to support pot jails
+
+LICENSE= MPL20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= pot:sysutils/pot \
+ nomad:sysutils/nomad
+
+USES= compiler go
+USE_GITHUB= yes
+GH_ACCOUNT= trivago
+GH_SUBDIR= src/github.com/trivago/nomad-pot-driver
+
+PLIST_FILES= libexec/nomad/plugins/nomad-pot-driver
+SUB_FILES= pkg-message
+
+do-build:
+ @cd ${WRKSRC}/src/github.com/trivago/nomad-pot-driver && \
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -v -x \
+ -o bin/nomad-pot-driver
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nomad/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/github.com/trivago/nomad-pot-driver/bin/nomad-pot-driver ${STAGEDIR}${PREFIX}/libexec/nomad/plugins
+
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang
+BUILD_ENV= CC=clang
+.endif
+
+.include <bsd.port.post.mk>