aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ntfsprogs/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-08-13 03:00:56 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-08-13 03:00:56 +0000
commitcf12848ad4376355947a3bbfde6c8e5e8ed27149 (patch)
tree98208cd6705a8e0b6820f9f8d69fa663aa3c2a9b /sysutils/ntfsprogs/Makefile
parentb4354399494ed241cc599cd08fdb23d9b60e4e44 (diff)
Notes
Diffstat (limited to 'sysutils/ntfsprogs/Makefile')
-rw-r--r--sysutils/ntfsprogs/Makefile85
1 files changed, 33 insertions, 52 deletions
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
index 68b885127deb..e4644b9679da 100644
--- a/sysutils/ntfsprogs/Makefile
+++ b/sysutils/ntfsprogs/Makefile
@@ -6,66 +6,38 @@
#
PORTNAME= ntfsprogs
-PORTVERSION= 1.13.1
-PORTREVISION= 5
+PORTVERSION= 2.0.0
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= linux-ntfs
MAINTAINER= farrokhi@FreeBSD.org
COMMENT= Utilities and library to manipulate NTFS partitions
-WANT_GNOME= yes
+BUILD_DEPENDS= fusefs-libs>2.5:${PORTSDIR}/sysutils/fusefs-libs
+
+USE_GNOME= pkgconfig
+USE_BZIP2= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-transform-name=""
-CONFIGURE_ENV= PKG_CONFIG=${LOCALBASE}/bin/pkg-config \
- CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-OPTIONS= FUSE "Compile with Fuse interface" off \
- GNOMEVFS2 "Install GnomeVFS 2.0 libntfs interface" off \
- LOCK "Lock the device when mounting (avoids access)" off \
- UBLIO "Enable user space cache for improved speed" on
+OPTIONS= GNOMEVFS2 "Install GnomeVFS 2.0 libntfs interface" off \
+ LOCK "Lock the device when mounting (avoids access)" on \
+ UBLIO "Enable user space cache for improved speed" on \
+ UUID "Generate DCE compliant UUIDs" off
-MAN8= libntfs-gnomevfs.8 \
- mkntfs.8 \
- ntfscat.8 \
- ntfsclone.8 \
- ntfscluster.8 \
- ntfscmp.8 \
- ntfscp.8 \
- ntfsfix.8 \
- ntfsinfo.8 \
- ntfslabel.8 \
- ntfsls.8 \
- ntfsmount.8 \
- ntfsprogs.8 \
- ntfsresize.8 \
- ntfsundelete.8
+MAN8= libntfs.8 libntfs-gnomevfs.8 mkntfs.8 \
+ ntfscat.8 ntfsclone.8 ntfscluster.8 ntfscmp.8 \
+ ntfscp.8 ntfsfix.8 ntfsinfo.8 ntfslabel.8 ntfsls.8 ntfsmount.8 \
+ ntfsprogs.8 ntfsresize.8 ntfsundelete.8
+MLINKS= ntfsmount.8 mount_ntfs-fuse.8
-MLINKS= mkntfs.8 mkfs.ntfs.8
+SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
-.if defined(WITH_FUSE) || defined(WITH_UBLIO)
-SUB_FILES+= pkg-message
-
-post-install:
- @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
-.endif
-
-.if defined(WITH_FUSE)
-CONFIGURE_ARGS+=--enable-fuse-module
-PLIST_SUB+= FUSE=""
-USE_GNOME+= pkgconfig
-BUILD_DEPENDS+= fusefs-libs>2.5:${PORTSDIR}/sysutils/fusefs-libs
-MLINKS+= ntfsmount.8 mount_ntfs-fuse.8
-.else
-CONFIGURE_ARGS+=--disable-fuse-module
-PLIST_SUB+= FUSE="@comment "
-.endif
-
.if defined(WITH_GNOMEVFS2)
CONFIGURE_ARGS+=--enable-gnome-vfs
USE_GNOME= gnomevfs2
@@ -79,6 +51,13 @@ PLIST_SUB+= GNOMEVFS2="@comment "
CFLAGS+= -DUSE_LOCK
.endif
+.if defined(WITH_UUID)
+LIB_DEPENDS+= uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
+CONFIGURE_ARGS+=--enable-uuid
+.else
+CONFIGURE_ARGS+=--disable-uuid
+.endif
+
.if defined(WITH_UBLIO)
LIB_DEPENDS+= ublio.1:${PORTSDIR}/devel/libublio
CFLAGS+= -DUSE_UBLIO
@@ -89,16 +68,18 @@ pre-everything::
@${ECHO_MSG}
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|$$(DESTDIR)/sbin|$$(DESTDIR)/${PREFIX}/sbin|' \
- ${WRKSRC}/ntfsprogs/Makefile.in
- @${REINPLACE_CMD} -e \
- 's|$$(libdir)/\(gnome-vfs-2.0/modules\)|${LOCALBASE}/lib/\1|; \
- s|$$(sysconfdir)/\(gnome-vfs-2.0/modules\)|${LOCALBASE}/etc/\1|' \
- ${WRKSRC}/libntfs/Makefile.in
.if defined(WITH_UBLIO)
+post-patch:
@${REINPLACE_CMD} -e 's|^libntfs_la_LIBADD =|& -lublio|' \
${WRKSRC}/libntfs/Makefile.in
.endif
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${DOCSDIR}
+.endif
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
.include <bsd.port.post.mk>