aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ntfsprogs/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-11-23 11:43:13 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-11-23 11:43:13 +0000
commit241f1cec6cb93b0196658dfb9d0f7c2618d1d37a (patch)
tree32ede448953cd90a760fb84236bc85499417bd13 /sysutils/ntfsprogs/Makefile
parent9bcbf968876bb3b1dbc721c5f11f13dcc74d62d5 (diff)
downloadports-241f1cec6cb93b0196658dfb9d0f7c2618d1d37a.tar.gz
ports-241f1cec6cb93b0196658dfb9d0f7c2618d1d37a.zip
Notes
Diffstat (limited to 'sysutils/ntfsprogs/Makefile')
-rw-r--r--sysutils/ntfsprogs/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
index 90ea4b641718..535778152581 100644
--- a/sysutils/ntfsprogs/Makefile
+++ b/sysutils/ntfsprogs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ntfsprogs
PORTVERSION= 1.12.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= linux-ntfs
@@ -24,7 +25,8 @@ USE_AUTOTOOLS= libtool:13:inc
CONFIGURE_ARGS= --program-transform-name=""
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-OPTIONS= GNOMEVFS2 "Install GnomeVFS 2.0 libntfs interface" off
+OPTIONS= GNOMEVFS2 "Install GnomeVFS 2.0 libntfs interface" off \
+ FUSE "Compile with Fuse interface" off
MAN8= libntfs-gnomevfs.8 \
mkntfs.8 \
@@ -46,11 +48,22 @@ MLINKS= mkntfs.8 mkfs.ntfs.8
.include <bsd.port.pre.mk>
.if defined(WITH_GNOMEVFS2)
+CONFIGURE_ARGS+=--enable-gnome-vfs
USE_GNOME= gnomevfs2
-PLIST_SUB= GNOMEVFS2=""
+PLIST_SUB+= GNOMEVFS2=""
.else
-CONFIGURE_ARGS= --disable-gnome-vfs
-PLIST_SUB= GNOMEVFS2="@comment "
+CONFIGURE_ARGS+=--disable-gnome-vfs
+PLIST_SUB+= GNOMEVFS2="@comment "
+.endif
+
+.if defined(WITH_FUSE)
+CONFIGURE_ARGS+=--enable-fuse-module
+PLIST_SUB+= FUSE=""
+LIB_DEPENDS+= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
+MLINKS+= ntfsmount.8 mount.ntfs-fuse.8
+.else
+CONFIGURE_ARGS+=--disable-fuse-module
+PLIST_SUB+= FUSE="@comment "
.endif
post-patch: