aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ntfsprogs/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-26 19:20:45 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-26 19:20:45 +0000
commit0597043bf655875c16e3280160a0ef6b69fe6cf8 (patch)
treee59b550575ea7e5e8e7838bc13c94568d1014266 /sysutils/ntfsprogs/Makefile
parenta06a4a8e8d160a28378a8dd5262e22963003b003 (diff)
downloadports-0597043bf655875c16e3280160a0ef6b69fe6cf8.tar.gz
ports-0597043bf655875c16e3280160a0ef6b69fe6cf8.zip
Notes
Diffstat (limited to 'sysutils/ntfsprogs/Makefile')
-rw-r--r--sysutils/ntfsprogs/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
index 5604b80b7d84..41890c299763 100644
--- a/sysutils/ntfsprogs/Makefile
+++ b/sysutils/ntfsprogs/Makefile
@@ -16,15 +16,15 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Utilities and library to manipulate NTFS partitions
GNU_CONFIGURE= yes
-USE_GCC= 3.4
+USE_GCC= 3.4+
USE_REINPLACE= yes
USE_GETOPT_LONG=yes
-USE_CONFIGURE= yes
+WANT_GNOME= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-OPTIONS= GNOMEVFS2 "Install Gnome-VFS-2.0 libntfs interface" off
+OPTIONS= GNOMEVFS2 "Install GnomeVFS 2.0 libntfs interface" off
MAN8= libntfs-gnomevfs.8 \
mkntfs.8 \
@@ -53,5 +53,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|^transform.*||' ${WRKSRC}/Makefile.in \
${WRKSRC}/libntfs/Makefile.in \
${WRKSRC}/ntfsprogs/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|$$(libdir)/\(gnome-vfs-2.0/modules\)|${X11BASE}/lib/\1|; \
+ s|$$(sysconfdir)/\(gnome-vfs-2.0/modules\)|${X11BASE}/etc/\1|' \
+ ${WRKSRC}/libntfs/Makefile.in
.include <bsd.port.post.mk>