aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ntfsprogs/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-10-11 15:49:57 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-10-11 15:49:57 +0000
commit14e13c4d0011a143018dbac202ce3753e20365ad (patch)
treeafcd2797676143aa5d33ec0e14ff0f10029e7044 /sysutils/ntfsprogs/Makefile
parent811ea76e55ef9d51b42d5d53c3ae9418ba66389c (diff)
downloadports-14e13c4d0011a143018dbac202ce3753e20365ad.tar.gz
ports-14e13c4d0011a143018dbac202ce3753e20365ad.zip
Notes
Diffstat (limited to 'sysutils/ntfsprogs/Makefile')
-rw-r--r--sysutils/ntfsprogs/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
index 3d3e09ec9216..f63078cd9c1b 100644
--- a/sysutils/ntfsprogs/Makefile
+++ b/sysutils/ntfsprogs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ntfsprogs
-PORTVERSION= 1.9.4
-PORTREVISION= 2
+PORTVERSION= 1.12.1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= linux-ntfs
@@ -21,7 +20,8 @@ USE_REINPLACE= yes
USE_GETOPT_LONG=yes
WANT_GNOME= yes
INSTALLS_SHLIB= yes
-
+USE_LIBTOOL_VER=15
+CONFIGURE_ARGS= --program-transform-name=""
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= GNOMEVFS2 "Install GnomeVFS 2.0 libntfs interface" off
@@ -31,14 +31,18 @@ MAN8= libntfs-gnomevfs.8 \
ntfscat.8 \
ntfsclone.8 \
ntfscluster.8 \
+ ntfscp.8 \
ntfsfix.8 \
ntfsinfo.8 \
ntfslabel.8 \
ntfsls.8 \
+ ntfsmount.8 \
ntfsprogs.8 \
ntfsresize.8 \
ntfsundelete.8
+MLINKS= mkntfs.8 mkfs.ntfs.8
+
.include <bsd.port.pre.mk>
.if defined(WITH_GNOMEVFS2)
@@ -50,9 +54,7 @@ PLIST_SUB= GNOMEVFS2="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|^transform.*||' ${WRKSRC}/Makefile.in \
- ${WRKSRC}/libntfs/Makefile.in \
- ${WRKSRC}/ntfsprogs/Makefile.in
+ @${REINPLACE_CMD} -e 's|/sbin/|${PREFIX}/sbin/|' ${WRKSRC}/ntfsprogs/Makefile.in
@${REINPLACE_CMD} -e \
's|$$(libdir)/\(gnome-vfs-2.0/modules\)|${X11BASE}/lib/\1|; \
s|$$(sysconfdir)/\(gnome-vfs-2.0/modules\)|${X11BASE}/etc/\1|' \