aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ntfsprogs
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-10-11 15:49:57 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-10-11 15:49:57 +0000
commit14e13c4d0011a143018dbac202ce3753e20365ad (patch)
treeafcd2797676143aa5d33ec0e14ff0f10029e7044 /sysutils/ntfsprogs
parent811ea76e55ef9d51b42d5d53c3ae9418ba66389c (diff)
downloadports-14e13c4d0011a143018dbac202ce3753e20365ad.tar.gz
ports-14e13c4d0011a143018dbac202ce3753e20365ad.zip
Notes
Diffstat (limited to 'sysutils/ntfsprogs')
-rw-r--r--sysutils/ntfsprogs/Makefile14
-rw-r--r--sysutils/ntfsprogs/distinfo4
-rw-r--r--sysutils/ntfsprogs/files/patch-512b_blocks15
-rw-r--r--sysutils/ntfsprogs/pkg-plist9
4 files changed, 25 insertions, 17 deletions
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
index 3d3e09ec9216..f63078cd9c1b 100644
--- a/sysutils/ntfsprogs/Makefile
+++ b/sysutils/ntfsprogs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ntfsprogs
-PORTVERSION= 1.9.4
-PORTREVISION= 2
+PORTVERSION= 1.12.1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= linux-ntfs
@@ -21,7 +20,8 @@ USE_REINPLACE= yes
USE_GETOPT_LONG=yes
WANT_GNOME= yes
INSTALLS_SHLIB= yes
-
+USE_LIBTOOL_VER=15
+CONFIGURE_ARGS= --program-transform-name=""
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= GNOMEVFS2 "Install GnomeVFS 2.0 libntfs interface" off
@@ -31,14 +31,18 @@ MAN8= libntfs-gnomevfs.8 \
ntfscat.8 \
ntfsclone.8 \
ntfscluster.8 \
+ ntfscp.8 \
ntfsfix.8 \
ntfsinfo.8 \
ntfslabel.8 \
ntfsls.8 \
+ ntfsmount.8 \
ntfsprogs.8 \
ntfsresize.8 \
ntfsundelete.8
+MLINKS= mkntfs.8 mkfs.ntfs.8
+
.include <bsd.port.pre.mk>
.if defined(WITH_GNOMEVFS2)
@@ -50,9 +54,7 @@ PLIST_SUB= GNOMEVFS2="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|^transform.*||' ${WRKSRC}/Makefile.in \
- ${WRKSRC}/libntfs/Makefile.in \
- ${WRKSRC}/ntfsprogs/Makefile.in
+ @${REINPLACE_CMD} -e 's|/sbin/|${PREFIX}/sbin/|' ${WRKSRC}/ntfsprogs/Makefile.in
@${REINPLACE_CMD} -e \
's|$$(libdir)/\(gnome-vfs-2.0/modules\)|${X11BASE}/lib/\1|; \
s|$$(sysconfdir)/\(gnome-vfs-2.0/modules\)|${X11BASE}/etc/\1|' \
diff --git a/sysutils/ntfsprogs/distinfo b/sysutils/ntfsprogs/distinfo
index f574e8e3293e..48d1118d0d03 100644
--- a/sysutils/ntfsprogs/distinfo
+++ b/sysutils/ntfsprogs/distinfo
@@ -1,2 +1,2 @@
-MD5 (ntfsprogs-1.9.4.tar.gz) = 6fb6465e75582fc70d50966a08dd3ec1
-SIZE (ntfsprogs-1.9.4.tar.gz) = 701154
+MD5 (ntfsprogs-1.12.1.tar.gz) = 607b86d45ab65cf9db2255669545006e
+SIZE (ntfsprogs-1.12.1.tar.gz) = 801124
diff --git a/sysutils/ntfsprogs/files/patch-512b_blocks b/sysutils/ntfsprogs/files/patch-512b_blocks
index 408254964fe8..e73f03a0f959 100644
--- a/sysutils/ntfsprogs/files/patch-512b_blocks
+++ b/sysutils/ntfsprogs/files/patch-512b_blocks
@@ -68,16 +68,17 @@
return 0;
return -1;
}
---- ntfsprogs/ntfsresize.c Sat Sep 4 13:16:32 2004
-+++ ntfsprogs/ntfsresize.c Tue Jul 12 01:15:30 2005
-@@ -1783,6 +1783,10 @@
+--- ntfsprogs/ntfsresize.c Fri Oct 7 23:57:31 2005
++++ ntfsprogs/ntfsresize.c Tue Oct 11 13:35:09 2005
+@@ -1971,6 +1971,11 @@
+ err_exit("Resident attribute in $Bitmap isn't supported!\n");
- nr_clusters = resize->new_volume_size;
- bm_bsize = nr_clusters_to_bitmap_byte_size(nr_clusters);
+ bm_bsize = nr_clusters_to_bitmap_byte_size(resize->new_volume_size);
+ if(bm_bsize % 512 != 0) {
-+ Dprintf("adjusted bm_bsize: %lld->%lld\n", bm_bsize, (bm_bsize + 511) / 512 * 512);
++ s64 old_bm_bsize = bm_bsize;
+ bm_bsize = (bm_bsize + 511) / 512 * 512;
++ Dprintf("adjusted bm_bsize: %lld->%lld\n", old_bm_bsize, bm_bsize);
+ }
nr_bm_clusters = rounded_up_division(bm_bsize, vol->cluster_size);
- if (!(tmp = (u8 *)realloc(resize->lcn_bitmap.bm, bm_bsize)))
+ if (resize->shrink) {
diff --git a/sysutils/ntfsprogs/pkg-plist b/sysutils/ntfsprogs/pkg-plist
index 92ebb1a25e0c..d9b1f30771ce 100644
--- a/sysutils/ntfsprogs/pkg-plist
+++ b/sysutils/ntfsprogs/pkg-plist
@@ -7,12 +7,14 @@ include/ntfs/attrib.h
include/ntfs/attrlist.h
include/ntfs/bitmap.h
include/ntfs/bootsect.h
+include/ntfs/collate.h
include/ntfs/compat.h
include/ntfs/compress.h
include/ntfs/debug.h
include/ntfs/device.h
include/ntfs/device_io.h
include/ntfs/dir.h
+include/ntfs/index.h
include/ntfs/endians.h
include/ntfs/gnome-vfs-method.h
include/ntfs/gnome-vfs-module.h
@@ -23,18 +25,21 @@ include/ntfs/list.h
include/ntfs/logfile.h
include/ntfs/mft.h
include/ntfs/mst.h
+include/ntfs/ntfstime.h
include/ntfs/runlist.h
include/ntfs/security.h
include/ntfs/support.h
include/ntfs/types.h
include/ntfs/unistr.h
+include/ntfs/version.h
include/ntfs/volume.h
lib/libntfs.a
-lib/libntfs.la
lib/libntfs.so
-lib/libntfs.so.6
+lib/libntfs.so.8
sbin/mkntfs
+sbin/mkfs.ntfs
sbin/ntfsclone
+sbin/ntfscp
sbin/ntfslabel
sbin/ntfsresize
sbin/ntfsundelete