aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nut/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-10-07 09:13:49 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-10-07 09:13:49 +0000
commite446c1f2f8dba40fc9840f5ddaa8c1a221e4d326 (patch)
tree78975f3cd6e8eb00afc54802d8658cb76b87bcee /sysutils/nut/Makefile
parentdadcf6bf663eb67dc69fd8507656a225af35af8c (diff)
downloadports-e446c1f2f8dba40fc9840f5ddaa8c1a221e4d326.tar.gz
ports-e446c1f2f8dba40fc9840f5ddaa8c1a221e4d326.zip
Notes
Diffstat (limited to 'sysutils/nut/Makefile')
-rw-r--r--sysutils/nut/Makefile131
1 files changed, 61 insertions, 70 deletions
diff --git a/sysutils/nut/Makefile b/sysutils/nut/Makefile
index ec0c486bbd16..c3dcd9404b9e 100644
--- a/sysutils/nut/Makefile
+++ b/sysutils/nut/Makefile
@@ -6,39 +6,27 @@
#
PORTNAME= nut
-PORTVERSION= 2.0.5
-PORTREVISION= 1
+PORTVERSION= 2.2.0
CATEGORIES= sysutils
-MASTER_SITES= http://eu1.networkupstools.org/source/${PORTVERSION:R}/ \
- http://us1.networkupstools.org/source/${PORTVERSION:R}/
+MASTER_SITES= http://www.networkupstools.org/source/${PORTVERSION:R}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= Joerg.Pulz@frm2.tum.de
-COMMENT?= Network UPS Tools
-
-SUBSYS?= base
-.if ${SUBSYS} != base
-PKGNAMESUFFIX= -${SUBSYS}
-.endif
+COMMENT= Network UPS Tools
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
- --localstatedir=${STATEDIR} \
- --datadir=${PREFIX}/etc/nut \
- --with-drvpath=${PREFIX}/libexec/nut \
- --with-statepath=${STATEDIR} \
- --with-altpidpath=${STATEDIR} \
- --with-pidpath=${STATEDIR} \
- --with-linux-hiddev=no \
- --with-user=${NUT_USER}
+USE_GMAKE= yes
NUT_USER?= uucp
-STATEDIR= /var/db/nut
+NUT_GROUP?= uucp
+STATEDIR?= /var/db/nut
-.include <bsd.port.pre.mk>
+OPTIONS= USB "USB support" on \
+ SNMP "SNMP support" on \
+ LIBUPSCLIENT "Include the libupsclient library" off \
+ CGI "Web CGI interface" off \
-.if ${SUBSYS} == base
USE_RC_SUBR= nut.sh nut_upsmon.sh nut_upslog.sh
SUB_LIST+= STATEDIR=${STATEDIR}
PLIST_SUB+= STATEDIR=${STATEDIR}
@@ -47,20 +35,31 @@ MAN5= ups.conf.5 upsd.conf.5 upsd.users.5 upsmon.conf.5 \
upssched.conf.5
MAN8= al175.8 apcsmart.8 bcmxcp.8 belkin.8 belkinunv.8 \
bestuferrups.8 bestups.8 bestfcom.8 cpsups.8 cyberpower.8 \
- dummy-ups.8 etapro.8 everups.8 fentonups.8 genericups.8 \
- ippon.8 isbmex.8 liebert.8 masterguard.8 megatec.8 metasys.8 \
- mge-shut.8 mge-utalk.8 mustek.8 nitram.8 nutupsdrv.8 oneac.8 \
- optiups.8 powercom.8 powerpanel.8 safenet.8 sms.8 solis.8 \
- tripplite.8 tripplitesu.8 upsc.8 upscmd.8 upscode2.8 upsd.8 \
- upsdrvctl.8 upslog.8 upsmon.8 upsrw.8 upssched.8 victronups.8
+ dummy-ups.8 etapro.8 everups.8 gamatronic.8 genericups.8 \
+ isbmex.8 liebert.8 masterguard.8 megatec.8 metasys.8 \
+ mge-shut.8 mge-utalk.8 nitram.8 nutupsdrv.8 oneac.8 optiups.8 \
+ powercom.8 powerpanel.8 rhino.8 safenet.8 solis.8 tripplite.8 \
+ tripplitesu.8 upsc.8 upscmd.8 upscode2.8 upsd.8 upsdrvctl.8 \
+ upslog.8 upsmon.8 upsrw.8 upssched.8 victronups.8
+
+PORTDOCS= *
-ALL_TARGET= all
-INSTALL_TARGET= install install-conf
+.include <bsd.port.pre.mk>
-.if defined(WITH_NUT_CGI)
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
+ --program-transform-name="" \
+ --localstatedir=${STATEDIR} \
+ --datadir=${PREFIX}/etc/nut \
+ --with-drvpath=${PREFIX}/libexec/nut \
+ --with-statepath=${STATEDIR} \
+ --with-altpidpath=${STATEDIR} \
+ --with-pidpath=${STATEDIR} \
+ --with-linux-hiddev=no \
+ --with-user=${NUT_USER} \
+ --with-group=${NUT_GROUP}
+
+.if defined(WITH_CGI)
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
-ALL_TARGET+= cgi
-INSTALL_TARGET+=install-cgi install-cgi-conf
MAN5+= hosts.conf.5 upsset.conf.5 upsstats.html.5
MAN8+= upsset.cgi.8 upsstats.cgi.8 upsimage.cgi.8
.if !exists(${PREFIX}/www) && exists(${PREFIX}/share/apache)
@@ -74,58 +73,52 @@ CONFIGURE_ARGS+= --with-cgi --with-cgipath=${PREFIX}/${CGIDIR}/nut \
--with-htmlpath=${PREFIX}/${WWWDIR}/nut \
--with-gd-includes=-I${PREFIX}/include \
--with-gd-libs="-L${PREFIX}/lib -lgd"
-PLIST_SUB+= WWWFILES="${WWWDIR}/nut/"
-PLIST_SUB+= WWWDIRRM="@dirrm ${WWWDIR}/nut"
-PLIST_SUB+= CGIFILES="${CGIDIR}/nut/"
-PLIST_SUB+= CGIDIRRM="@dirrm ${CGIDIR}/nut"
-PLIST_SUB+= CGIETC="etc/nut/"
+PLIST_SUB+= NUT_CGI=""
+PLIST_SUB+= WWWDIR="${WWWDIR}"
+PLIST_SUB+= CGIDIR="${CGIDIR}"
+PLIST_SUB+= CGIETCDIR="etc/nut/"
.else
-PLIST_SUB+= WWWFILES="@comment "
-PLIST_SUB+= WWWDIRRM="@comment "
-PLIST_SUB+= CGIFILES="@comment "
-PLIST_SUB+= CGIDIRRM="@comment "
-PLIST_SUB+= CGIETC="@comment "
-.endif
+CONFIGURE_ARGS+= --without-cgi
+PLIST_SUB+= NUT_CGI="@comment "
.endif
-.if ${SUBSYS} == usb
+.if !defined(WITHOUT_USB)
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-ALL_TARGET= usb
-INSTALL_TARGET= install-usb
-
-MAN8= bcmxcp_usb.8 newhidups.8 tripplite_usb.8
+CONFIGURE_ARGS+= --with-usb=auto
+MAN8+= bcmxcp_usb.8 megatec_usb.8 tripplite_usb.8 usbhid-ups.8
+PLIST_SUB+= NUT_USB=""
+.else
+CONFIGURE_ARGS+= --without-usb
+PLIST_SUB+= NUT_USB="@comment "
.endif
-.if ${SUBSYS} == snmp
+.if !defined(WITHOUT_SNMP)
LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
-ALL_TARGET= snmp
-INSTALL_TARGET= install-snmp
-
-MAN8= snmp-ups.8
+CONFIGURE_ARGS+= --with-snmp
+MAN8+= snmp-ups.8
+PLIST_SUB+= NUT_SNMP=""
+.else
+CONFIGURE_ARGS+= --without-snmp
+PLIST_SUB+= NUT_SNMP="@comment "
.endif
-.if ${SUBSYS} == libupsclient
-CONFIGURE_ARGS+= --enable-pkg-config \
+.if defined(WITH_LIBUPSCLIENT)
+CONFIGURE_ARGS+= --with-lib --enable-pkg-config \
--with-pkgconfig-dir=${PREFIX}/libdata/pkgconfig
-ALL_TARGET= lib
-INSTALL_TARGET= install-lib
-MAN3= upscli_connect.3 upscli_disconnect.3 upscli_readline.3 \
+MAN3+= upscli_connect.3 upscli_disconnect.3 upscli_readline.3 \
upscli_sendline.3 upscli_splitname.3 upscli_strerror.3
-post-patch:
- @${REINPLACE_CMD} -e "s#@PKG_CFG_DIR@#${PREFIX}/libdata/pkgconfig#g" \
- ${WRKSRC}/lib/Makefile.in
+PLIST_SUB+= NUT_LIB=""
+.else
+CONFIGURE_ARGS+= --without-lib
+PLIST_SUB+= NUT_LIB="@comment "
.endif
-.if ${SUBSYS} == base
pre-install:
-.if !defined(WITH_NUT_CGI) && !defined(BATCH) && !defined(PACKAGE_BUILDING)
- @${ECHO_MSG} "Type \"make -DWITH_NUT_CGI\" if you want to build CGI scripts."
-.endif
@${MKDIR} ${PREFIX}/libexec/nut
@${MKDIR} ${STATEDIR}
- @${CHOWN} ${NUT_USER}:wheel ${STATEDIR}
+ @${CHOWN} ${NUT_USER}:${NUT_GROUP} ${STATEDIR}
@${CHMOD} 0750 ${STATEDIR}
.if !defined(NOPORTDOCS)
@@ -134,11 +127,9 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/docs/cables/*.txt ${DOCSDIR}/cables
${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/FAQ ${DOCSDIR}
-.for file in ChangeLog CREDITS INSTALL NEWS README UPGRADING
+.for file in AUTHORS COPYING ChangeLog INSTALL MAINTAINERS NEWS README UPGRADING
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
-.endif
-
.include <bsd.port.post.mk>