aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nut/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2018-10-24 07:17:08 +0000
committerCy Schubert <cy@FreeBSD.org>2018-10-24 07:17:08 +0000
commit350fba28e97337d37dd6035de2ec8171f294cd60 (patch)
treec6cc6b848221e5153d52ac127d8950a6c9a938f0 /sysutils/nut/Makefile
parent9205d5dbc7f8ea97b348ffe393ba0d9f4acf6921 (diff)
Notes
Diffstat (limited to 'sysutils/nut/Makefile')
-rw-r--r--sysutils/nut/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/sysutils/nut/Makefile b/sysutils/nut/Makefile
index 9d8d9c997dfa..1e92544f9ec6 100644
--- a/sysutils/nut/Makefile
+++ b/sysutils/nut/Makefile
@@ -22,10 +22,11 @@ STATEDIR?= /var/db/nut
PLIST_SUB+= NUT_USER=${NUT_USER}
PLIST_SUB+= NUT_GROUP=${NUT_GROUP}
-OPTIONS_DEFAULT=SERIAL USB SNMP NEON IPMI_OFF
-OPTIONS_DEFINE= SERIAL USB SNMP NEON PDU CGI BASH AVAHI OPENSSL DOCS
-OPTIONS_SINGLE= IPMI
+OPTIONS_DEFAULT=SERIAL USB SNMP NEON IPMI_OFF SSL_OFF
+OPTIONS_DEFINE= SERIAL USB SNMP NEON PDU CGI BASH AVAHI DOCS
+OPTIONS_SINGLE= IPMI SSL
OPTIONS_SINGLE_IPMI= IPMI_OFF IPMIPSU FREEIPMI
+OPTIONS_SINGLE_SSL= SSL_OFF OPENSSL NSS
SERIAL_DESC= SERIAL support
USB_DESC= USB support
@@ -38,6 +39,7 @@ AVAHI_DESC= Avahi support
IPMI_OFF_DESC= No IPMI support
FREEIPMI_DESC= freeipmi support
IPMIPSU_DESC= Use nut-ipmipsu support (experimental)
+SSL_OFF_DESC= No SSL support
USE_RC_SUBR= nut nut_upsmon nut_upslog
SUB_LIST+= STATEDIR=${STATEDIR}
@@ -160,6 +162,9 @@ PLIST_SUB+= NUT_IPMIPSU="@comment "
.if ${PORT_OPTIONS:MOPENSSL}
USES+= ssl
CONFIGURE_ARGS+= --with-openssl
+.elif ${PORT_OPTIONS:MNSS}
+LIB_DEPENDS= libnss3.so:security/nss
+CONFIGURE_ARGS+= --with-nss
.else
CONFIGURE_ARGS+= --without-openssl --without-ssl
.endif