aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nut22/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2001-10-07 23:01:18 +0000
committerDoug Barton <dougb@FreeBSD.org>2001-10-07 23:01:18 +0000
commit276d9b8ab8e7dc4e3ae4a78fbbd2c952241bcf12 (patch)
tree18810fdddafe5aa8d2a083fdb0a17d06473ab5fc /sysutils/nut22/Makefile
parent258473fcaa65d21e872c4e3ffdaff66144bf48c2 (diff)
* Update to 0.45.1, which as numerous new features, new UPS', and
many bugfixes. Check out http://www.exploits.org/nut/release/new-0.45.1.txt for more details. Highlights include experimental USB support, and the various programs dropping more privileges after startup. * Clean up the Makefile a little by grouping more of the CGI-dependent stuff together. Improve the pkg-plist in this regard as well. Make a directory and install a conf file sample that the software Makefile's are missing for some reason. * Make the cgi directory depend on one of the previously discussed plans to use PREFIX/www/cgi-bin if it exists already, and PREFIX/share/apache if not.
Notes
Notes: svn path=/head/; revision=48541
Diffstat (limited to 'sysutils/nut22/Makefile')
-rw-r--r--sysutils/nut22/Makefile45
1 files changed, 25 insertions, 20 deletions
diff --git a/sysutils/nut22/Makefile b/sysutils/nut22/Makefile
index 1f0b039155b8..dcc9633b64f5 100644
--- a/sysutils/nut22/Makefile
+++ b/sysutils/nut22/Makefile
@@ -6,34 +6,35 @@
#
PORTNAME= nut
-PORTVERSION= 0.45.0
+PORTVERSION= 0.45.1
CATEGORIES= sysutils
MASTER_SITES= http://www.exploits.org/nut/release/
MAINTAINER= DougB@FreeBSD.org
-.if defined(CGI)
-LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
-.endif
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
- --with-cgipath=${PREFIX}/share/nut/cgi \
--with-modelpath=${PREFIX}/libexec/nut \
--with-statepath=/var/db
-MAN8= powercom.8 apcsmart.8
+MAN8= apcsmart.8 powercom.8
ALL_TARGET= all
-NDOCDIR= ${PREFIX}/share/doc/nut
-
.if defined(CGI)
-NCGIDIR= ${PREFIX}/share/nut/cgi
+LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+.if !exists(${PREFIX}/www) && exists(${PREFIX}/share/apache)
+CGIDIR?= share/apache/cgi-bin
+.else
+CGIDIR?= www/cgi-bin
+.endif
+CONFIGURE_ARGS+=--with-cgipath=${PREFIX}/${CGIDIR}/nut
ALL_TARGET+= cgi
-PLIST_SUB+= CGIFILES=""
+PLIST_SUB+= CGIFILES="${CGIDIR}/nut/"
+PLIST_SUB+= CGIDIRRM="@dirrm ${CGIDIR}/nut"
.else
PLIST_SUB+= CGIFILES="@comment "
+PLIST_SUB+= CGIDIRRM="@comment "
.endif
pre-fetch:
@@ -41,28 +42,32 @@ pre-fetch:
@${ECHO_MSG} "Type \"make CGI=yes\" if you want to build CGI scripts."
.endif
+pre-install:
+ @${MKDIR} ${PREFIX}/libexec/nut
+
+NDOCDIR= ${PREFIX}/share/doc/nut
+
post-install:
@${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" \
${WRKSRC}/scripts/FreeBSD/upsd.sh.sample \
>${PREFIX}/etc/rc.d/nut.sh.sample
@${CHMOD} 0755 ${PREFIX}/etc/rc.d/nut.sh.sample
+ ${INSTALL_DATA} ${WRKSRC}/conf/ups.conf \
+ ${PREFIX}/etc/nut/ups.conf.sample
.if !defined(NOPORTDOCS)
- @if ! [ -d ${NDOCDIR} ]; then ${MKDIR} ${NDOCDIR}; fi
- @if ! [ -d ${NDOCDIR}/cables ]; then ${MKDIR} ${NDOCDIR}/cables; fi
+ @${MKDIR} ${NDOCDIR}/cables
${INSTALL_DATA} ${WRKSRC}/docs/cables/*.txt ${NDOCDIR}/cables
${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${NDOCDIR}
${INSTALL_DATA} ${WRKSRC}/docs/FAQ ${NDOCDIR}
${INSTALL_DATA} ${WRKSRC}/docs/Changes.trust ${NDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${NDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGES ${NDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${NDOCDIR}
${INSTALL_DATA} ${WRKSRC}/INSTALL ${NDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${NDOCDIR}
.endif
.if defined(CGI)
- @if ! [ -d ${NCGIDIR} ]; then ${MKDIR} ${NCGIDIR}; fi
- ${INSTALL_DATA} ${WRKSRC}/clients/*.cgi ${NCGIDIR}
- @${ECHO_MSG} "Look in ${NCGIDIR} for cgi scripts."
-.endif
-.if !defined(NOPORTDOCS)
- @${ECHO_MSG} "Look in ${NDOCDIR} for documentation."
+ @${MKDIR} ${PREFIX}/${CGIDIR}/nut
+ ${INSTALL_DATA} ${WRKSRC}/clients/*.cgi ${PREFIX}/${CGIDIR}/nut
.endif
.include <bsd.port.mk>