aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nut
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-10-07 09:13:49 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-10-07 09:13:49 +0000
commite446c1f2f8dba40fc9840f5ddaa8c1a221e4d326 (patch)
tree78975f3cd6e8eb00afc54802d8658cb76b87bcee /sysutils/nut
parentdadcf6bf663eb67dc69fd8507656a225af35af8c (diff)
downloadports-e446c1f2f8dba40fc9840f5ddaa8c1a221e4d326.tar.gz
ports-e446c1f2f8dba40fc9840f5ddaa8c1a221e4d326.zip
Notes
Diffstat (limited to 'sysutils/nut')
-rw-r--r--sysutils/nut/Makefile131
-rw-r--r--sysutils/nut/distinfo12
-rw-r--r--sysutils/nut/files/patch-Makefile.in33
-rw-r--r--sysutils/nut/files/patch-clients-Makefile.in11
-rw-r--r--sysutils/nut/files/patch-data-html-Makefile.in20
-rw-r--r--sysutils/nut/files/patch-drivers_Makefile.in11
-rw-r--r--sysutils/nut/files/patch-include-Makefile.in11
-rw-r--r--sysutils/nut/pkg-plist92
8 files changed, 138 insertions, 183 deletions
diff --git a/sysutils/nut/Makefile b/sysutils/nut/Makefile
index ec0c486bbd16..c3dcd9404b9e 100644
--- a/sysutils/nut/Makefile
+++ b/sysutils/nut/Makefile
@@ -6,39 +6,27 @@
#
PORTNAME= nut
-PORTVERSION= 2.0.5
-PORTREVISION= 1
+PORTVERSION= 2.2.0
CATEGORIES= sysutils
-MASTER_SITES= http://eu1.networkupstools.org/source/${PORTVERSION:R}/ \
- http://us1.networkupstools.org/source/${PORTVERSION:R}/
+MASTER_SITES= http://www.networkupstools.org/source/${PORTVERSION:R}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= Joerg.Pulz@frm2.tum.de
-COMMENT?= Network UPS Tools
-
-SUBSYS?= base
-.if ${SUBSYS} != base
-PKGNAMESUFFIX= -${SUBSYS}
-.endif
+COMMENT= Network UPS Tools
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
- --localstatedir=${STATEDIR} \
- --datadir=${PREFIX}/etc/nut \
- --with-drvpath=${PREFIX}/libexec/nut \
- --with-statepath=${STATEDIR} \
- --with-altpidpath=${STATEDIR} \
- --with-pidpath=${STATEDIR} \
- --with-linux-hiddev=no \
- --with-user=${NUT_USER}
+USE_GMAKE= yes
NUT_USER?= uucp
-STATEDIR= /var/db/nut
+NUT_GROUP?= uucp
+STATEDIR?= /var/db/nut
-.include <bsd.port.pre.mk>
+OPTIONS= USB "USB support" on \
+ SNMP "SNMP support" on \
+ LIBUPSCLIENT "Include the libupsclient library" off \
+ CGI "Web CGI interface" off \
-.if ${SUBSYS} == base
USE_RC_SUBR= nut.sh nut_upsmon.sh nut_upslog.sh
SUB_LIST+= STATEDIR=${STATEDIR}
PLIST_SUB+= STATEDIR=${STATEDIR}
@@ -47,20 +35,31 @@ MAN5= ups.conf.5 upsd.conf.5 upsd.users.5 upsmon.conf.5 \
upssched.conf.5
MAN8= al175.8 apcsmart.8 bcmxcp.8 belkin.8 belkinunv.8 \
bestuferrups.8 bestups.8 bestfcom.8 cpsups.8 cyberpower.8 \
- dummy-ups.8 etapro.8 everups.8 fentonups.8 genericups.8 \
- ippon.8 isbmex.8 liebert.8 masterguard.8 megatec.8 metasys.8 \
- mge-shut.8 mge-utalk.8 mustek.8 nitram.8 nutupsdrv.8 oneac.8 \
- optiups.8 powercom.8 powerpanel.8 safenet.8 sms.8 solis.8 \
- tripplite.8 tripplitesu.8 upsc.8 upscmd.8 upscode2.8 upsd.8 \
- upsdrvctl.8 upslog.8 upsmon.8 upsrw.8 upssched.8 victronups.8
+ dummy-ups.8 etapro.8 everups.8 gamatronic.8 genericups.8 \
+ isbmex.8 liebert.8 masterguard.8 megatec.8 metasys.8 \
+ mge-shut.8 mge-utalk.8 nitram.8 nutupsdrv.8 oneac.8 optiups.8 \
+ powercom.8 powerpanel.8 rhino.8 safenet.8 solis.8 tripplite.8 \
+ tripplitesu.8 upsc.8 upscmd.8 upscode2.8 upsd.8 upsdrvctl.8 \
+ upslog.8 upsmon.8 upsrw.8 upssched.8 victronups.8
+
+PORTDOCS= *
-ALL_TARGET= all
-INSTALL_TARGET= install install-conf
+.include <bsd.port.pre.mk>
-.if defined(WITH_NUT_CGI)
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
+ --program-transform-name="" \
+ --localstatedir=${STATEDIR} \
+ --datadir=${PREFIX}/etc/nut \
+ --with-drvpath=${PREFIX}/libexec/nut \
+ --with-statepath=${STATEDIR} \
+ --with-altpidpath=${STATEDIR} \
+ --with-pidpath=${STATEDIR} \
+ --with-linux-hiddev=no \
+ --with-user=${NUT_USER} \
+ --with-group=${NUT_GROUP}
+
+.if defined(WITH_CGI)
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
-ALL_TARGET+= cgi
-INSTALL_TARGET+=install-cgi install-cgi-conf
MAN5+= hosts.conf.5 upsset.conf.5 upsstats.html.5
MAN8+= upsset.cgi.8 upsstats.cgi.8 upsimage.cgi.8
.if !exists(${PREFIX}/www) && exists(${PREFIX}/share/apache)
@@ -74,58 +73,52 @@ CONFIGURE_ARGS+= --with-cgi --with-cgipath=${PREFIX}/${CGIDIR}/nut \
--with-htmlpath=${PREFIX}/${WWWDIR}/nut \
--with-gd-includes=-I${PREFIX}/include \
--with-gd-libs="-L${PREFIX}/lib -lgd"
-PLIST_SUB+= WWWFILES="${WWWDIR}/nut/"
-PLIST_SUB+= WWWDIRRM="@dirrm ${WWWDIR}/nut"
-PLIST_SUB+= CGIFILES="${CGIDIR}/nut/"
-PLIST_SUB+= CGIDIRRM="@dirrm ${CGIDIR}/nut"
-PLIST_SUB+= CGIETC="etc/nut/"
+PLIST_SUB+= NUT_CGI=""
+PLIST_SUB+= WWWDIR="${WWWDIR}"
+PLIST_SUB+= CGIDIR="${CGIDIR}"
+PLIST_SUB+= CGIETCDIR="etc/nut/"
.else
-PLIST_SUB+= WWWFILES="@comment "
-PLIST_SUB+= WWWDIRRM="@comment "
-PLIST_SUB+= CGIFILES="@comment "
-PLIST_SUB+= CGIDIRRM="@comment "
-PLIST_SUB+= CGIETC="@comment "
-.endif
+CONFIGURE_ARGS+= --without-cgi
+PLIST_SUB+= NUT_CGI="@comment "
.endif
-.if ${SUBSYS} == usb
+.if !defined(WITHOUT_USB)
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-ALL_TARGET= usb
-INSTALL_TARGET= install-usb
-
-MAN8= bcmxcp_usb.8 newhidups.8 tripplite_usb.8
+CONFIGURE_ARGS+= --with-usb=auto
+MAN8+= bcmxcp_usb.8 megatec_usb.8 tripplite_usb.8 usbhid-ups.8
+PLIST_SUB+= NUT_USB=""
+.else
+CONFIGURE_ARGS+= --without-usb
+PLIST_SUB+= NUT_USB="@comment "
.endif
-.if ${SUBSYS} == snmp
+.if !defined(WITHOUT_SNMP)
LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
-ALL_TARGET= snmp
-INSTALL_TARGET= install-snmp
-
-MAN8= snmp-ups.8
+CONFIGURE_ARGS+= --with-snmp
+MAN8+= snmp-ups.8
+PLIST_SUB+= NUT_SNMP=""
+.else
+CONFIGURE_ARGS+= --without-snmp
+PLIST_SUB+= NUT_SNMP="@comment "
.endif
-.if ${SUBSYS} == libupsclient
-CONFIGURE_ARGS+= --enable-pkg-config \
+.if defined(WITH_LIBUPSCLIENT)
+CONFIGURE_ARGS+= --with-lib --enable-pkg-config \
--with-pkgconfig-dir=${PREFIX}/libdata/pkgconfig
-ALL_TARGET= lib
-INSTALL_TARGET= install-lib
-MAN3= upscli_connect.3 upscli_disconnect.3 upscli_readline.3 \
+MAN3+= upscli_connect.3 upscli_disconnect.3 upscli_readline.3 \
upscli_sendline.3 upscli_splitname.3 upscli_strerror.3
-post-patch:
- @${REINPLACE_CMD} -e "s#@PKG_CFG_DIR@#${PREFIX}/libdata/pkgconfig#g" \
- ${WRKSRC}/lib/Makefile.in
+PLIST_SUB+= NUT_LIB=""
+.else
+CONFIGURE_ARGS+= --without-lib
+PLIST_SUB+= NUT_LIB="@comment "
.endif
-.if ${SUBSYS} == base
pre-install:
-.if !defined(WITH_NUT_CGI) && !defined(BATCH) && !defined(PACKAGE_BUILDING)
- @${ECHO_MSG} "Type \"make -DWITH_NUT_CGI\" if you want to build CGI scripts."
-.endif
@${MKDIR} ${PREFIX}/libexec/nut
@${MKDIR} ${STATEDIR}
- @${CHOWN} ${NUT_USER}:wheel ${STATEDIR}
+ @${CHOWN} ${NUT_USER}:${NUT_GROUP} ${STATEDIR}
@${CHMOD} 0750 ${STATEDIR}
.if !defined(NOPORTDOCS)
@@ -134,11 +127,9 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/docs/cables/*.txt ${DOCSDIR}/cables
${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/FAQ ${DOCSDIR}
-.for file in ChangeLog CREDITS INSTALL NEWS README UPGRADING
+.for file in AUTHORS COPYING ChangeLog INSTALL MAINTAINERS NEWS README UPGRADING
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
-.endif
-
.include <bsd.port.post.mk>
diff --git a/sysutils/nut/distinfo b/sysutils/nut/distinfo
index 75fc04d0f31e..ee34cf696f29 100644
--- a/sysutils/nut/distinfo
+++ b/sysutils/nut/distinfo
@@ -1,6 +1,6 @@
-MD5 (nut-2.0.5.tar.gz) = b08fde86191154bbcfda860f95a5dca2
-SHA256 (nut-2.0.5.tar.gz) = 5e1bfecfca528104db7025050c81258ee20620df7497ab5988ad461d951c8203
-SIZE (nut-2.0.5.tar.gz) = 809006
-MD5 (nut-2.0.5.tar.gz.sig) = 87e01f70e56e647af64c1a9324525f6c
-SHA256 (nut-2.0.5.tar.gz.sig) = e2307cde6369dd9d425758171cc5de36676b419d9d88b76012c9f0acc6ac657d
-SIZE (nut-2.0.5.tar.gz.sig) = 65
+MD5 (nut-2.2.0.tar.gz) = a3570515d80804051d4e7631e8a3eb12
+SHA256 (nut-2.2.0.tar.gz) = e670ff7b51a652fd61472aa5fa5a1ed4730b5411671068be456551ea46094120
+SIZE (nut-2.2.0.tar.gz) = 1173801
+MD5 (nut-2.2.0.tar.gz.sig) = b844a079cd7673f79d87197c189f23fe
+SHA256 (nut-2.2.0.tar.gz.sig) = 6b240886432e0e095c4bf6109a79f4bd1c67e53a14438fe885f7ffd7932e2169
+SIZE (nut-2.2.0.tar.gz.sig) = 65
diff --git a/sysutils/nut/files/patch-Makefile.in b/sysutils/nut/files/patch-Makefile.in
deleted file mode 100644
index 72832e15e229..000000000000
--- a/sysutils/nut/files/patch-Makefile.in
+++ /dev/null
@@ -1,33 +0,0 @@
---- Makefile.in.orig Mon Oct 10 04:12:51 2005
-+++ Makefile.in Thu Feb 23 19:44:12 2006
-@@ -90,6 +90,12 @@
- install-cgi-conf:
- @cd conf; $(MAKE) install-cgi-conf; cd ..;
-
-+lib: build-lib
-+
-+build-lib:
-+ @cd common ; $(MAKE) || exit 1; cd ..;
-+ @cd clients; $(MAKE) libupsclient.a || exit 1; cd ..;
-+
- install-lib:
- @cd clients; $(MAKE) install-lib; cd ..;
- @cd man; $(MAKE) install-lib-man; cd ..;
-@@ -98,6 +104,7 @@
- usb: build-usb
-
- build-usb:
-+ @cd common ; $(MAKE) || exit 1; cd ..;
- @cd drivers; $(MAKE) build-usb; cd ..;
-
- install-usb:
-@@ -107,7 +114,8 @@
- snmp: build-snmp
-
- build-snmp:
-- @cd drivers; $(MAKE) snmp-ups; cd ..;
-+ @cd common ; $(MAKE) || exit 1; cd ..;
-+ @cd drivers; $(MAKE) snmp-ups || exit 1; cd ..;
-
- install-snmp: snmp install-snmp-man install-snmp-mgr
-
diff --git a/sysutils/nut/files/patch-clients-Makefile.in b/sysutils/nut/files/patch-clients-Makefile.in
new file mode 100644
index 000000000000..a8fb0585387d
--- /dev/null
+++ b/sysutils/nut/files/patch-clients-Makefile.in
@@ -0,0 +1,11 @@
+--- clients/Makefile.in.orig 2007-07-05 15:21:22.000000000 +0200
++++ clients/Makefile.in 2007-08-28 15:25:39.000000000 +0200
+@@ -440,7 +440,7 @@
+ done
+ install-cgiexecPROGRAMS: $(cgiexec_PROGRAMS)
+ @$(NORMAL_INSTALL)
+- test -z "$(cgiexecdir)" || $(mkdir_p) "$(DESTDIR)$(cgiexecdir)"
++ test -z "$(cgiexec_PROGRAMS)" -o -z "$(cgiexecdir)" || $(mkdir_p) "$(DESTDIR)$(cgiexecdir)"
+ @list='$(cgiexec_PROGRAMS)'; for p in $$list; do \
+ p1=`echo $$p|sed 's/$(EXEEXT)$$//'`; \
+ if test -f $$p \
diff --git a/sysutils/nut/files/patch-data-html-Makefile.in b/sysutils/nut/files/patch-data-html-Makefile.in
new file mode 100644
index 000000000000..002733026fcf
--- /dev/null
+++ b/sysutils/nut/files/patch-data-html-Makefile.in
@@ -0,0 +1,20 @@
+--- data/html/Makefile.in.orig 2007-07-05 15:21:23.000000000 +0200
++++ data/html/Makefile.in 2007-08-28 15:25:08.000000000 +0200
+@@ -285,7 +285,7 @@
+ uninstall-info-am:
+ install-dist_htmlDATA: $(dist_html_DATA)
+ @$(NORMAL_INSTALL)
+- test -z "$(htmldir)" || $(mkdir_p) "$(DESTDIR)$(htmldir)"
++ test -z "$(dist_html_DATA)" -o -z "$(htmldir)" || $(mkdir_p) "$(DESTDIR)$(htmldir)"
+ @list='$(dist_html_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f=$(am__strip_dir) \
+@@ -302,7 +302,7 @@
+ done
+ install-nodist_htmlDATA: $(nodist_html_DATA)
+ @$(NORMAL_INSTALL)
+- test -z "$(htmldir)" || $(mkdir_p) "$(DESTDIR)$(htmldir)"
++ test -z "$(nodist_html_DATA)" -o -z "$(htmldir)" || $(mkdir_p) "$(DESTDIR)$(htmldir)"
+ @list='$(nodist_html_DATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f=$(am__strip_dir) \
diff --git a/sysutils/nut/files/patch-drivers_Makefile.in b/sysutils/nut/files/patch-drivers_Makefile.in
deleted file mode 100644
index 5ef287b7ee51..000000000000
--- a/sysutils/nut/files/patch-drivers_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- drivers/Makefile.in.orig Thu Feb 23 19:38:14 2006
-+++ drivers/Makefile.in Thu Feb 23 19:38:43 2006
-@@ -8,7 +8,7 @@
-
- # other definitions
- CC = @CC@
--CFLAGS = -I../include @CFLAGS@
-+CFLAGS = -I../include @CFLAGS@ @LIBUSB_CFLAGS@
- PROGS = bestups fentonups apcsmart everups belkin masterguard powercom \
- cyberpower tripplite victronups genericups mge-utalk bestuferrups \
- isbmex etapro liebert sms esupssmart tripplitesu blazer safenet \
diff --git a/sysutils/nut/files/patch-include-Makefile.in b/sysutils/nut/files/patch-include-Makefile.in
new file mode 100644
index 000000000000..ad0ffe555c98
--- /dev/null
+++ b/sysutils/nut/files/patch-include-Makefile.in
@@ -0,0 +1,11 @@
+--- include/Makefile.in.orig 2007-08-28 15:39:22.000000000 +0200
++++ include/Makefile.in 2007-08-28 15:36:52.000000000 +0200
+@@ -229,7 +229,7 @@
+ BUILT_SOURCES = nut_version.h
+ CLEANFILES = nut_version.h
+ SVNREV = $(shell svnversion -n $(top_srcdir) 2>/dev/null)
+-NUT_VERSION = $(shell if test "$(SVNREV)" = "exported"; then echo "$(PACKAGE_VERSION)"; else echo "$(PACKAGE_VERSION)-$(SVNREV)"; fi)
++NUT_VERSION = $(shell if test "$(SVNREV)" = "exported" -o -z "${SVNREV}"; then echo "$(PACKAGE_VERSION)"; else echo "$(PACKAGE_VERSION)-$(SVNREV)"; fi)
+ all: $(BUILT_SOURCES) config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+
diff --git a/sysutils/nut/pkg-plist b/sysutils/nut/pkg-plist
index ff9f544227ba..c9f2f25af901 100644
--- a/sysutils/nut/pkg-plist
+++ b/sysutils/nut/pkg-plist
@@ -4,10 +4,12 @@
@unexec %D/etc/rc.d/nut_upslog forcestop 2>/dev/null || true
@unexec %D/etc/rc.d/nut_upsmon forcestop 2>/dev/null || true
@unexec %D/etc/rc.d/nut forcestop 2>/dev/null || true
+%%NUT_LIB%%bin/libupsclient-config
bin/upsc
bin/upscmd
bin/upslog
bin/upsrw
+bin/upssched-cmd
etc/nut/cmdvartab
etc/nut/driver.list
etc/nut/ups.conf.sample
@@ -15,32 +17,34 @@ etc/nut/upsd.conf.sample
etc/nut/upsd.users.sample
etc/nut/upsmon.conf.sample
etc/nut/upssched.conf.sample
+%%NUT_LIB%%include/parseconf.h
+%%NUT_LIB%%include/upsclient.h
+%%NUT_LIB%%lib/libupsclient.a
libexec/nut/al175
libexec/nut/apcsmart
libexec/nut/bcmxcp
+%%NUT_USB%%libexec/nut/bcmxcp_usb
libexec/nut/belkin
libexec/nut/belkinunv
libexec/nut/bestfcom
libexec/nut/bestuferrups
libexec/nut/bestups
-libexec/nut/blazer
libexec/nut/cpsups
libexec/nut/cyberpower
-libexec/nut/esupssmart
+libexec/nut/dummy-ups
libexec/nut/etapro
libexec/nut/everups
-libexec/nut/fentonups
libexec/nut/gamatronic
libexec/nut/genericups
-libexec/nut/ippon
libexec/nut/isbmex
libexec/nut/liebert
libexec/nut/masterguard
libexec/nut/megatec
+%%NUT_USB%%libexec/nut/megatec_usb
libexec/nut/metasys
libexec/nut/mge-shut
libexec/nut/mge-utalk
-libexec/nut/mustek
+libexec/nut/newmge-shut
libexec/nut/nitram
libexec/nut/oneac
libexec/nut/optiups
@@ -48,73 +52,35 @@ libexec/nut/powercom
libexec/nut/powerpanel
libexec/nut/rhino
libexec/nut/safenet
-libexec/nut/sms
+%%NUT_SNMP%%libexec/nut/snmp-ups
+libexec/nut/skel
libexec/nut/solis
libexec/nut/tripplite
+%%NUT_USB%%libexec/nut/tripplite_usb
libexec/nut/tripplitesu
libexec/nut/upscode2
libexec/nut/upsdrvctl
+%%NUT_USB%%libexec/nut/usbhid-ups
libexec/nut/victronups
+%%NUT_LIB%%libdata/pkgconfig/libupsclient.pc
sbin/upsd
sbin/upsmon
sbin/upssched
-%%CGIFILES%%upsimage.cgi
-%%CGIFILES%%upsset.cgi
-%%CGIFILES%%upsstats.cgi
-%%CGIETC%%hosts.conf.sample
-%%CGIETC%%upsset.conf.sample
-%%CGIETC%%upsstats.html.sample
-%%CGIETC%%upsstats-single.html.sample
-%%WWWFILES%%bottom.html
-%%WWWFILES%%header.html
-%%WWWFILES%%index.html
-%%WWWFILES%%nut-banner.png
-%%PORTDOCS%%@exec mkdir %D/%%DOCSDIR%%
-%%PORTDOCS%%@exec mkdir %D/%%DOCSDIR%%/cables
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
-%%PORTDOCS%%%%DOCSDIR%%/acpi.txt
-%%PORTDOCS%%%%DOCSDIR%%/al175-vars.txt
-%%PORTDOCS%%%%DOCSDIR%%/big-servers.txt
-%%PORTDOCS%%%%DOCSDIR%%/cables/apc-rs500-serial.txt
-%%PORTDOCS%%%%DOCSDIR%%/cables/apc.txt
-%%PORTDOCS%%%%DOCSDIR%%/cables/ge-imv-victron.txt
-%%PORTDOCS%%%%DOCSDIR%%/cables/imv.txt
-%%PORTDOCS%%%%DOCSDIR%%/cables/mgeups.txt
-%%PORTDOCS%%%%DOCSDIR%%/cables/powerware.txt
-%%PORTDOCS%%%%DOCSDIR%%/cables/repotec.txt
-%%PORTDOCS%%%%DOCSDIR%%/cables/sms.txt
-%%PORTDOCS%%%%DOCSDIR%%/chroot.txt
-%%PORTDOCS%%%%DOCSDIR%%/commands.txt
-%%PORTDOCS%%%%DOCSDIR%%/config-files.txt
-%%PORTDOCS%%%%DOCSDIR%%/configure.txt
-%%PORTDOCS%%%%DOCSDIR%%/contact-closure.txt
-%%PORTDOCS%%%%DOCSDIR%%/data-room.txt
-%%PORTDOCS%%%%DOCSDIR%%/design.txt
-%%PORTDOCS%%%%DOCSDIR%%/developers.txt
-%%PORTDOCS%%%%DOCSDIR%%/ideas.txt
-%%PORTDOCS%%%%DOCSDIR%%/hid-subdrivers.txt
-%%PORTDOCS%%%%DOCSDIR%%/megatec.txt
-%%PORTDOCS%%%%DOCSDIR%%/new-drivers.txt
-%%PORTDOCS%%%%DOCSDIR%%/new-names.txt
-%%PORTDOCS%%%%DOCSDIR%%/osd-notify.txt
-%%PORTDOCS%%%%DOCSDIR%%/pager.txt
-%%PORTDOCS%%%%DOCSDIR%%/powersaving.txt
-%%PORTDOCS%%%%DOCSDIR%%/protocol.txt
-%%PORTDOCS%%%%DOCSDIR%%/shutdown.txt
-%%PORTDOCS%%%%DOCSDIR%%/snmp.txt
-%%PORTDOCS%%%%DOCSDIR%%/sock-protocol.txt
-%%PORTDOCS%%%%DOCSDIR%%/ssl.txt
-%%PORTDOCS%%%%DOCSDIR%%/upssched.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/cables
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%NUT_CGI%%%%CGIDIR%%/nut/upsimage.cgi
+%%NUT_CGI%%%%CGIDIR%%/nut/upsset.cgi
+%%NUT_CGI%%%%CGIDIR%%/nut/upsstats.cgi
+%%NUT_CGI%%%%CGIETCDIR%%/hosts.conf.sample
+%%NUT_CGI%%%%CGIETCDIR%%/upsset.conf.sample
+%%NUT_CGI%%%%CGIETCDIR%%/upsstats.html.sample
+%%NUT_CGI%%%%CGIETCDIR%%/upsstats-single.html.sample
+%%NUT_CGI%%%%WWWDIR%%/nut/bottom.html
+%%NUT_CGI%%%%WWWDIR%%/nut/header.html
+%%NUT_CGI%%%%WWWDIR%%/nut/index.html
+%%NUT_CGI%%%%WWWDIR%%/nut/nut-banner.png
@dirrmtry etc/nut
@dirrmtry libexec/nut
@dirrmtry %%STATEDIR%%
-%%CGIDIRRM%%
-%%WWWDIRRM%%
+%%NUT_CGI%%@dirrm %%CGIDIR%%/nut
+%%NUT_CGI%%@dirrmtry %%CGIDIR%%
+%%NUT_CGI%%@dirrm %%WWWDIR%%/nut
+%%NUT_CGI%%@dirrmtry %%WWWDIR%%