aboutsummaryrefslogtreecommitdiff
path: root/sysutils/openipmi
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 20:01:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 20:01:07 +0000
commit27d44119e7e106f32a4b4b25539a57a35cc68823 (patch)
tree8462df47de7a523e2debd710ebc0516911e33a43 /sysutils/openipmi
parentf3184698839707db08f51b1529956b01b49932cf (diff)
downloadports-27d44119e7e106f32a4b4b25539a57a35cc68823.tar.gz
ports-27d44119e7e106f32a4b4b25539a57a35cc68823.zip
Notes
Diffstat (limited to 'sysutils/openipmi')
-rw-r--r--sysutils/openipmi/Makefile53
1 files changed, 26 insertions, 27 deletions
diff --git a/sysutils/openipmi/Makefile b/sysutils/openipmi/Makefile
index 58ef215b108d..d90ec6cd260b 100644
--- a/sysutils/openipmi/Makefile
+++ b/sysutils/openipmi/Makefile
@@ -29,39 +29,42 @@ MAN1= ipmi_ui.1 openipmicmd.1 openipmigui.1 \
MAN7= ipmi_cmdlang.7 openipmi_conparms.7
MAN8= ipmilan.8
-OPTIONS= SSL "IPMI 2.0 RMCP+ encryption and authentication" On \
- SNMP "SNMP trap support for the sample programs" Off \
- PERL "Perl interface for OpenIPMI library" Off \
- PYTHON "Python interface for OpenIPMI library" Off \
- TCL "TCL interface for OpenIPMI library" Off \
- TKINTER "GUI for OpenIPMI, written in Python" Off \
- TRACE "Enable backtrace inspecting" Off \
- GDBM "Local SDR caching on startup" Off \
- GLIB12 "Simply OS handler for glib 1.2" Off \
- GLIB20 "Simply OS handler for glib 2.0" Off
+OPTIONS_DEFINE= SSL SNMP PERL PYTHON TCL TKINTER TRACE GDBM
+OPTIONS_RADIO= GLIB
+OPTIONS_RADIO_GLIB= GLIB12 GLIB20
+SSL_DESC= IPMI 2.0 RMCP+ encryption and authentication
+SNMP_DESC= SNMP trap support for the sample programs
+PERL_DESC= Perl interface for OpenIPMI library
+PYTHON_DESC= Python interface for OpenIPMI library
+TCL_DESC= TCL interface for OpenIPMI library
+TKINTER_DESC= GUI for OpenIPMI, written in Python
+TRACE_DESC= Enable backtrace inspecting
+GDBM_DESC= Local SDR caching on startup
+GLIB12_DESC= Simply OS handler for glib 1.2
+GLIB20_DESC= Simply OS handler for glib 2.0
.include <bsd.port.options.mk>
.if exists(${LOCALBASE}/lib/libgdbm.so.3)
-WITH_GDBM= yes
+PORT_OPTIONS+= GDBM
.endif
-.if defined(WITH_SNMP)
-WITH_SSL= yes
+.if ${PORT_OPTIONS:MSNMP}
+PORT_OPTIONS+= SSL
LIB_DEPENDS+= netsnmp:${PORTSDIR}/net-mgmt/net-snmp
CONFIGURE_ARGS+= --with-ucdsnmp=${LOCALBASE}
.else
CONFIGURE_ARGS+= --with-ucdsnmp=no
.endif
-.if defined(WITH_SSL)
+.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.else
CONFIGURE_ARGS+= --with-openssl=no
.endif
-.if defined(WITH_TKINTER)
+.if ${PORT_OPTIONS:MTKINTER}
WITH_TCL= yes
USE_PYTHON= yes
WITH_PYTHON= yes
@@ -74,7 +77,7 @@ CONFIGURE_ARGS+= --with-tkinter=no
PLIST_SUB+= TKINTER="@comment "
.endif
-.if defined(WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
WITH_SWIG= yes
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl
@@ -84,7 +87,7 @@ CONFIGURE_ARGS+= --with-perl=no
PLIST_SUB+= PERL="@comment "
.endif
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
WITH_SWIG= yes
USE_PYTHON= yes
CONFIGURE_ARGS+= --with-python
@@ -94,14 +97,14 @@ CONFIGURE_ARGS+= --with-python=no
PLIST_SUB+= PYTHON="@comment "
.endif
-.if defined(WITH_SWIG)
+.if ${PORT_OPTIONS:MSWIG}
BUILD_DEPENDS+= swig:${PORTSDIR}/devel/swig13
CONFIGURE_ARGS+= --with-swig
.else
CONFIGURE_ARGS+= --with-swig=no
.endif
-.if defined(WITH_TCL)
+.if ${PORT_OPTIONS:MTCL}
USE_TCL= 84
CONFIGURE_ARGS+= --with-tcl \
--with-tclcflags=-I${TCL_INCLUDEDIR} \
@@ -112,15 +115,15 @@ CONFIGURE_ARGS+= --with-tcl=no
PLIST_SUB+= TCL="@comment "
.endif
-.if defined(WITH_TRACE)
+.if ${PORT_OPTIONS:MTRACE}
LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
.endif
-.if defined(WITH_GDBM)
+.if ${PORT_OPTIONS:MGDBM}
LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
.endif
-.if defined(WITH_GLIB12)
+.if ${PORT_OPTIONS:MGLIB12}
USE_GNOME+= glib12
CONFIGURE_ARGS+= --with-glib12 --with-glibver=1.2
PLIST_SUB+= GLIB12=""
@@ -129,7 +132,7 @@ CONFIGURE_ARGS+= --with-glib12=no
PLIST_SUB+= GLIB12="@comment "
.endif
-.if defined(WITH_GLIB20)
+.if ${PORT_OPTIONS:MGLIB20}
USE_GNOME+= glib20
CONFIGURE_ARGS+= --with-glib --with-glibver=2.0
PLIST_SUB+= GLIB20=""
@@ -138,8 +141,4 @@ CONFIGURE_ARGS+= --with-glib=no
PLIST_SUB+= GLIB20="@comment "
.endif
-.if defined(WITH_GLIB12) && defined(WITH_GLIB20)
-IGNORE=selected mutually exclusive options: WITH_GLIB12 and WITH_GLIB20
-.endif
-
.include <bsd.port.mk>