aboutsummaryrefslogtreecommitdiff
path: root/sysutils/openipmi
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-04 10:22:56 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-04 10:22:56 +0000
commit1b47901e7935a938edfc1b13ba9812cac1ab76b8 (patch)
treed4e4620b837870bef2a4350f286606a54e0a6e07 /sysutils/openipmi
parentb8235ad399fed7c86264c0b7aaeace1f69f93dcf (diff)
downloadports-1b47901e7935a938edfc1b13ba9812cac1ab76b8.tar.gz
ports-1b47901e7935a938edfc1b13ba9812cac1ab76b8.zip
- Add a patch to support sensors for Sun Fire x64 systems
PR: ports/147287 Submitted by: Alex Deiter <alex.deiter AT gmail.com> (maintainer) Obtained from: OpenIPMI CVS Repositories
Notes
Notes: svn path=/head/; revision=258758
Diffstat (limited to 'sysutils/openipmi')
-rw-r--r--sysutils/openipmi/Makefile2
-rw-r--r--sysutils/openipmi/files/patch-lib-sensor.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/sysutils/openipmi/Makefile b/sysutils/openipmi/Makefile
index 620e9366bbc1..342acbbc73a2 100644
--- a/sysutils/openipmi/Makefile
+++ b/sysutils/openipmi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openipmi
PORTVERSION= 2.0.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/OpenIPMI%202.0%20Library/${PORTVERSION}
DISTNAME= OpenIPMI-${PORTVERSION}
diff --git a/sysutils/openipmi/files/patch-lib-sensor.c b/sysutils/openipmi/files/patch-lib-sensor.c
new file mode 100644
index 000000000000..484f2baaddc4
--- /dev/null
+++ b/sysutils/openipmi/files/patch-lib-sensor.c
@@ -0,0 +1,11 @@
+--- lib/sensor.c.orig 2010-05-28 18:51:20.949496519 +0400
++++ lib/sensor.c 2010-05-28 18:51:37.079705617 +0400
+@@ -1438,7 +1438,7 @@
+ s[p]->id_type = IPMI_ASCII_STR;
+ }
+
+- if (share_count) {
++ if (share_count > 1) {
+ /* Duplicate the sensor records for each instance. Go
+ backwards to avoid destroying the first one until we
+ finish the others. */