aboutsummaryrefslogtreecommitdiff
path: root/sysutils/openupsd
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-25 09:14:06 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-25 09:14:06 +0000
commitf8954066434d71bdbcf48584bd905ad1d13cd693 (patch)
tree7b665bfe0fc621f5e10532573c742e526e1336cf /sysutils/openupsd
parent61727442d1a460320bd96be081ff17637455eb13 (diff)
downloadports-f8954066434d71bdbcf48584bd905ad1d13cd693.tar.gz
ports-f8954066434d71bdbcf48584bd905ad1d13cd693.zip
Notes
Diffstat (limited to 'sysutils/openupsd')
-rw-r--r--sysutils/openupsd/Makefile2
-rw-r--r--sysutils/openupsd/distinfo4
-rw-r--r--sysutils/openupsd/files/openupsd.sh15
-rw-r--r--sysutils/openupsd/files/patch-support.c10
4 files changed, 7 insertions, 24 deletions
diff --git a/sysutils/openupsd/Makefile b/sysutils/openupsd/Makefile
index 105d22f20038..d2d0bf2cc2bf 100644
--- a/sysutils/openupsd/Makefile
+++ b/sysutils/openupsd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openupsd
-PORTVERSION= 0.3.0
+PORTVERSION= 0.3.1
CATEGORIES= sysutils
MASTER_SITES= http://frmb.org/download/
diff --git a/sysutils/openupsd/distinfo b/sysutils/openupsd/distinfo
index d99539b701af..5fe96a43afc1 100644
--- a/sysutils/openupsd/distinfo
+++ b/sysutils/openupsd/distinfo
@@ -1,2 +1,2 @@
-MD5 (openupsd-0.3.0.tar.gz) = 99cecb372895a8a08d9ae5b2d428a606
-SIZE (openupsd-0.3.0.tar.gz) = 120596
+MD5 (openupsd-0.3.1.tar.gz) = 68b192b007fa80c0a26c13d2917be0d2
+SIZE (openupsd-0.3.1.tar.gz) = 122229
diff --git a/sysutils/openupsd/files/openupsd.sh b/sysutils/openupsd/files/openupsd.sh
index d5610a224146..a203c9f968d4 100644
--- a/sysutils/openupsd/files/openupsd.sh
+++ b/sysutils/openupsd/files/openupsd.sh
@@ -13,18 +13,11 @@ openupsd_enable=${openupsd_enable:-"NO"}
name="openupsd"
rcvar=`set_rcvar`
-start_cmd="${name}_start"
-stop_cmd="${name}_stop"
+pidfile=/var/run/${name}.pid
+required_files=%%PREFIX%%/etc/${name}.conf
-openupsd_start()
-{
- %%PREFIX%%/sbin/openupsd
-}
-
-openupsd_stop()
-{
- killall openupsd
-}
+command=%%PREFIX%%/sbin/openupsd
+command_args="-p ${pidfile}"
load_rc_config $name
run_rc_command "$1"
diff --git a/sysutils/openupsd/files/patch-support.c b/sysutils/openupsd/files/patch-support.c
deleted file mode 100644
index b18bb2828b85..000000000000
--- a/sysutils/openupsd/files/patch-support.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- support.c.bak Sun Aug 15 16:26:05 2004
-+++ support.c Sun Aug 15 16:26:13 2004
-@@ -23,7 +23,6 @@
- #ifdef HAVE_STDLIB_H
- #include <stdlib.h>
- #endif
--#include <malloc.h>
- #include <sys/time.h>
- #include <netinet/in.h>
- #include <termios.h>