aboutsummaryrefslogtreecommitdiff
path: root/sysutils/osquery/Makefile
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2017-05-01 20:24:59 +0000
committerDavid Thiel <lx@FreeBSD.org>2017-05-01 20:24:59 +0000
commite47cdf24c5ab53c27e4ef716ca731e84f38ea649 (patch)
tree7abec14291da3001ebd4f0ed8a3655e019aa0363 /sysutils/osquery/Makefile
parentcde338157e92ead6aa07e57bf6616378924a87af (diff)
downloadports-e47cdf24c5ab53c27e4ef716ca731e84f38ea649.tar.gz
ports-e47cdf24c5ab53c27e4ef716ca731e84f38ea649.zip
Notes
Diffstat (limited to 'sysutils/osquery/Makefile')
-rw-r--r--sysutils/osquery/Makefile34
1 files changed, 28 insertions, 6 deletions
diff --git a/sysutils/osquery/Makefile b/sysutils/osquery/Makefile
index 44335a7bdede..be187be0176d 100644
--- a/sysutils/osquery/Makefile
+++ b/sysutils/osquery/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= osquery
-PORTVERSION= 2.4.0
+PORTVERSION= 2.4.3
CATEGORIES= sysutils
MAINTAINER= zi@FreeBSD.org
@@ -21,12 +21,10 @@ LIB_DEPENDS= libaugeas.so:textproc/augeas \
libgflags.so:devel/gflags \
libglog.so:devel/glog \
libicuuc.so:devel/icu \
- libthrift.so:devel/thrift-cpp \
- libtsk.so:sysutils/sleuthkit \
- libcppnetlib-uri.so:devel/cpp-netlib \
librocksdb-lite.so:databases/rocksdb-lite \
- libyara.so:security/yara \
- liblldpctl.so:net-mgmt/lldpd
+ libthrift.so:devel/thrift-cpp \
+ libcppnetlib-uri.so:devel/cpp-netlib
+RUN_DEPENDS= ca_root_nss>0:security/ca_root_nss
USES= cmake:outsource gmake libtool python:build compiler:c++11-lib
CONFIGURE_ENV+= OSQUERY_BUILD_VERSION="${PORTVERSION}" HOME="${WRKDIR}" \
@@ -40,6 +38,25 @@ GH_PROJECT= third-party:tp
GH_SUBDIR= third-party:tp
MAKE_JOBS_UNSAFE= yes
+# Some options for things that bring in many dependencies
+OPTIONS_DEFINE= TSK AWS YARA LLDPD
+
+TSK_DESC= Build with sleuthkit support
+TSK_LIB_DEPENDS= libtsk.so:sysutils/sleuthkit
+TSK_CONFIGURE_ENV_OFF= SKIP_TSK=1
+
+AWS_DESC= Support logging to AWS Kinesis
+AWS_LIB_DEPENDS= libaws-cpp-sdk-core.so:devel/aws-sdk-cpp
+AWS_CONFIGURE_ENV_OFF= SKIP_AWS=1
+
+YARA_DESC= Build with YARA malware identification support
+YARA_LIB_DEPENDS= libyara.so:security/yara
+YARA_CONFIGURE_ENV_OFF= SKIP_YARA=1
+
+LLDPD_DESC= Support Link Layer Discovery Protocol
+LLDPD_LIB_DEPENDS= liblldpctl.so:net-mgmt/lldpd
+LLDPD_CONFIGURE_ENV_OFF= SKIP_LLDPD=1
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1100000
@@ -51,6 +68,10 @@ CXX= clang++38
post-patch:
${REINPLACE_CMD} -e 's|/var/osquery/|/var/db/osquery/|g' \
${WRKSRC}/tools/deployment/osquery.example.conf
+ ${REINPLACE_CMD} -e 's|/etc/osquery/yara/|/var/db/osquery/yara/|g' \
+ ${WRKSRC}/osquery/tables/yara/yara.cpp \
+ ${WRKSRC}/osquery/tables/yara/yara_utils.cpp \
+ ${WRKSRC}/specs/yara/yara.table
${REINPLACE_CMD} -e 's|python|${PYTHON_CMD}|g' \
${WRKSRC}/CMakeLists.txt \
${WRKSRC}/tools/get_platform.py
@@ -63,6 +84,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/tools/deployment/osquery.example.conf \
${STAGEDIR}${PREFIX}/etc/osquery.conf.sample
+ ${TOUCH} ${STAGEDIR}${PREFIX}/etc/osquery.flags
${MKDIR} ${STAGEDIR}/var/db/osquery
${MKDIR} ${STAGEDIR}/var/log/osquery