aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-MogileFS-Server
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-05-04 01:52:56 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-05-04 01:52:56 +0000
commit6e12fb3d6566d30652bb8ca939124e4cbe4c5b41 (patch)
tree53604702dedade614d318e6c2c53aadd16296a60 /sysutils/p5-MogileFS-Server
parentca30e4a0f6ee093d0a31f47fd7156c970f0410a8 (diff)
downloadports-6e12fb3d6566d30652bb8ca939124e4cbe4c5b41.tar.gz
ports-6e12fb3d6566d30652bb8ca939124e4cbe4c5b41.zip
Notes
Diffstat (limited to 'sysutils/p5-MogileFS-Server')
-rw-r--r--sysutils/p5-MogileFS-Server/Makefile40
-rw-r--r--sysutils/p5-MogileFS-Server/distinfo3
-rw-r--r--sysutils/p5-MogileFS-Server/pkg-descr16
-rw-r--r--sysutils/p5-MogileFS-Server/pkg-plist55
4 files changed, 114 insertions, 0 deletions
diff --git a/sysutils/p5-MogileFS-Server/Makefile b/sysutils/p5-MogileFS-Server/Makefile
new file mode 100644
index 000000000000..80b8266fc6d5
--- /dev/null
+++ b/sysutils/p5-MogileFS-Server/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-mogilefs-server
+# Date created: 2007-04-28
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mogilefs-server
+PORTVERSION= 2.10.919
+CATEGORIES= sysutils perl5
+MASTER_SITES= http://freebsd.csie.nctu.edu.tw/~gslin/files/
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-2.10.r919
+
+MAINTAINER= gslin@gslin.org
+COMMENT= MogileFS (distributed filesystem) server
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IO/AIO.pm:${PORTSDIR}/devel/p5-IO-AIO \
+ ${SITE_PERL}/Danga/Socket.pm:${PORTSDIR}/devel/p5-Danga-Socket \
+ ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
+ ${SITE_PERL}/Perlbal.pm:${PORTSDIR}/www/perlbal \
+ ${SITE_PERL}/Sys/Syscall.pm:${PORTSDIR}/devel/p5-Sys-Syscall
+
+PERL_CONFIGURE= yes
+
+MAN1= mogautomount.1 mogilefsd.1 mogstored.1
+MAN3= MogileFS::DevFID.3 MogileFS::FID.3 MogileFS::IOStatWatcher.3 \
+ MogileFS::Overview.3 \
+ MogileFS::ReplicationPolicy::MultipleHosts.3 \
+ MogileFS::Server.3 MogileFS::Store.3 \
+ MogileFS::Store::MySQL.3 MogileFS::Store::SQLite.3 \
+ MogileFS::Worker::Query.3 MogileFS::Worker::Replicate.3
+
+post-install:
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-MogileFS-Server/distinfo b/sysutils/p5-MogileFS-Server/distinfo
new file mode 100644
index 000000000000..5103dc605c6a
--- /dev/null
+++ b/sysutils/p5-MogileFS-Server/distinfo
@@ -0,0 +1,3 @@
+MD5 (mogilefs-server-2.10.r919.tar.gz) = b9e4aeeef4f69bbf6592a2db2db2856a
+SHA256 (mogilefs-server-2.10.r919.tar.gz) = 82d79d00995748d9fd1511d3480ee08ecbd8683a814f4ab7d2956612951b8b00
+SIZE (mogilefs-server-2.10.r919.tar.gz) = 111815
diff --git a/sysutils/p5-MogileFS-Server/pkg-descr b/sysutils/p5-MogileFS-Server/pkg-descr
new file mode 100644
index 000000000000..e25880af53b6
--- /dev/null
+++ b/sysutils/p5-MogileFS-Server/pkg-descr
@@ -0,0 +1,16 @@
+http://en.wikipedia.org/wiki/MogileFS:
+
+MogileFS was created by Danga Interactive for use with LiveJournal. It
+is similar to the Andrew File System in its design goal. It is different
+than a traditional filesystem in that the user has to access files via
+an API. However, it's possible to implement the file system in user
+space using FUSE, or a similar package.
+
+MogileFS enables horizontal scaling of storage across any number of
+machines. Files are replicated between machines according to
+customizable rules such that at any time a number of drives or machines
+could be lost without data becoming unavailable. It is designed for high
+volume applications, such as high traffic websites, to spread storage
+across cheaper machines without relying on technologies such as NFS.
+
+WWW: http://search.cpan.org/dist/mogilefs-server/
diff --git a/sysutils/p5-MogileFS-Server/pkg-plist b/sysutils/p5-MogileFS-Server/pkg-plist
new file mode 100644
index 000000000000..e359fc86ec49
--- /dev/null
+++ b/sysutils/p5-MogileFS-Server/pkg-plist
@@ -0,0 +1,55 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/apache.conf
+%%PORTDOCS%%%%DOCSDIR%%/fsck-notes.txt
+%%PORTDOCS%%%%DOCSDIR%%/lighttpd.conf
+%%PORTDOCS%%%%DOCSDIR%%/memcache-support.txt
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/mogilefs-server/.packlist
+%%SITE_PERL%%/MogileFS/Class.pm
+%%SITE_PERL%%/MogileFS/Config.pm
+%%SITE_PERL%%/MogileFS/Connection/Client.pm
+%%SITE_PERL%%/MogileFS/Connection/Worker.pm
+%%SITE_PERL%%/MogileFS/DevFID.pm
+%%SITE_PERL%%/MogileFS/Device.pm
+%%SITE_PERL%%/MogileFS/Domain.pm
+%%SITE_PERL%%/MogileFS/Exception.pm
+%%SITE_PERL%%/MogileFS/FID.pm
+%%SITE_PERL%%/MogileFS/HTTPFile.pm
+%%SITE_PERL%%/MogileFS/Host.pm
+%%SITE_PERL%%/MogileFS/IOStatWatcher.pm
+%%SITE_PERL%%/MogileFS/Overview.pm
+%%SITE_PERL%%/MogileFS/ProcManager.pm
+%%SITE_PERL%%/MogileFS/ReplicationPolicy/MultipleHosts.pm
+%%SITE_PERL%%/MogileFS/Server.pm
+%%SITE_PERL%%/MogileFS/Store.pm
+%%SITE_PERL%%/MogileFS/Store/MySQL.pm
+%%SITE_PERL%%/MogileFS/Store/SQLite.pm
+%%SITE_PERL%%/MogileFS/Sys.pm
+%%SITE_PERL%%/MogileFS/Util.pm
+%%SITE_PERL%%/MogileFS/Worker.pm
+%%SITE_PERL%%/MogileFS/Worker/Delete.pm
+%%SITE_PERL%%/MogileFS/Worker/Fsck.pm
+%%SITE_PERL%%/MogileFS/Worker/Monitor.pm
+%%SITE_PERL%%/MogileFS/Worker/Query.pm
+%%SITE_PERL%%/MogileFS/Worker/Reaper.pm
+%%SITE_PERL%%/MogileFS/Worker/Replicate.pm
+%%SITE_PERL%%/Mogstored/HTTPServer.pm
+%%SITE_PERL%%/Mogstored/HTTPServer/Lighttpd.pm
+%%SITE_PERL%%/Mogstored/HTTPServer/Perlbal.pm
+%%SITE_PERL%%/Mogstored/SideChannelClient.pm
+%%SITE_PERL%%/Mogstored/SideChannelListener.pm
+%%SITE_PERL%%/makedocs.pl
+bin/mogautomount
+bin/mogdbsetup
+bin/mogilefsd
+bin/mogstored
+bin/mogstored-diskusage
+bin/mogstored-iostat
+@dirrmtry %%SITE_PERL%%/Mogstored/HTTPServer
+@dirrmtry %%SITE_PERL%%/Mogstored
+@dirrmtry %%SITE_PERL%%/MogileFS/Worker
+@dirrmtry %%SITE_PERL%%/MogileFS/Store
+@dirrmtry %%SITE_PERL%%/MogileFS/ReplicationPolicy
+@dirrmtry %%SITE_PERL%%/MogileFS/Connection
+@dirrmtry %%SITE_PERL%%/MogileFS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/mogilefs-server
+%%PORTDOCS%%@dirrm %%DOCSDIR%%