aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-Schedule-At
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2001-01-10 03:04:46 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2001-01-10 03:04:46 +0000
commit453b6391fcc73f379d76952ec529300affb8454b (patch)
tree0e27d151953a1548d45c78470d6318023d12dc1d /sysutils/p5-Schedule-At
parent00a8c6dd4e69305df14da8a19258d1edac0d2d92 (diff)
downloadports-453b6391fcc73f379d76952ec529300affb8454b.tar.gz
ports-453b6391fcc73f379d76952ec529300affb8454b.zip
Notes
Diffstat (limited to 'sysutils/p5-Schedule-At')
-rw-r--r--sysutils/p5-Schedule-At/Makefile23
-rw-r--r--sysutils/p5-Schedule-At/distinfo1
-rw-r--r--sysutils/p5-Schedule-At/files/patch-At.pm27
-rw-r--r--sysutils/p5-Schedule-At/files/patch-t1.t11
-rw-r--r--sysutils/p5-Schedule-At/pkg-comment1
-rw-r--r--sysutils/p5-Schedule-At/pkg-descr4
-rw-r--r--sysutils/p5-Schedule-At/pkg-plist14
7 files changed, 81 insertions, 0 deletions
diff --git a/sysutils/p5-Schedule-At/Makefile b/sysutils/p5-Schedule-At/Makefile
new file mode 100644
index 000000000000..4c0b944c8070
--- /dev/null
+++ b/sysutils/p5-Schedule-At/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Schedule-At
+# Date created: 10th Jan 2001
+# Whom: kuriyama
+#
+# $FreeBSD$
+#
+
+PORTNAME= Schedule-At
+PORTVERSION= 1.02
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Schedule
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Schedule::At.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-Schedule-At/distinfo b/sysutils/p5-Schedule-At/distinfo
new file mode 100644
index 000000000000..d09961416065
--- /dev/null
+++ b/sysutils/p5-Schedule-At/distinfo
@@ -0,0 +1 @@
+MD5 (Schedule-At-1.02.tar.gz) = 2aed5f342888901be63b67751620ed1b
diff --git a/sysutils/p5-Schedule-At/files/patch-At.pm b/sysutils/p5-Schedule-At/files/patch-At.pm
new file mode 100644
index 000000000000..f74c60475ba3
--- /dev/null
+++ b/sysutils/p5-Schedule-At/files/patch-At.pm
@@ -0,0 +1,27 @@
+--- At.pm.orig Thu Feb 12 20:08:37 1998
++++ At.pm Wed Jan 10 11:56:50 2001
+@@ -264,6 +264,7 @@
+ Jose A. Rodriguez (josear@ac.upc.es)
+
+ =cut
++#' for Emacs face
+
+ ###############################################################################
+ # OS dependent code
+@@ -330,4 +331,16 @@
+ $AT{'getCommand'} = 'at -c %JOBID% |';
+ $AT{'parseJobList'} =
+ sub { (substr($_[0], 27), substr($_[0], 0, 17)) } ;
++}
++
++sub AtCfg_freebsd {
++ $AT{'add'} = 'at %TIME% 2> /dev/null';
++ $AT{'addFile'} = 'at -f %FILE% %TIME% 2> /dev/null';
++ $AT{'timeFormat'} = '%HOUR%:%MINS% %MONTH%/%DAY%/%YEAR%';
++ $AT{'remove'} = 'atrm %JOBID%';
++ $AT{'getJobs'} = 'atq';
++ $AT{'headings'} = ['Date'];
++ $AT{'getCommand'} = 'at -c %JOBID% |';
++ $AT{'parseJobList'} =
++ sub { my @a = split(/\s+/, $_[0]); ("$a[0] $a[1]", $a[4]) } ;
+ }
diff --git a/sysutils/p5-Schedule-At/files/patch-t1.t b/sysutils/p5-Schedule-At/files/patch-t1.t
new file mode 100644
index 000000000000..4491fc72b69f
--- /dev/null
+++ b/sysutils/p5-Schedule-At/files/patch-t1.t
@@ -0,0 +1,11 @@
+--- t1.t.orig Thu Feb 12 19:59:26 1998
++++ t1.t Wed Jan 10 12:00:00 2001
+@@ -28,7 +28,7 @@
+ print "ok 3\n";
+
+ my %atJobs = Schedule::At::getJobs();
+-print "not " if !defined(%atJobs);
++print "not " if (not %atJobs);
+ print "ok 4\n";
+
+ $rv = Schedule::At::remove (TAG => 'Schedule::At');
diff --git a/sysutils/p5-Schedule-At/pkg-comment b/sysutils/p5-Schedule-At/pkg-comment
new file mode 100644
index 000000000000..8208da642573
--- /dev/null
+++ b/sysutils/p5-Schedule-At/pkg-comment
@@ -0,0 +1 @@
+OS independent interface to the Unix 'at' command
diff --git a/sysutils/p5-Schedule-At/pkg-descr b/sysutils/p5-Schedule-At/pkg-descr
new file mode 100644
index 000000000000..172a1bb9cd41
--- /dev/null
+++ b/sysutils/p5-Schedule-At/pkg-descr
@@ -0,0 +1,4 @@
+This modules provides an OS independent interface to 'at', the Unix
+command that allows you to execute commands at a specified time.
+
+WWW: http://search.cpan.org/search?dist=Schedule-At
diff --git a/sysutils/p5-Schedule-At/pkg-plist b/sysutils/p5-Schedule-At/pkg-plist
new file mode 100644
index 000000000000..590cc1898ce5
--- /dev/null
+++ b/sysutils/p5-Schedule-At/pkg-plist
@@ -0,0 +1,14 @@
+lib/perl5/site_perl/%%PERL_VER%%/Schedule/At.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg_dec_osf.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg_hpux.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg_linux.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg_solaris.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/AtCfg_sunos.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Schedule/At/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule/At
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Schedule/At
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Schedule 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Schedule 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Schedule 2>/dev/null || true