aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-Schedule-At
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2002-05-14 08:21:42 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2002-05-14 08:21:42 +0000
commit45930064e81836aae2a16489537606b061e59cf2 (patch)
treed47c4319e26aa5e00f24a2cf611dc21404a508d6 /sysutils/p5-Schedule-At
parent696497e2c8e02609edf2437f53a3f49e722b9b63 (diff)
downloadports-45930064e81836aae2a16489537606b061e59cf2.tar.gz
ports-45930064e81836aae2a16489537606b061e59cf2.zip
Notes
Diffstat (limited to 'sysutils/p5-Schedule-At')
-rw-r--r--sysutils/p5-Schedule-At/Makefile2
-rw-r--r--sysutils/p5-Schedule-At/distinfo2
-rw-r--r--sysutils/p5-Schedule-At/files/patch-At.pm25
-rw-r--r--sysutils/p5-Schedule-At/files/patch-t1.t11
4 files changed, 19 insertions, 21 deletions
diff --git a/sysutils/p5-Schedule-At/Makefile b/sysutils/p5-Schedule-At/Makefile
index 9629da067b17..776f5712d3cd 100644
--- a/sysutils/p5-Schedule-At/Makefile
+++ b/sysutils/p5-Schedule-At/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Schedule-At
-PORTVERSION= 1.02
+PORTVERSION= 1.03
CATEGORIES= sysutils perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Schedule
diff --git a/sysutils/p5-Schedule-At/distinfo b/sysutils/p5-Schedule-At/distinfo
index d09961416065..e2bde38661e9 100644
--- a/sysutils/p5-Schedule-At/distinfo
+++ b/sysutils/p5-Schedule-At/distinfo
@@ -1 +1 @@
-MD5 (Schedule-At-1.02.tar.gz) = 2aed5f342888901be63b67751620ed1b
+MD5 (Schedule-At-1.03.tar.gz) = 9428817d3ca79dc12dc44d8035fdc514
diff --git a/sysutils/p5-Schedule-At/files/patch-At.pm b/sysutils/p5-Schedule-At/files/patch-At.pm
index c05d9302b653..4d5f48a926f5 100644
--- a/sysutils/p5-Schedule-At/files/patch-At.pm
+++ b/sysutils/p5-Schedule-At/files/patch-At.pm
@@ -1,6 +1,6 @@
---- At.pm.orig Thu Feb 12 20:08:37 1998
-+++ At.pm Wed Jan 10 11:56:50 2001
-@@ -264,6 +264,7 @@
+--- At.pm.orig Mon Mar 25 20:52:01 2002
++++ At.pm Tue May 14 17:17:41 2002
+@@ -258,6 +258,7 @@
Jose A. Rodriguez (josear@ac.upc.es)
=cut
@@ -8,10 +8,10 @@
###############################################################################
# OS dependent code
-@@ -330,4 +331,16 @@
- $AT{'getCommand'} = 'at -c %JOBID% |';
- $AT{'parseJobList'} =
- sub { (substr($_[0], 27), substr($_[0], 0, 17)) } ;
+@@ -327,6 +328,25 @@
+ my @fields = split("\t", $_[0]);
+ ($fields[0], substr($fields[1], 0, 16))
+ };
+}
+
+sub AtCfg_freebsd {
@@ -23,5 +23,14 @@
+ $AT{'headings'} = ['Date'];
+ $AT{'getCommand'} = 'at -c %JOBID% |';
+ $AT{'parseJobList'} =
-+ sub { my @a = split(/\s+/, $_[0]); ($a[4], "$a[0] $a[1]") } ;
++ sub {
++ my @a = split(/\s+/, $_[0]);
++ if (/^\d\d/) {
++ return ($a[4], "$a[0] $a[1]");
++ } elsif (defined $a[8]) {
++ return ($a[8], "$a[0] $a[1] $a[2] $a[3] $a[4] $a[5]");
++ }
++ };
}
+
+ sub AtCfg_aix {
diff --git a/sysutils/p5-Schedule-At/files/patch-t1.t b/sysutils/p5-Schedule-At/files/patch-t1.t
deleted file mode 100644
index 7d4c228440de..000000000000
--- a/sysutils/p5-Schedule-At/files/patch-t1.t
+++ /dev/null
@@ -1,11 +0,0 @@
---- t/t1.t.orig Thu Feb 12 19:59:26 1998
-+++ t/t1.t Wed Jan 10 12:00:00 2001
-@@ -28,7 +28,7 @@
- print "ok 3\n";
-
- my %atJobs = Schedule::At::getJobs();
--print "not " if !defined(%atJobs);
-+print "not " if (not %atJobs);
- print "ok 4\n";
-
- $rv = Schedule::At::remove (TAG => 'Schedule::At');