aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-Schedule-Load
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-10-14 16:52:27 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-10-14 16:52:27 +0000
commit64db6fe0d82cb09696cfb176859dfdc4a0b44486 (patch)
tree95818ca59c7096aea04fbd665f7d9f639edc0e8a /sysutils/p5-Schedule-Load
parent7537d9a80f61c37f7a5e59e1642cba8efc8a1ea0 (diff)
downloadports-64db6fe0d82cb09696cfb176859dfdc4a0b44486.tar.gz
ports-64db6fe0d82cb09696cfb176859dfdc4a0b44486.zip
Add p5-Schedule-Load 3.002,
load distribution and status across multiple host machines.
Notes
Notes: svn path=/head/; revision=91222
Diffstat (limited to 'sysutils/p5-Schedule-Load')
-rw-r--r--sysutils/p5-Schedule-Load/Makefile41
-rw-r--r--sysutils/p5-Schedule-Load/distinfo1
-rw-r--r--sysutils/p5-Schedule-Load/pkg-descr3
-rw-r--r--sysutils/p5-Schedule-Load/pkg-plist28
4 files changed, 73 insertions, 0 deletions
diff --git a/sysutils/p5-Schedule-Load/Makefile b/sysutils/p5-Schedule-Load/Makefile
new file mode 100644
index 000000000000..c64b41d7b564
--- /dev/null
+++ b/sysutils/p5-Schedule-Load/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Schedule-Load
+# Date created: 13 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Schedule-Load
+PORTVERSION= 3.002
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Schedule
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Load distribution and status across multiple host machines
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/${PERL_ARCH}/Proc/ProcessTable.pm:${PORTSDIR}/devel/p5-Proc-ProcessTable \
+ ${SITE_PERL}/${PERL_ARCH}/Unix/Processors.pm:${PORTSDIR}/sysutils/p5-Unix-Processors \
+ ${SITE_PERL}/IPC/PidStat.pm:${PORTSDIR}/devel/p5-IPC-Locker
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= rschedule.1 slpolice.1 slchoosed.1 slreportd.1
+MAN3= Schedule::Load.3 Schedule::Load::Chooser.3 \
+ Schedule::Load::FakeReporter.3 Schedule::Load::Hold.3 \
+ Schedule::Load::Hosts.3 Schedule::Load::Hosts::Host.3 \
+ Schedule::Load::Hosts::Proc.3 Schedule::Load::Reporter.3 \
+ Schedule::Load::ResourceReq.3 Schedule::Load::Schedule.3
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}/init.d
+ ${INSTALL_SCRIPT} ${WRKSRC}/init.d/* ${EXAMPLESDIR}/init.d
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-Schedule-Load/distinfo b/sysutils/p5-Schedule-Load/distinfo
new file mode 100644
index 000000000000..a5a95485636f
--- /dev/null
+++ b/sysutils/p5-Schedule-Load/distinfo
@@ -0,0 +1 @@
+MD5 (Schedule-Load-3.002.tar.gz) = 4d8f6aaec79fa7060f379a16dc37ba45
diff --git a/sysutils/p5-Schedule-Load/pkg-descr b/sysutils/p5-Schedule-Load/pkg-descr
new file mode 100644
index 000000000000..55e136e450d8
--- /dev/null
+++ b/sysutils/p5-Schedule-Load/pkg-descr
@@ -0,0 +1,3 @@
+ This package allows accessing loading and top job status across many
+machines on a network, comprising a server farm. It also allows for
+scheduling new jobs on the best machine across the entire network.
diff --git a/sysutils/p5-Schedule-Load/pkg-plist b/sysutils/p5-Schedule-Load/pkg-plist
new file mode 100644
index 000000000000..c878328a5bb8
--- /dev/null
+++ b/sysutils/p5-Schedule-Load/pkg-plist
@@ -0,0 +1,28 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Schedule/Load/.packlist
+bin/rschedule
+bin/slchoosed
+bin/slpolice
+bin/slreportd
+bin/slrsh
+%%SITE_PERL%%/Schedule/Load.pm
+%%SITE_PERL%%/Schedule/Load/Chooser.pm
+%%SITE_PERL%%/Schedule/Load/FakeReporter.pm
+%%SITE_PERL%%/Schedule/Load/Hold.pm
+%%SITE_PERL%%/Schedule/Load/Hosts.pm
+%%SITE_PERL%%/Schedule/Load/Hosts/Host.pm
+%%SITE_PERL%%/Schedule/Load/Hosts/Proc.pm
+%%SITE_PERL%%/Schedule/Load/Reporter.pm
+%%SITE_PERL%%/Schedule/Load/ResourceReq.pm
+%%SITE_PERL%%/Schedule/Load/Schedule.pm
+%%SITE_PERL%%/auto/Schedule/Load/Hosts/Host/autosplit.ix
+%%SITE_PERL%%/auto/Schedule/Load/Hosts/Proc/autosplit.ix
+@dirrm %%SITE_PERL%%/Schedule/Load/Hosts
+@dirrm %%SITE_PERL%%/Schedule/Load
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Schedule/Load
+@dirrm lib/rschedule
+@unexec rmdir %D/%%SITE_PERL%%/Schedule 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Schedule 2>/dev/null || true
+%%PORTDOCS%%%%EXAMPLESDIR%%/init.d/slchoosed
+%%PORTDOCS%%%%EXAMPLESDIR%%/init.d/slreportd
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/init.d
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%