aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-Sys-Gamin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-11 08:29:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-11 08:29:36 +0000
commit7358ed38749b6889a16a3de913297a7810633f9c (patch)
tree878153b2aef3bea8b851d59797c40ba6ade62288 /sysutils/p5-Sys-Gamin
parent07dc4134d5935502138e5b5dada2f4d608c9b09f (diff)
downloadports-7358ed38749b6889a16a3de913297a7810633f9c.tar.gz
ports-7358ed38749b6889a16a3de913297a7810633f9c.zip
Notes
Diffstat (limited to 'sysutils/p5-Sys-Gamin')
-rw-r--r--sysutils/p5-Sys-Gamin/Makefile26
-rw-r--r--sysutils/p5-Sys-Gamin/distinfo3
-rw-r--r--sysutils/p5-Sys-Gamin/pkg-descr6
-rw-r--r--sysutils/p5-Sys-Gamin/pkg-plist20
4 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/p5-Sys-Gamin/Makefile b/sysutils/p5-Sys-Gamin/Makefile
new file mode 100644
index 000000000000..4571e261c58c
--- /dev/null
+++ b/sysutils/p5-Sys-Gamin/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Sys-Gamin
+# Date created: 03 May 2007
+# Whom: Nick Hibma <n_hibma@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sys-Gamin
+PORTVERSION= 0.1
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sys
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= n_hibma@freebsd.org
+COMMENT= Perl interface to Gamin (File Access Monitor implementation)
+
+PERL_CONFIGURE= yes
+USE_FAM= yes
+MAN1= monitor.1
+MAN3= Sys::Gamin.3
+
+pre-configure:
+ ${PERL} -pi -e 'm/LIBS =>/ && print " INC => \"-I${LOCALBASE}/include\",\n"' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-Sys-Gamin/distinfo b/sysutils/p5-Sys-Gamin/distinfo
new file mode 100644
index 000000000000..7a21415df26d
--- /dev/null
+++ b/sysutils/p5-Sys-Gamin/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sys-Gamin-0.1.tar.gz) = 4eb05138c28e8a5f12340938b0823a4c
+SHA256 (Sys-Gamin-0.1.tar.gz) = e3a7395005240048e5c19a12f27c8ea5133f3066421e781de7ed23942fe53ffc
+SIZE (Sys-Gamin-0.1.tar.gz) = 6766
diff --git a/sysutils/p5-Sys-Gamin/pkg-descr b/sysutils/p5-Sys-Gamin/pkg-descr
new file mode 100644
index 000000000000..67cd9b0414b4
--- /dev/null
+++ b/sysutils/p5-Sys-Gamin/pkg-descr
@@ -0,0 +1,6 @@
+Perl interface to Gamin (File Access Monitor implementation)
+Provides a somewhat higher-level and friendlier interface to the Gamin File
+Access Monitor API. This allows one to monitor both local and remote
+(NFS-mounted) files and directories for common filesystem events. To do so, you
+must register "monitors" on specified pathnames and wait for events to arrive
+pertaining to them.
diff --git a/sysutils/p5-Sys-Gamin/pkg-plist b/sysutils/p5-Sys-Gamin/pkg-plist
new file mode 100644
index 000000000000..698996d6419a
--- /dev/null
+++ b/sysutils/p5-Sys-Gamin/pkg-plist
@@ -0,0 +1,20 @@
+bin/monitor
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/Gamin.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/Gamin.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/Sys/Gamin.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/new.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/pending.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/next_event.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/monitor.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/check_monitored.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/cancel.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/monitored.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/suspended.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/suspend.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/resume.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/which.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin/autosplit.ix
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Gamin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Sys