aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-Sys-Hostname-FQDN
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-28 07:17:13 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-28 07:17:13 +0000
commit5a10b57cbb5e7e05ed5be0b0cc04c4b3a3857960 (patch)
treed35c22c9bb2c86f631c0582dccc9a7c447a14445 /sysutils/p5-Sys-Hostname-FQDN
parentd3a43fd95fce0a32528d2f288a8466ea585b68a2 (diff)
downloadports-5a10b57cbb5e7e05ed5be0b0cc04c4b3a3857960.tar.gz
ports-5a10b57cbb5e7e05ed5be0b0cc04c4b3a3857960.zip
Notes
Diffstat (limited to 'sysutils/p5-Sys-Hostname-FQDN')
-rw-r--r--sysutils/p5-Sys-Hostname-FQDN/Makefile33
-rw-r--r--sysutils/p5-Sys-Hostname-FQDN/distinfo3
-rw-r--r--sysutils/p5-Sys-Hostname-FQDN/pkg-descr10
-rw-r--r--sysutils/p5-Sys-Hostname-FQDN/pkg-plist9
4 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/p5-Sys-Hostname-FQDN/Makefile b/sysutils/p5-Sys-Hostname-FQDN/Makefile
new file mode 100644
index 000000000000..e4e44c883ff1
--- /dev/null
+++ b/sysutils/p5-Sys-Hostname-FQDN/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Sys-Hostname-FQDN
+# Date created: 2006-07-23
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sys-Hostname-FQDN
+PORTVERSION= 0.07
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sys
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= Get the short or long hostname
+
+PERL_CONFIGURE= yes
+
+MAN3= Sys::Hostname::FQDN.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS+= ${SITE_PERL}/base.pm:${PORTSDIR}/devel/p5-Class-Fields
+RUN_DEPENDS+= ${SITE_PERL}/base.pm:${PORTSDIR}/devel/p5-Class-Fields
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-Sys-Hostname-FQDN/distinfo b/sysutils/p5-Sys-Hostname-FQDN/distinfo
new file mode 100644
index 000000000000..5d63899d0db4
--- /dev/null
+++ b/sysutils/p5-Sys-Hostname-FQDN/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sys-Hostname-FQDN-0.07.tar.gz) = ab6b00e3f0781b3e074daa53160d1815
+SHA256 (Sys-Hostname-FQDN-0.07.tar.gz) = 54752e9daeff5f583ed078483a2d51d5ab2934b9aba21b3f230129ff1c421621
+SIZE (Sys-Hostname-FQDN-0.07.tar.gz) = 12632
diff --git a/sysutils/p5-Sys-Hostname-FQDN/pkg-descr b/sysutils/p5-Sys-Hostname-FQDN/pkg-descr
new file mode 100644
index 000000000000..d6996e97a438
--- /dev/null
+++ b/sysutils/p5-Sys-Hostname-FQDN/pkg-descr
@@ -0,0 +1,10 @@
+Sys::Hostname::FQDN uses the host 'C' library
+to discover the (usually) short host name,
+then uses (perl) gethostbyname to extract the real hostname.
+
+The results from gethostbyname are exported as gethostinfo
+and asciihostinfo as a convenience since they are available.
+Similarly, the 'C' library functions inet_ntoa and inet_aton are exported.
+
+Author: Michael Robinton <michael@bizsystems.com>
+WWW: http://search.cpan.org/dist/Sys-Hostname-FQDN/
diff --git a/sysutils/p5-Sys-Hostname-FQDN/pkg-plist b/sysutils/p5-Sys-Hostname-FQDN/pkg-plist
new file mode 100644
index 000000000000..a1e2b8bfed85
--- /dev/null
+++ b/sysutils/p5-Sys-Hostname-FQDN/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Sys/Hostname/FQDN.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Hostname/FQDN/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Hostname/FQDN/FQDN.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Hostname/FQDN/FQDN.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Hostname/FQDN
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Hostname
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Sys/Hostname
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Sys