aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-ZConf-Cron
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-30 14:29:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-30 14:29:12 +0000
commit89d12534d8d49608b1cddb33b3002e4e34933413 (patch)
treed28463328a5528efa93120c479861f3744ee92df /sysutils/p5-ZConf-Cron
parent463a0f8ca8ad5a9b97f8649da39387a3b7f9975f (diff)
downloadports-89d12534d8d49608b1cddb33b3002e4e34933413.tar.gz
ports-89d12534d8d49608b1cddb33b3002e4e34933413.zip
Notes
Diffstat (limited to 'sysutils/p5-ZConf-Cron')
-rw-r--r--sysutils/p5-ZConf-Cron/Makefile27
-rw-r--r--sysutils/p5-ZConf-Cron/distinfo3
-rw-r--r--sysutils/p5-ZConf-Cron/pkg-descr9
-rw-r--r--sysutils/p5-ZConf-Cron/pkg-plist7
4 files changed, 46 insertions, 0 deletions
diff --git a/sysutils/p5-ZConf-Cron/Makefile b/sysutils/p5-ZConf-Cron/Makefile
new file mode 100644
index 000000000000..9529eefbe280
--- /dev/null
+++ b/sysutils/p5-ZConf-Cron/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-ZConf-Cron
+# Date created: 2009-09-27
+# Whom: Zane C, Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ZConf-Cron
+PORTVERSION= 0.0.1
+CATEGORIES= sysutils perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/V/VV/VVELOX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Handles storing cron tabs in ZConf
+
+BUILD_DEPENDS= ${SITE_PERL}/ZConf.pm:${PORTSDIR}/net/p5-ZConf \
+ ${SITE_PERL}/DateTime/Event/Cron.pm:${PORTSDIR}/devel/p5-DateTime-Event-Cron \
+ ${SITE_PERL}/mach/DateTime/Duration.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime
+
+PERL_CONFIGURE= yes
+
+MAN3= ZConf::Cron.3
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-ZConf-Cron/distinfo b/sysutils/p5-ZConf-Cron/distinfo
new file mode 100644
index 000000000000..8e5b9e92b597
--- /dev/null
+++ b/sysutils/p5-ZConf-Cron/distinfo
@@ -0,0 +1,3 @@
+MD5 (ZConf-Cron-0.0.1.tar.gz) = c4b96ef0599ab3444d35a465f2b78a80
+SHA256 (ZConf-Cron-0.0.1.tar.gz) = 600ebfcc8b41629e39592572689ef22305515c2b7a9fabd5fcc0f430767f8dcc
+SIZE (ZConf-Cron-0.0.1.tar.gz) = 8659
diff --git a/sysutils/p5-ZConf-Cron/pkg-descr b/sysutils/p5-ZConf-Cron/pkg-descr
new file mode 100644
index 000000000000..6f2d40a2240b
--- /dev/null
+++ b/sysutils/p5-ZConf-Cron/pkg-descr
@@ -0,0 +1,9 @@
+This provides the required module for managing crontabs stored
+in ZConf. Scripts to use thoseare also included.
+
+The utility zccron is a single pass cron utilitie.
+
+zccron - Runs crontabs stored in ZConf.
+zccrontab - Manage crontabs stored in ZConf.
+
+WWW: http://search.cpan.org/dist/ZConf-Cron
diff --git a/sysutils/p5-ZConf-Cron/pkg-plist b/sysutils/p5-ZConf-Cron/pkg-plist
new file mode 100644
index 000000000000..56f32409a27f
--- /dev/null
+++ b/sysutils/p5-ZConf-Cron/pkg-plist
@@ -0,0 +1,7 @@
+bin/zccron
+bin/zccrontab
+%%SITE_PERL%%/ZConf/Cron.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf/Cron/.packlist
+@dirrmtry %%SITE_PERL%%/ZConf
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf/Cron
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf