aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pam_mount/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-11-02 09:51:12 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-11-02 09:51:12 +0000
commit1c6d04df187e9e123f3b9bea825978f5216f25f4 (patch)
tree4c21b53de19783277ce572c21930d9d8bfe94326 /sysutils/pam_mount/Makefile
parentcb5e56ec4b02ca9c51ee35c1ea1ec7fbc0097429 (diff)
downloadports-1c6d04df187e9e123f3b9bea825978f5216f25f4.tar.gz
ports-1c6d04df187e9e123f3b9bea825978f5216f25f4.zip
Notes
Diffstat (limited to 'sysutils/pam_mount/Makefile')
-rw-r--r--sysutils/pam_mount/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/sysutils/pam_mount/Makefile b/sysutils/pam_mount/Makefile
new file mode 100644
index 000000000000..6b724f13bfb6
--- /dev/null
+++ b/sysutils/pam_mount/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# New ports collection Makefile for: pam_mount
+# Date created: 14 October 2010
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_mount
+PORTVERSION= 2.5
+CATEGORIES= sysutils
+MASTER_SITES= SF/${PORTNAME:S/_/-/}/${PORTNAME}/${PORTVERSION}/
+EXTRACT_SUFX= .tar.xz
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A PAM that can mount volumes for a user session
+
+LIB_DEPENDS= HX.25:${PORTSDIR}/lang/libhx
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= libcrypto_LIBS="-L/usr/lib -lcrypto" \
+ libcrypto_CFLAGS="-I/usr/include"
+CONFIGURE_ARGS+=--localstatedir=/var
+
+post-patch:
+ ${REINPLACE_CMD} -e '11172s|yes|no|' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/src/pam_mount.c
+ ${REINPLACE_CMD} -e '/dist_security_DATA/s|\.xml$$|.xml.sample|' \
+ ${WRKSRC}/config/Makefile.am ${WRKSRC}/config/Makefile.in
+ ${MV} ${WRKSRC}/config/pam_mount.conf.xml ${WRKSRC}/config/pam_mount.conf.xml.sample
+
+MAN1= pmt-fd0ssh.1
+MAN5= pam_mount.conf.5
+MAN8= mount.crypt.8 mount.crypt_LUKS.8 mount.crypto_LUKS.8 \
+ pmvarrun.8 pmt-ehd.8 umount.crypt.8 umount.crypt_LUKS.8 \
+ umount.crypto_LUKS.8 pam_mount.8
+
+.include <bsd.port.mk>