aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pax-utils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-08-31 21:31:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-08-31 21:31:26 +0000
commit99c0eded094f58ee598f23918a9318db8183df24 (patch)
tree2a06e0c501ae90a83e59efb378bfbd9911aa6f96 /sysutils/pax-utils
parent6abccf921155e70b1de86ac52e76597dba5d746b (diff)
downloadports-99c0eded094f58ee598f23918a9318db8183df24.tar.gz
ports-99c0eded094f58ee598f23918a9318db8183df24.zip
Notes
Diffstat (limited to 'sysutils/pax-utils')
-rw-r--r--sysutils/pax-utils/Makefile24
-rw-r--r--sysutils/pax-utils/distinfo3
-rw-r--r--sysutils/pax-utils/files/patch-Makefile29
-rw-r--r--sysutils/pax-utils/pkg-descr4
-rw-r--r--sysutils/pax-utils/pkg-plist7
5 files changed, 67 insertions, 0 deletions
diff --git a/sysutils/pax-utils/Makefile b/sysutils/pax-utils/Makefile
new file mode 100644
index 000000000000..b7f259e2cba3
--- /dev/null
+++ b/sysutils/pax-utils/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pax-utils
+# Date created: 20 July 2006
+# Whom: Timothy Redaelli
+#
+# $FreeBSD$
+#
+
+PORTNAME= pax-utils
+PORTVERSION= 0.1.13
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_GENTOO} \
+ http://dev.gentoo.org/~solar/pax/ \
+ http://dev.gentoo.org/~vapier/dist/
+MASTER_SITE_SUBDIR= distfiles
+
+MAINTAINER= drizzt@gufi.org
+COMMENT= Various ELF related utils for ELF32, ELF64 binaries
+
+USE_BZIP2= true
+USE_GMAKE= true
+
+MAN1= dumpelf.1 pspax.1 scanelf.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/pax-utils/distinfo b/sysutils/pax-utils/distinfo
new file mode 100644
index 000000000000..c0c95391a86b
--- /dev/null
+++ b/sysutils/pax-utils/distinfo
@@ -0,0 +1,3 @@
+MD5 (pax-utils-0.1.13.tar.bz2) = 5f09df47a16e83462384b44b75310539
+SHA256 (pax-utils-0.1.13.tar.bz2) = 72f3cdad93b5436070dcc63b67764a06c594f324ccc001e8bfb974a8d1a86f36
+SIZE (pax-utils-0.1.13.tar.bz2) = 53354
diff --git a/sysutils/pax-utils/files/patch-Makefile b/sysutils/pax-utils/files/patch-Makefile
new file mode 100644
index 000000000000..79dff9601994
--- /dev/null
+++ b/sysutils/pax-utils/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig Wed May 17 23:48:10 2006
++++ Makefile Thu Jul 20 20:51:39 2006
+@@ -20,7 +20,7 @@
+ LDFLAGS +=
+ LIBS :=
+ DESTDIR =
+-PREFIX := $(DESTDIR)/usr
++#PREFIX := $(DESTDIR)/usr
+ STRIP := strip
+ MKDIR := mkdir -p
+ CP := cp
+@@ -98,7 +98,7 @@
+ $(STRIP) --strip-unneeded $(TARGETS)
+
+ install: all
+- -$(MKDIR) $(PREFIX)/bin/ $(PREFIX)/share/man/man1/
++ -$(MKDIR) $(PREFIX)/bin/ $(MANPREFIX)/man/man1/
+ $(CP) $(TARGETS) $(PREFIX)/bin/
+ ifeq ($(S),)
+ -$(MKDIR) $(PREFIX)/share/doc/pax-utils/
+@@ -106,7 +106,7 @@
+ endif
+ for mpage in $(MPAGES) ; do \
+ [ -e $$mpage ] \
+- && cp $$mpage $(PREFIX)/share/man/man1/ || : ;\
++ && cp $$mpage $(MANPREFIX)/man/man1/ || : ;\
+ done
+
+ dist: distclean
diff --git a/sysutils/pax-utils/pkg-descr b/sysutils/pax-utils/pkg-descr
new file mode 100644
index 000000000000..e1b3ed907b5b
--- /dev/null
+++ b/sysutils/pax-utils/pkg-descr
@@ -0,0 +1,4 @@
+Various ELF related utils for ELF32, ELF64 binaries useful
+tools that can check files for security relevant properties
+
+WWW: http://www.gentoo.org/proj/en/hardened/pax-utils.xml
diff --git a/sysutils/pax-utils/pkg-plist b/sysutils/pax-utils/pkg-plist
new file mode 100644
index 000000000000..3f6bfe149030
--- /dev/null
+++ b/sysutils/pax-utils/pkg-plist
@@ -0,0 +1,7 @@
+bin/dumpelf
+bin/pspax
+bin/scanelf
+share/doc/pax-utils/BUGS
+share/doc/pax-utils/README
+share/doc/pax-utils/TODO
+@dirrm share/doc/pax-utils