aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pcbsd-appweb/Makefile
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2015-02-03 15:05:14 +0000
committerKris Moore <kmoore@FreeBSD.org>2015-02-03 15:05:14 +0000
commitb03b6f55283557bc3dbd0fd6faca7c2139a00d34 (patch)
tree5b77698088158f3f43227a60c03a746bbb44c034 /sysutils/pcbsd-appweb/Makefile
parentbecaeffa9ba5e2d50a50804026eb6671b3e9352a (diff)
Notes
Diffstat (limited to 'sysutils/pcbsd-appweb/Makefile')
-rw-r--r--sysutils/pcbsd-appweb/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/sysutils/pcbsd-appweb/Makefile b/sysutils/pcbsd-appweb/Makefile
new file mode 100644
index 000000000000..70452fc46e97
--- /dev/null
+++ b/sysutils/pcbsd-appweb/Makefile
@@ -0,0 +1,39 @@
+# Created by: Kris Moore <kmoore@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pcbsd-appweb
+PORTVERSION= 1422974666
+CATEGORIES= sysutils
+MASTER_SITES= http://www.pcbsd.org/~kris/software/ \
+ ftp://ftp.pcbsd.org/pub/software/
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= PC-BSD Web Interface
+
+LICENSE= BSD
+
+RUN_DEPENDS= syscache:${PORTSDIR}/sysutils/pcbsd-syscache \
+ pbi:${PORTSDIR}/sysutils/pbi-manager \
+ warden:${PORTSDIR}/sysutils/warden \
+ nginx:${PORTSDIR}/www/nginx
+
+DEFAULT_PHP_VER=55
+IGNORE_WITH_PHP=54
+USE_PHP= gd filter session
+WRKSRC= ${WRKDIR}/src-webui
+USES= pkgconfig tar:xz
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000
+IGNORE= requires FreeBSD 10 or later
+.endif
+
+do-install:
+ cd ${WRKSRC} && make install PREFIX=${STAGEDIR}${PREFIX}
+
+post-install:
+ PKG_PREFIX=${STAGEDIR}${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.post.mk>