aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pcbsd-libsh
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2015-02-03 15:05:14 +0000
committerKris Moore <kmoore@FreeBSD.org>2015-02-03 15:05:14 +0000
commitb03b6f55283557bc3dbd0fd6faca7c2139a00d34 (patch)
tree5b77698088158f3f43227a60c03a746bbb44c034 /sysutils/pcbsd-libsh
parentbecaeffa9ba5e2d50a50804026eb6671b3e9352a (diff)
downloadports-b03b6f55283557bc3dbd0fd6faca7c2139a00d34.tar.gz
ports-b03b6f55283557bc3dbd0fd6faca7c2139a00d34.zip
Notes
Diffstat (limited to 'sysutils/pcbsd-libsh')
-rw-r--r--sysutils/pcbsd-libsh/Makefile31
-rw-r--r--sysutils/pcbsd-libsh/distinfo2
-rw-r--r--sysutils/pcbsd-libsh/pkg-descr3
-rw-r--r--sysutils/pcbsd-libsh/pkg-install16
-rw-r--r--sysutils/pcbsd-libsh/pkg-plist1
5 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/pcbsd-libsh/Makefile b/sysutils/pcbsd-libsh/Makefile
new file mode 100644
index 000000000000..67f2a03f6155
--- /dev/null
+++ b/sysutils/pcbsd-libsh/Makefile
@@ -0,0 +1,31 @@
+# Created by: Kris Moore <kmoore@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pcbsd-libsh
+PORTVERSION= 1420064498
+CATEGORIES= sysutils
+MASTER_SITES= http://www.pcbsd.org/~kris/software/ \
+ ftp://ftp.pcbsd.org/pub/software/
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= PC-BSD Shell Library
+
+LICENSE= BSD
+
+WRKSRC= ${WRKDIR}/libsh
+USES= pkgconfig tar:xz
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000
+IGNORE= requires FreeBSD 10 or later
+.endif
+
+do-install:
+ cd ${WRKSRC} && make install PREFIX=${STAGEDIR}${PREFIX}
+
+post-install:
+ PKG_PREFIX=${STAGEDIR}${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/pcbsd-libsh/distinfo b/sysutils/pcbsd-libsh/distinfo
new file mode 100644
index 000000000000..d9981f42bb62
--- /dev/null
+++ b/sysutils/pcbsd-libsh/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pcbsd-libsh-1420064498.tar.xz) = 189d7a84d150270ba9f4ada6321c0690833b35561263a13cfa91d5c8930eeaf9
+SIZE (pcbsd-libsh-1420064498.tar.xz) = 6996
diff --git a/sysutils/pcbsd-libsh/pkg-descr b/sysutils/pcbsd-libsh/pkg-descr
new file mode 100644
index 000000000000..85628eaedb6e
--- /dev/null
+++ b/sysutils/pcbsd-libsh/pkg-descr
@@ -0,0 +1,3 @@
+A library of shell functions used by various PC-BSD utilities.
+
+WWW: https://github.com/pcbsd/pcbsd
diff --git a/sysutils/pcbsd-libsh/pkg-install b/sysutils/pcbsd-libsh/pkg-install
new file mode 100644
index 000000000000..769ac9fe31d0
--- /dev/null
+++ b/sysutils/pcbsd-libsh/pkg-install
@@ -0,0 +1,16 @@
+#!/bin/sh
+# Script for any install setup
+
+PREFIX=${PKG_PREFIX-/usr/local}
+
+if [ "$2" != "POST-INSTALL" ] ; then
+ exit 0
+fi
+
+# If this is during staging, we can skip for now
+echo $PREFIX | grep -q '/stage/'
+if [ $? -eq 0 ] ; then
+ exit 0
+fi
+
+exit 0
diff --git a/sysutils/pcbsd-libsh/pkg-plist b/sysutils/pcbsd-libsh/pkg-plist
new file mode 100644
index 000000000000..3de632c97ac3
--- /dev/null
+++ b/sysutils/pcbsd-libsh/pkg-plist
@@ -0,0 +1 @@
+share/pcbsd/scripts/functions.sh