aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pcbsd-syscache
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2015-02-03 15:05:14 +0000
committerKris Moore <kmoore@FreeBSD.org>2015-02-03 15:05:14 +0000
commitb03b6f55283557bc3dbd0fd6faca7c2139a00d34 (patch)
tree5b77698088158f3f43227a60c03a746bbb44c034 /sysutils/pcbsd-syscache
parentbecaeffa9ba5e2d50a50804026eb6671b3e9352a (diff)
Notes
Diffstat (limited to 'sysutils/pcbsd-syscache')
-rw-r--r--sysutils/pcbsd-syscache/Makefile32
-rw-r--r--sysutils/pcbsd-syscache/distinfo2
-rw-r--r--sysutils/pcbsd-syscache/pkg-descr5
-rw-r--r--sysutils/pcbsd-syscache/pkg-install16
-rw-r--r--sysutils/pcbsd-syscache/pkg-plist3
5 files changed, 58 insertions, 0 deletions
diff --git a/sysutils/pcbsd-syscache/Makefile b/sysutils/pcbsd-syscache/Makefile
new file mode 100644
index 000000000000..0de3946f0b11
--- /dev/null
+++ b/sysutils/pcbsd-syscache/Makefile
@@ -0,0 +1,32 @@
+# Created by: Kris Moore <kmoore@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pcbsd-syscache
+PORTVERSION= 1421343297
+CATEGORIES= sysutils
+MASTER_SITES= http://www.pcbsd.org/~kris/software/ \
+ ftp://ftp.pcbsd.org/pub/software/
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= PC-BSD SysCache Utility
+
+LICENSE= BSD
+
+WRKSRC= ${WRKDIR}/syscache
+USE_QT5= core network buildtools qmake
+USES= pkgconfig tar:xz
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000
+IGNORE= requires FreeBSD 10 or later
+.endif
+
+do-install:
+ cd ${WRKSRC} && make install PREFIX=${STAGEDIR}${PREFIX}
+
+post-install:
+ PKG_PREFIX=${STAGEDIR}${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/pcbsd-syscache/distinfo b/sysutils/pcbsd-syscache/distinfo
new file mode 100644
index 000000000000..2b3ae8e9018d
--- /dev/null
+++ b/sysutils/pcbsd-syscache/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pcbsd-syscache-1421343297.tar.xz) = a99d914b5d09ab9d5f3a2be5b9388b7505e3f474ba7c767a5fd91d20cb59ff28
+SIZE (pcbsd-syscache-1421343297.tar.xz) = 130044
diff --git a/sysutils/pcbsd-syscache/pkg-descr b/sysutils/pcbsd-syscache/pkg-descr
new file mode 100644
index 000000000000..4539359e42c7
--- /dev/null
+++ b/sysutils/pcbsd-syscache/pkg-descr
@@ -0,0 +1,5 @@
+The syscache utility is used by PC-BSD and others to provide fast
+access and retrival of system state data, such as package info, jail
+status, update info and more.
+
+WWW: https://github.com/pcbsd/pcbsd
diff --git a/sysutils/pcbsd-syscache/pkg-install b/sysutils/pcbsd-syscache/pkg-install
new file mode 100644
index 000000000000..769ac9fe31d0
--- /dev/null
+++ b/sysutils/pcbsd-syscache/pkg-install
@@ -0,0 +1,16 @@
+#!/bin/sh
+# Script for any install setup
+
+PREFIX=${PKG_PREFIX-/usr/local}
+
+if [ "$2" != "POST-INSTALL" ] ; then
+ exit 0
+fi
+
+# If this is during staging, we can skip for now
+echo $PREFIX | grep -q '/stage/'
+if [ $? -eq 0 ] ; then
+ exit 0
+fi
+
+exit 0
diff --git a/sysutils/pcbsd-syscache/pkg-plist b/sysutils/pcbsd-syscache/pkg-plist
new file mode 100644
index 000000000000..c77a56224d9c
--- /dev/null
+++ b/sysutils/pcbsd-syscache/pkg-plist
@@ -0,0 +1,3 @@
+bin/syscache
+bin/syscache-daemon
+etc/rc.d/syscache