aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pciutils
diff options
context:
space:
mode:
authorMarius Strobl <marius@FreeBSD.org>2007-10-28 21:18:12 +0000
committerMarius Strobl <marius@FreeBSD.org>2007-10-28 21:18:12 +0000
commit07c3a4988641072f4140cd946dbea02cb6a7b658 (patch)
treed3ac3627aa3e0a2ea238f036fd6cfe68e7e3d6f0 /sysutils/pciutils
parent4db6f92b05f514b7a058320c58a46d8db73abad6 (diff)
downloadports-07c3a4988641072f4140cd946dbea02cb6a7b658.tar.gz
ports-07c3a4988641072f4140cd946dbea02cb6a7b658.zip
Notes
Diffstat (limited to 'sysutils/pciutils')
-rw-r--r--sysutils/pciutils/Makefile2
-rw-r--r--sysutils/pciutils/distinfo6
-rw-r--r--sysutils/pciutils/files/patch-Makefile4
-rw-r--r--sysutils/pciutils/files/patch-lib::fbsd-device.c99
-rw-r--r--sysutils/pciutils/files/patch-lspci.c14
5 files changed, 6 insertions, 119 deletions
diff --git a/sysutils/pciutils/Makefile b/sysutils/pciutils/Makefile
index 5f767e926655..7e7f67678de9 100644
--- a/sysutils/pciutils/Makefile
+++ b/sysutils/pciutils/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pciutils
-PORTVERSION= 2.2.6
+PORTVERSION= 2.2.8
CATEGORIES= sysutils
MASTER_SITES= ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/ \
ftp://ftp.kernel.org/pub/software/utils/pciutils/ \
diff --git a/sysutils/pciutils/distinfo b/sysutils/pciutils/distinfo
index e2d9748a4f0b..700d6e67cc90 100644
--- a/sysutils/pciutils/distinfo
+++ b/sysutils/pciutils/distinfo
@@ -1,3 +1,3 @@
-MD5 (pciutils-2.2.6.tar.gz) = e26593ab38ef9ae4457826be9e35aff8
-SHA256 (pciutils-2.2.6.tar.gz) = 30019fa23996429d3bedaa1b30e32b9ddcd2eaa4fe39ec015d533af6afc0ee6b
-SIZE (pciutils-2.2.6.tar.gz) = 226049
+MD5 (pciutils-2.2.8.tar.gz) = c0b742521a13ef624b9a0a237f46c1c8
+SHA256 (pciutils-2.2.8.tar.gz) = 8bdbcac28a80e05799c3e788bbb24417059537aff53b8bf16c7c8e08b3979fa2
+SIZE (pciutils-2.2.8.tar.gz) = 232602
diff --git a/sysutils/pciutils/files/patch-Makefile b/sysutils/pciutils/files/patch-Makefile
index dc0bd966e0ff..ea4020744cf9 100644
--- a/sysutils/pciutils/files/patch-Makefile
+++ b/sysutils/pciutils/files/patch-Makefile
@@ -8,8 +8,8 @@
-CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
+CFLAGS+=-Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
- VERSION=2.2.6
- DATE=2007-06-20
+ VERSION=2.2.8
+ DATE=2007-10-19
-PREFIX=/usr/local
SBINDIR=$(PREFIX)/sbin
diff --git a/sysutils/pciutils/files/patch-lib::fbsd-device.c b/sysutils/pciutils/files/patch-lib::fbsd-device.c
deleted file mode 100644
index 5b69d7c76ba2..000000000000
--- a/sysutils/pciutils/files/patch-lib::fbsd-device.c
+++ /dev/null
@@ -1,99 +0,0 @@
---- lib/fbsd-device.c.orig Tue Jul 20 07:01:31 1999
-+++ lib/fbsd-device.c Tue Apr 12 10:49:09 2005
-@@ -7,7 +7,9 @@
- * Can be freely distributed and used under the terms of the GNU GPL.
- */
-
-+#include <errno.h>
- #include <fcntl.h>
-+#include <stdio.h>
- #include <string.h>
- #include <unistd.h>
- #include <osreldate.h>
-@@ -19,13 +21,8 @@
- # endif
- #endif
-
--#if __FreeBSD_version < 500000
--# include <pci/pcivar.h>
--#else
--# include <dev/pci/pcivar.h>
--#endif
--
- #if __FreeBSD_version < 430000
-+# include <pci/pcivar.h>
- # include <pci/pci_ioctl.h>
- #else
- # include <sys/pciio.h>
-@@ -84,6 +81,9 @@
- if (pos >= 256)
- return 0;
-
-+#if __FreeBSD_version >= 700053
-+ pi.pi_sel.pc_domain = d->domain;
-+#endif
- pi.pi_sel.pc_bus = d->bus;
- pi.pi_sel.pc_dev = d->dev;
- pi.pi_sel.pc_func = d->func;
-@@ -92,7 +92,13 @@
- pi.pi_width = len;
-
- if (ioctl(d->access->fd, PCIOCREAD, &pi) < 0)
-- d->access->error("fbsd_read: ioctl(PCIOCREAD) failed");
-+ {
-+ if (errno == ENODEV)
-+ {
-+ return 0;
-+ }
-+ d->access->error("fbsd_read: ioctl(PCIOCREAD) failed: %s", strerror(errno));
-+ }
-
- switch (len)
- {
-@@ -100,10 +106,10 @@
- buf[0] = (u8) pi.pi_data;
- break;
- case 2:
-- ((u16 *) buf)[0] = (u16) pi.pi_data;
-+ ((u16 *) buf)[0] = cpu_to_le16((u16) pi.pi_data);
- break;
- case 4:
-- ((u32 *) buf)[0] = (u32) pi.pi_data;
-+ ((u32 *) buf)[0] = cpu_to_le32((u32) pi.pi_data);
- break;
- }
- return 1;
-@@ -122,6 +128,9 @@
- if (pos >= 256)
- return 0;
-
-+#if __FreeBSD_version >= 700053
-+ pi.pi_sel.pc_domain = d->domain;
-+#endif
- pi.pi_sel.pc_bus = d->bus;
- pi.pi_sel.pc_dev = d->dev;
- pi.pi_sel.pc_func = d->func;
-@@ -135,16 +144,20 @@
- pi.pi_data = buf[0];
- break;
- case 2:
-- pi.pi_data = ((u16 *) buf)[0];
-+ pi.pi_data = le16_to_cpu(((u16 *) buf)[0]);
- break;
- case 4:
-- pi.pi_data = ((u32 *) buf)[0];
-+ pi.pi_data = le32_to_cpu(((u32 *) buf)[0]);
- break;
- }
-
- if (ioctl(d->access->fd, PCIOCWRITE, &pi) < 0)
- {
-- d->access->error("fbsd_write: ioctl(PCIOCWRITE) failed");
-+ if (errno == ENODEV)
-+ {
-+ return 0;
-+ }
-+ d->access->error("fbsd_write: ioctl(PCIOCWRITE) failed: %s", strerror(errno));
- }
-
- return 1;
diff --git a/sysutils/pciutils/files/patch-lspci.c b/sysutils/pciutils/files/patch-lspci.c
deleted file mode 100644
index 7748d873b14d..000000000000
--- a/sysutils/pciutils/files/patch-lspci.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- lspci.c.orig Fri Mar 30 11:56:35 2007
-+++ lspci.c Tue Oct 2 13:24:51 2007
-@@ -58,8 +58,9 @@
- * This increases our memory footprint, but only slightly since we don't
- * use alloca() much.
- */
--
--#ifdef __GNUC__
-+#if defined (__FreeBSD__) || defined (__NetBSD__) || defined (__OpenBSD__) || defined (__DragonFly__)
-+/* alloca() is defined in stdlib.h */
-+#elif defined(__GNUC__) && !defined(PCI_OS_WINDOWS)
- #include <alloca.h>
- #else
- #undef alloca