aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pear-Cache
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-04-06 19:17:02 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-04-06 19:17:02 +0000
commit2e8f878fe62810aec5e31020fcde5b77650c602c (patch)
tree430f67722afc9f68451a6f787d0e27c69974ee72 /sysutils/pear-Cache
parentc39e66ac50e7fcb79e8fe22d4f72d200ff6c10b1 (diff)
downloadports-2e8f878fe62810aec5e31020fcde5b77650c602c.tar.gz
ports-2e8f878fe62810aec5e31020fcde5b77650c602c.zip
Notes
Diffstat (limited to 'sysutils/pear-Cache')
-rw-r--r--sysutils/pear-Cache/Makefile28
-rw-r--r--sysutils/pear-Cache/distinfo2
-rw-r--r--sysutils/pear-Cache/pkg-descr5
3 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/pear-Cache/Makefile b/sysutils/pear-Cache/Makefile
new file mode 100644
index 000000000000..94dd80b7dbdc
--- /dev/null
+++ b/sysutils/pear-Cache/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: pear-Cache
+# Date created: 5 April 2004
+# Whom: Thierry Thomas (<thierry@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cache
+PORTVERSION= 1.5.4
+CATEGORIES= sysutils www pear
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR framework for caching of arbitrary data
+
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Cache
+FILES= Application.php Cache.php Container.php Container/db.php \
+ Container/dbx.php Container/file.php Container/mdb.php \
+ Container/mdb_cache_schema.xml Container/msession.php \
+ Container/phplib.php Container/shm.php Container/trifile.php \
+ Error.php Function.php Graphics.php HTTP_Request.php Output.php \
+ OutputCompression.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/sysutils/pear-Cache/distinfo b/sysutils/pear-Cache/distinfo
new file mode 100644
index 000000000000..5a9c4cd69102
--- /dev/null
+++ b/sysutils/pear-Cache/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Cache-1.5.4.tgz) = 1a7698fcfdf9ab63e56bbbff0c76a13d
+SIZE (PEAR/Cache-1.5.4.tgz) = 30690
diff --git a/sysutils/pear-Cache/pkg-descr b/sysutils/pear-Cache/pkg-descr
new file mode 100644
index 000000000000..4155a4ca03ec
--- /dev/null
+++ b/sysutils/pear-Cache/pkg-descr
@@ -0,0 +1,5 @@
+With the PEAR Cache you can cache the result of certain function
+calls, as well as the output of a whole script run or share data
+between applications.
+
+WWW: http://pear.php.net/package/Cache/