aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pear-Log/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-01-09 04:47:07 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-01-09 04:47:07 +0000
commit39c2e2cc9a5c6556603295502559c5f721361c64 (patch)
tree08062daea149bb9369da0ff727eb59c580400dae /sysutils/pear-Log/Makefile
parent7d6d450bc61c6d036955f4f4be31efd749f4d168 (diff)
downloadports-39c2e2cc9a5c6556603295502559c5f721361c64.tar.gz
ports-39c2e2cc9a5c6556603295502559c5f721361c64.zip
Notes
Diffstat (limited to 'sysutils/pear-Log/Makefile')
-rw-r--r--sysutils/pear-Log/Makefile24
1 files changed, 15 insertions, 9 deletions
diff --git a/sysutils/pear-Log/Makefile b/sysutils/pear-Log/Makefile
index c03385284246..0707a9b1750e 100644
--- a/sysutils/pear-Log/Makefile
+++ b/sysutils/pear-Log/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Log
-PORTVERSION= 1.8.6
+PORTVERSION= 1.8.7
CATEGORIES= sysutils www pear
MAINTAINER= antonio@php.net
@@ -17,16 +17,16 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PHP= yes
-FILES= Log.php Log/composite.php Log/console.php Log/display.php \
- Log/error_log.php Log/file.php Log/mail.php Log/mcal.php \
- Log/null.php Log/observer.php Log/sql.php Log/sqlite.php \
- Log/syslog.php Log/win.php
+FILES= Log/composite.php Log/console.php Log/daemon.php \
+ Log/display.php Log/error_log.php Log/file.php Log/mail.php \
+ Log/mcal.php Log/null.php Log/observer.php Log/sql.php \
+ Log/sqlite.php Log/syslog.php Log/win.php Log.php
DOCS= guide.txt
-EXAMPLES= composite.php console.php display.php error_log.php file.php \
- mail.php null.php observer_mail.php pear_error_handler.php \
+EXAMPLES= composite.php console.php display.php error_log.php file.php \
+ mail.php null.php observer_mail.php pear_error_handler.php \
php_error_handler.php sql.php sqlite.php syslog.php win.php
-TESTS= composite.phpt console.phpt display.phpt error_log.phpt \
- extract.phpt extract2.phpt factory.phpt null.phpt priority.phpt \
+TESTS= composite.phpt console.phpt display.phpt error_log.phpt \
+ extract.phpt extract2.phpt factory.phpt null.phpt priority.phpt \
singleton.phpt sqlite.phpt sql_ident.phpt
SQLS= log.sql
@@ -48,6 +48,12 @@ OPTIONS+= PHP_SQLITE "PHP sqlite support" off
.include <bsd.port.pre.mk>
+PHP_VERS= ${PHP_VERSION:S/.//g}
+
+.if defined(PHP_VERS) && ${PHP_VERS} < 430
+IGNORE= "You need PHP 4.3.0 or later to install PEAR::Log"
+.endif
+
.if defined(WITH_PEAR_DB)
BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
.endif