aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pear-Log
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
committerSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
commit050dd1b1031022b49cd1623dd3892f3c4be3a1ae (patch)
tree0876fb5cc1d38a316c0fbaf87137d69775f5dad0 /sysutils/pear-Log
parentcf19879c06b65241c187f1b0663a0db0270be14f (diff)
Notes
Diffstat (limited to 'sysutils/pear-Log')
-rw-r--r--sysutils/pear-Log/Makefile36
-rw-r--r--sysutils/pear-Log/distinfo1
-rw-r--r--sysutils/pear-Log/pkg-comment1
-rw-r--r--sysutils/pear-Log/pkg-descr6
-rw-r--r--sysutils/pear-Log/pkg-plist10
5 files changed, 54 insertions, 0 deletions
diff --git a/sysutils/pear-Log/Makefile b/sysutils/pear-Log/Makefile
new file mode 100644
index 000000000000..3398734c2fe6
--- /dev/null
+++ b/sysutils/pear-Log/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: pear-Log
+# Date created: 22 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log
+PORTVERSION= 1.5
+CATEGORIES= sysutils www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
+ @${CHOWN} -R root:wheel ${PEARDIR}/${PORTNAME}*
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/pear-Log/distinfo b/sysutils/pear-Log/distinfo
new file mode 100644
index 000000000000..3849df423b84
--- /dev/null
+++ b/sysutils/pear-Log/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Log-1.5.tgz) = 30421577a99e0837c0235abb89578697
diff --git a/sysutils/pear-Log/pkg-comment b/sysutils/pear-Log/pkg-comment
new file mode 100644
index 000000000000..625e42b202c1
--- /dev/null
+++ b/sysutils/pear-Log/pkg-comment
@@ -0,0 +1 @@
+PEAR logging utilities
diff --git a/sysutils/pear-Log/pkg-descr b/sysutils/pear-Log/pkg-descr
new file mode 100644
index 000000000000..d15b0ddefb82
--- /dev/null
+++ b/sysutils/pear-Log/pkg-descr
@@ -0,0 +1,6 @@
+PEAR Log framework providing an abstracted logging system.
+
+It supports logging to console, file, syslog, SQL, mail, and mcal targets.
+It also provides a subject - observer mechanism.
+
+WWW: http://pear.php.net/manual/en/packages.log.php
diff --git a/sysutils/pear-Log/pkg-plist b/sysutils/pear-Log/pkg-plist
new file mode 100644
index 000000000000..51c492c0b71a
--- /dev/null
+++ b/sysutils/pear-Log/pkg-plist
@@ -0,0 +1,10 @@
+%%PEARDIR%%/Log/composite.php
+%%PEARDIR%%/Log/console.php
+%%PEARDIR%%/Log/file.php
+%%PEARDIR%%/Log/mail.php
+%%PEARDIR%%/Log/mcal.php
+%%PEARDIR%%/Log/observer.php
+%%PEARDIR%%/Log/sql.php
+%%PEARDIR%%/Log/syslog.php
+%%PEARDIR%%/Log.php
+@dirrm %%PEARDIR%%/Log