aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pecl-fileinfo
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-11-07 15:58:20 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-11-07 15:58:20 +0000
commit64809ed7bfcec67f04bc5b04dba7265b8b9f3d0a (patch)
treeb8bbd3bd9e4aeb2dba2a3bb1c3b6383c6aebaf06 /sysutils/pecl-fileinfo
parentb9cc99f2b35a43c93099e07486f7d3fbe9a06f9f (diff)
downloadports-64809ed7bfcec67f04bc5b04dba7265b8b9f3d0a.tar.gz
ports-64809ed7bfcec67f04bc5b04dba7265b8b9f3d0a.zip
Notes
Diffstat (limited to 'sysutils/pecl-fileinfo')
-rw-r--r--sysutils/pecl-fileinfo/Makefile1
-rw-r--r--sysutils/pecl-fileinfo/files/patch-fileinfo.c24
2 files changed, 25 insertions, 0 deletions
diff --git a/sysutils/pecl-fileinfo/Makefile b/sysutils/pecl-fileinfo/Makefile
index bff8e8ec0d1b..af9e9356d06c 100644
--- a/sysutils/pecl-fileinfo/Makefile
+++ b/sysutils/pecl-fileinfo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fileinfo
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= sysutils pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
diff --git a/sysutils/pecl-fileinfo/files/patch-fileinfo.c b/sysutils/pecl-fileinfo/files/patch-fileinfo.c
new file mode 100644
index 000000000000..e4cca194fa7a
--- /dev/null
+++ b/sysutils/pecl-fileinfo/files/patch-fileinfo.c
@@ -0,0 +1,24 @@
+--- fileinfo.c.orig 2005/12/20 19:17:00
++++ fileinfo.c 2006/10/10 09:52:06
+@@ -121,10 +121,17 @@
+ /* {{{ finfo_class_functions
+ */
+ function_entry finfo_class_functions[] = {
+- ZEND_ME_MAPPING(finfo, finfo_open, NULL)
+- ZEND_ME_MAPPING(set_flags, finfo_set_flags,NULL)
+- ZEND_ME_MAPPING(file, finfo_file, NULL)
+- ZEND_ME_MAPPING(buffer, finfo_buffer, NULL)
++#if PHP_VERSION_ID >= 50200
++ ZEND_ME_MAPPING(finfo, finfo_open, NULL, ZEND_ACC_PUBLIC)
++ ZEND_ME_MAPPING(set_flags, finfo_set_flags,NULL, ZEND_ACC_PUBLIC)
++ ZEND_ME_MAPPING(file, finfo_file, NULL, ZEND_ACC_PUBLIC)
++ ZEND_ME_MAPPING(buffer, finfo_buffer, NULL, ZEND_ACC_PUBLIC)
++#else
++ ZEND_ME_MAPPING(finfo, finfo_open, NULL)
++ ZEND_ME_MAPPING(set_flags, finfo_set_flags,NULL)
++ ZEND_ME_MAPPING(file, finfo_file, NULL)
++ ZEND_ME_MAPPING(buffer, finfo_buffer, NULL)
++#endif
+ {NULL, NULL, NULL}
+ };
+ /* }}} */