aboutsummaryrefslogtreecommitdiff
path: root/sysutils/penv/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2002-03-21 12:06:59 +0000
committerPeter Pentchev <roam@FreeBSD.org>2002-03-21 12:06:59 +0000
commit9c889e38626d30301640e0d141cca9bcdd94045d (patch)
tree79852f76358a96a9a9ca5f054e2f06070f850bbd /sysutils/penv/Makefile
parent809d3bb90598bd5b5c6cd9dc14729edc1dcfe70f (diff)
Notes
Diffstat (limited to 'sysutils/penv/Makefile')
-rw-r--r--sysutils/penv/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/sysutils/penv/Makefile b/sysutils/penv/Makefile
index cd189ab23d1a..db9d6f2b0066 100644
--- a/sysutils/penv/Makefile
+++ b/sysutils/penv/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= penv
-PORTVERSION= 1.1
+PORTVERSION= 1.2.b1
CATEGORIES= sysutils
MASTER_SITES= http://devel.ringlet.net/sysutils/penv/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/pre/}
@@ -29,6 +29,11 @@ DBDIR?= /var/db/${PORTNAME}
PLIST_SUB+= DBDIR=${DBDIR}
+HTMLDOCS= docbook.css index.html penv-compat.html penv-history.html \
+ penv-install.html penv-src.html penv-usage.html penv.html
+HTMLCDOCS= changes.html changes.txt
+TXTDOCS= penv.txt
+
post-install:
${MKDIR} ${PREFIX}/etc
${MKDIR} ${DBDIR}
@@ -39,7 +44,11 @@ post-install:
fi
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}/html
+ ${INSTALL_DATA} ${HTMLDOCS:S,^,${WRKSRC}/doc/html/,} ${DOCSDIR}/html
+ ${MKDIR} ${DOCSDIR}/html/changes
+ ${INSTALL_DATA} ${HTMLCDOCS:S,^,${WRKSRC}/doc/html/changes/,} ${DOCSDIR}/html/changes
+ ${MKDIR} ${DOCSDIR}/txt
+ ${INSTALL_DATA} ${TXTDOCS:S,^,${WRKSRC}/doc/txt/,} ${DOCSDIR}/txt
.endif
.include <bsd.port.mk>