aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pflogx
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 20:01:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 20:01:07 +0000
commit27d44119e7e106f32a4b4b25539a57a35cc68823 (patch)
tree8462df47de7a523e2debd710ebc0516911e33a43 /sysutils/pflogx
parentf3184698839707db08f51b1529956b01b49932cf (diff)
downloadports-27d44119e7e106f32a4b4b25539a57a35cc68823.tar.gz
ports-27d44119e7e106f32a4b4b25539a57a35cc68823.zip
Notes
Diffstat (limited to 'sysutils/pflogx')
-rw-r--r--sysutils/pflogx/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/sysutils/pflogx/Makefile b/sysutils/pflogx/Makefile
index f062034c1c6a..81e2eecfc494 100644
--- a/sysutils/pflogx/Makefile
+++ b/sysutils/pflogx/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: pflogx
-# Date created: May 10 2006
-# Whom: clsung
-#
+# Created by: clsung
# $FreeBSD$
-#
PORTNAME= pflogx
PORTVERSION= 0.86
@@ -17,11 +12,12 @@ COMMENT= Simple tool to export pf (packet filter) logs to XML files
WRKSRC= ${WRKDIR}/${PORTNAME}
-OPTIONS= EXPAT "Ability to merge new events (require expat) " Off
+OPTIONS_DEFINE= EXPAT DOCS
+EXPAT_DESC= Ability to merge new events (require expat)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_EXPAT)
+.if ${PORT_OPTIONS:MEXPAT}
LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
MAKE_ARGS+= -DWITH_EXPAT \
EXPAT_INCLUDEDIR=${LOCALBASE}/include \
@@ -30,7 +26,7 @@ MAKE_ARGS+= -DWITH_EXPAT \
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/pflogx ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
@@ -39,4 +35,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/xsl/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>