aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pfstat
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-10-13 14:28:45 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-10-13 14:28:45 +0000
commit9ae530655422348f2a72cd0567f258a8ce7987c8 (patch)
treee1d453173ac5195556e62a00d737e9238240bdb4 /sysutils/pfstat
parent21dacc250191ba6fdb420664dc1fa44e4f1d8517 (diff)
downloadports-9ae530655422348f2a72cd0567f258a8ce7987c8.tar.gz
ports-9ae530655422348f2a72cd0567f258a8ce7987c8.zip
Notes
Diffstat (limited to 'sysutils/pfstat')
-rw-r--r--sysutils/pfstat/Makefile50
-rw-r--r--sysutils/pfstat/distinfo1
-rw-r--r--sysutils/pfstat/pkg-descr7
-rw-r--r--sysutils/pfstat/pkg-plist1
4 files changed, 59 insertions, 0 deletions
diff --git a/sysutils/pfstat/Makefile b/sysutils/pfstat/Makefile
new file mode 100644
index 000000000000..95c9aaae323a
--- /dev/null
+++ b/sysutils/pfstat/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: pfstat
+# Date created: 10 October 2003
+# Whom: Max Laier <max@love2party.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pfstat
+PORTVERSION= 1.7
+CATEGORIES= sysutils net
+MASTER_SITES= http://www.benzedrine.cx/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= max@love2party.net
+COMMENT= Utility to render grafical statistics for pf
+
+BUILD_DEPENDS= ${LOCALBASE}/include/pf/net/pfvar.h:${PORTSDIR}/security/pf
+RUN_DEPENDS= ${LOCALBASE}/modules/pf.ko:${PORTSDIR}/security/pf
+.if defined(WITH_GD1)
+LIB_DEPENDS= gd1.2:${PORTSDIR}/graphics/gd1
+CFLAGS+= -I${LOCALBASE}/include/gd
+MAKE_ARGS= "LD_GD=gd1"
+.else
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+MAKE_ARGS= "LD_GD=gd"
+.endif
+
+USE_REINPLACE= yes
+
+MAN8= pfstat.8
+
+MANCOMPRESSED= no
+
+CFLAGS+= -I${LOCALBASE}/include/pf
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+#IGNORE= "Only for 5.0 and above"
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|-lgd|-l$${LD_GD}|; s| -lttf||' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pfstat ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pfstat.8 ${PREFIX}/man/man8
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/pfstat/distinfo b/sysutils/pfstat/distinfo
new file mode 100644
index 000000000000..585054288756
--- /dev/null
+++ b/sysutils/pfstat/distinfo
@@ -0,0 +1 @@
+MD5 (pfstat-1.7.tar.gz) = bd58864b56774aa10aa763258de8b625
diff --git a/sysutils/pfstat/pkg-descr b/sysutils/pfstat/pkg-descr
new file mode 100644
index 000000000000..cb7b379f8608
--- /dev/null
+++ b/sysutils/pfstat/pkg-descr
@@ -0,0 +1,7 @@
+Pfstat is a small utility that collects packet filter (security/pf) statistics
+and produces graphs like mrtg or alike. Samples can be found at the website
+below.
+
+WWW: http://www.benzedrine.cx/pfstat.html
+
+-Max <max@love2party.net>
diff --git a/sysutils/pfstat/pkg-plist b/sysutils/pfstat/pkg-plist
new file mode 100644
index 000000000000..942e06f65004
--- /dev/null
+++ b/sysutils/pfstat/pkg-plist
@@ -0,0 +1 @@
+bin/pfstat