aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pfstat
diff options
context:
space:
mode:
authorMax Laier <mlaier@FreeBSD.org>2006-12-16 01:58:38 +0000
committerMax Laier <mlaier@FreeBSD.org>2006-12-16 01:58:38 +0000
commitdc55152eac2d55dc5fe7909a482a906ac38b6ef1 (patch)
tree072fe03d383db78fbed785cd2c4f054ae0ea4f9a /sysutils/pfstat
parenta72d2dc92ac7272c971ed937ee158bdb7065477c (diff)
downloadports-dc55152eac2d55dc5fe7909a482a906ac38b6ef1.tar.gz
ports-dc55152eac2d55dc5fe7909a482a906ac38b6ef1.zip
Notes
Diffstat (limited to 'sysutils/pfstat')
-rw-r--r--sysutils/pfstat/Makefile6
-rw-r--r--sysutils/pfstat/files/patch-pf.c17
2 files changed, 18 insertions, 5 deletions
diff --git a/sysutils/pfstat/Makefile b/sysutils/pfstat/Makefile
index 704f5a565af0..5111081a61fb 100644
--- a/sysutils/pfstat/Makefile
+++ b/sysutils/pfstat/Makefile
@@ -7,13 +7,13 @@
PORTNAME= pfstat
PORTVERSION= 2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils net
MASTER_SITES= http://www.benzedrine.cx/
DISTNAME= ${PORTNAME}-${PORTVERSION}
-MAINTAINER= mlaier@freebsd.org
-COMMENT= Utility to render grafical statistics for pf
+MAINTAINER= mlaier@FreeBSD.org
+COMMENT= Utility to render graphical statistics for pf
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
diff --git a/sysutils/pfstat/files/patch-pf.c b/sysutils/pfstat/files/patch-pf.c
index 71e897e8d49a..92abe2b69e40 100644
--- a/sysutils/pfstat/files/patch-pf.c
+++ b/sysutils/pfstat/files/patch-pf.c
@@ -1,6 +1,19 @@
--- pf.c.orig Thu May 11 23:41:07 2006
-+++ pf.c Fri Jul 7 21:49:20 2006
-@@ -144,23 +144,24 @@
++++ pf.c Mon Dec 11 21:08:31 2006
+@@ -67,10 +67,8 @@
+
+ /* first, find out how many queues there are */
+ memset(&pa, 0, sizeof(pa));
+- if (ioctl(fd, DIOCGETALTQS, &pa)) {
+- fprintf(stderr, "ioctl: DIOCGETALTQS: %s\n", strerror(errno));
+- return (1);
+- }
++ if (ioctl(fd, DIOCGETALTQS, &pa))
++ return (0);
+ mnr = pa.nr;
+
+ /* fetch each of those queues */
+@@ -144,23 +142,24 @@
query_ifaces(int fd, void (*cb)(int, const char *, int, double))
{
struct pfioc_iface io;