aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pftop/Makefile
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-02-14 17:07:07 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-02-14 17:07:07 +0000
commita1cde0a2c447f8ff33fe9fde2fac29b62157eaa1 (patch)
tree7c1584fd8a1180a2cba209da4d22a2db3e1ed9e8 /sysutils/pftop/Makefile
parente8a67ded537af11f4db16fa56278d8b42abde842 (diff)
downloadports-a1cde0a2c447f8ff33fe9fde2fac29b62157eaa1.tar.gz
ports-a1cde0a2c447f8ff33fe9fde2fac29b62157eaa1.zip
Notes
Diffstat (limited to 'sysutils/pftop/Makefile')
-rw-r--r--sysutils/pftop/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/sysutils/pftop/Makefile b/sysutils/pftop/Makefile
index 3c6faa603ab9..63ef1b23c7ef 100644
--- a/sysutils/pftop/Makefile
+++ b/sysutils/pftop/Makefile
@@ -23,13 +23,18 @@ MANCOMPRESSED= no
.if ${OSVERSION} < 700049
MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=37
CFLAGS+= -DHAVE_ALTQ=1
-.else
+.elif ${OSVERSION} < 900000
MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=41
CFLAGS+= -DHAVE_ALTQ=1
-.endif
-
-.if ${OSVERSION} >= 900000
-BROKEN= does not compile on 9.X
+.else
+MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=45
+CFLAGS+= -DHAVE_ALTQ=1 -DHAVE_SNPRINTF=1 -DHAVE_VSNPRINTF=1
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-cache.c \
+ ${FILESDIR}/extra-patch-cache.h \
+ ${FILESDIR}/extra-patch-config.h \
+ ${FILESDIR}/extra-patch-engine.c \
+ ${FILESDIR}/extra-patch-pftop.c \
+ ${FILESDIR}/extra-patch-sf-gencode.c
.endif
MAKE_ENV+= __MAKE_CONF=/dev/null
@@ -41,6 +46,7 @@ post-patch:
${WRKSRC}/engine.c
@${REINPLACE_CMD} -e 's|__dead|__dead2|g' ${WRKSRC}/sf-gencode.h
@${REINPLACE_CMD} -e 's|__dead|__dead2|g' ${WRKSRC}/sf-gencode.c
+ @${REINPLACE_CMD} -e 's|__inline__|static __inline__|g' ${WRKSRC}/pftop.c
@${REINPLACE_CMD} -e 's|#include <net/if_pflog.h>||g' \
${WRKSRC}/sf-gencode.c