aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pftop
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 13:32:06 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 13:32:06 +0000
commit82720705aa2ccd5569e9bef478cec9501f273d8e (patch)
tree01d90664faad2ae922aa77f977dcc6ce498e4e7e /sysutils/pftop
parentdad882d5d0711777dfd585fbc63eefc8f422ffe5 (diff)
downloadports-82720705aa2ccd5569e9bef478cec9501f273d8e.tar.gz
ports-82720705aa2ccd5569e9bef478cec9501f273d8e.zip
Notes
Diffstat (limited to 'sysutils/pftop')
-rw-r--r--sysutils/pftop/Makefile43
-rw-r--r--sysutils/pftop/distinfo1
-rw-r--r--sysutils/pftop/files/patch-aa11
-rw-r--r--sysutils/pftop/files/patch-ab15
-rw-r--r--sysutils/pftop/pkg-descr6
-rw-r--r--sysutils/pftop/pkg-plist1
6 files changed, 77 insertions, 0 deletions
diff --git a/sysutils/pftop/Makefile b/sysutils/pftop/Makefile
new file mode 100644
index 000000000000..cacfa2f8f9b2
--- /dev/null
+++ b/sysutils/pftop/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: pfflowd
+# Date created: 23 June 2003
+# Whom: Max Laier <max@love2party.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pftop
+PORTVERSION= 0.4
+CATEGORIES= sysutils net
+MASTER_SITES= http://www.eee.metu.edu.tr/~canacar/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= max@love2party.net
+COMMENT= Utility for real-time display of statistics for pf
+
+BUILD_DEPENDS= ${LOCALBASE}/include/pf/net/pfvar.h:${PORTSDIR}/security/pf
+.if defined(WITH_ALTQ) && (${WITH_ALTQ} == "yes")
+BUILD_DEPENDS+=${LOCALBASE}/include/pf/altq/altq.h:${PORTSDIR}/security/pf
+.endif
+RUN_DEPENDS= ${LOCALBASE}/modules/pf.ko:${PORTSDIR}/security/pf
+
+MAN8= pftop.8
+
+MANCOMPRESSED= no
+
+CFLAGS+= -I${LOCALBASE}/include/pf
+MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=34
+.if defined(WITH_ALTQ) && (${WITH_ALTQ} == "yes")
+CFLAGS+= -DHAVE_ALTQ=1
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= "Only for 5.0 and above"
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pftop ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/pftop.8 ${PREFIX}/man/man8
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/pftop/distinfo b/sysutils/pftop/distinfo
new file mode 100644
index 000000000000..e72b316d1340
--- /dev/null
+++ b/sysutils/pftop/distinfo
@@ -0,0 +1 @@
+MD5 (pftop-0.4.tar.gz) = d33b3a30152bac7d50d019a78bc58c72
diff --git a/sysutils/pftop/files/patch-aa b/sysutils/pftop/files/patch-aa
new file mode 100644
index 000000000000..419d0ba1a47a
--- /dev/null
+++ b/sysutils/pftop/files/patch-aa
@@ -0,0 +1,11 @@
+--- config.h.orig Sat Sep 27 14:21:58 2003
++++ config.h Sat Sep 27 14:22:21 2003
+@@ -24,7 +24,7 @@
+ #if OS_LEVEL > 32
+ #define HAVE_ADDR_MASK
+ #define HAVE_ADDR_TYPE
+-#define HAVE_ALTQ
++/* #define HAVE_ALTQ */
+ #define HAVE_RULE_ANCHOR
+ #define HAVE_RULE_TOS
+ #endif
diff --git a/sysutils/pftop/files/patch-ab b/sysutils/pftop/files/patch-ab
new file mode 100644
index 000000000000..82a0772f17b1
--- /dev/null
+++ b/sysutils/pftop/files/patch-ab
@@ -0,0 +1,15 @@
+--- ../pftop-0.4.orig/pftop.c Tue Aug 5 10:20:39 2003
++++ ./pftop.c Fri Sep 26 13:03:55 2003
+@@ -1983,10 +1983,10 @@
+ #ifdef HAVE_RULE_UGID
+ if (pr->uid.op)
+ tb_print_ugid(pr->uid.op, pr->uid.uid[0], pr->uid.uid[1],
+- "user", UID_MAX);
++ "user", UINT_MAX);
+ if (pr->gid.op)
+ tb_print_ugid(pr->gid.op, pr->gid.gid[0], pr->gid.gid[1],
+- "group", GID_MAX);
++ "group", UINT_MAX);
+ #endif
+
+ if (pr->flags || pr->flagset) {
diff --git a/sysutils/pftop/pkg-descr b/sysutils/pftop/pkg-descr
new file mode 100644
index 000000000000..434645dd4ff0
--- /dev/null
+++ b/sysutils/pftop/pkg-descr
@@ -0,0 +1,6 @@
+"Pftop is a small, curses-based utility for real-time display of active
+states and rule statistics for pf, the packet filter (for OpenBSD)"
+
+WWW: http://www.eee.metu.edu.tr/~canacar/pftop/
+
+-Max <max@love2party.net>
diff --git a/sysutils/pftop/pkg-plist b/sysutils/pftop/pkg-plist
new file mode 100644
index 000000000000..22d904d88f2e
--- /dev/null
+++ b/sysutils/pftop/pkg-plist
@@ -0,0 +1 @@
+sbin/pftop