aboutsummaryrefslogtreecommitdiff
path: root/sysutils/php5-fileinfo
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-09-07 14:30:03 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-09-07 14:30:03 +0000
commit570f1b227ce7fdadb7c031679c3aa93fe5f7ee70 (patch)
treec02f89a59a7e138b929074a6ed263c97f8eeabdd /sysutils/php5-fileinfo
parenteb6b6a7d155e64e16cd7a0a1323db82d2f504dd6 (diff)
downloadports-570f1b227ce7fdadb7c031679c3aa93fe5f7ee70.tar.gz
ports-570f1b227ce7fdadb7c031679c3aa93fe5f7ee70.zip
Notes
Diffstat (limited to 'sysutils/php5-fileinfo')
-rw-r--r--sysutils/php5-fileinfo/Makefile14
-rw-r--r--sysutils/php5-fileinfo/files/patch-config.m421
2 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/php5-fileinfo/Makefile b/sysutils/php5-fileinfo/Makefile
new file mode 100644
index 000000000000..88a720220b56
--- /dev/null
+++ b/sysutils/php5-fileinfo/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php5-fileinfo
+# Date created: 7 Sep 2010
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php5
+
+PKGNAMESUFFIX= -fileinfo
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/php5-fileinfo/files/patch-config.m4 b/sysutils/php5-fileinfo/files/patch-config.m4
new file mode 100644
index 000000000000..1348023ccf64
--- /dev/null
+++ b/sysutils/php5-fileinfo/files/patch-config.m4
@@ -0,0 +1,21 @@
+--- config.m4.orig 2010-09-07 15:45:30.000000000 +0200
++++ config.m4 2010-09-07 15:46:50.000000000 +0200
+@@ -4,6 +4,9 @@
+ PHP_ARG_ENABLE(fileinfo, for fileinfo support,
+ [ --disable-fileinfo Disable fileinfo support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir FILEINFO: pcre install prefix], no, no)
++
+ if test "$PHP_FILEINFO" != "no"; then
+
+ libmagic_sources=" \
+@@ -13,6 +16,8 @@
+ libmagic/is_tar.c libmagic/magic.c libmagic/print.c \
+ libmagic/readcdf.c libmagic/readelf.c libmagic/softmagic.c"
+
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++
+ PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
+ PHP_ADD_BUILD_DIR($ext_builddir/libmagic)
+