aboutsummaryrefslogtreecommitdiff
path: root/sysutils/php81-fileinfo
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-12-29 02:09:08 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-12-29 02:09:08 +0000
commit44e99def8ddf26311675cb2070eb062e1f7d0da5 (patch)
tree9406ba2c32bbaf622db561bc60e7483638f4beb2 /sysutils/php81-fileinfo
parent0ecc22072ebf57bc15002884e4baecf9c1d8dc92 (diff)
downloadports-44e99def8ddf26311675cb2070eb062e1f7d0da5.tar.gz
ports-44e99def8ddf26311675cb2070eb062e1f7d0da5.zip
Diffstat (limited to 'sysutils/php81-fileinfo')
-rw-r--r--sysutils/php81-fileinfo/Makefile7
-rw-r--r--sysutils/php81-fileinfo/files/patch-config.m421
2 files changed, 28 insertions, 0 deletions
diff --git a/sysutils/php81-fileinfo/Makefile b/sysutils/php81-fileinfo/Makefile
new file mode 100644
index 000000000000..38bd347b0ffe
--- /dev/null
+++ b/sysutils/php81-fileinfo/Makefile
@@ -0,0 +1,7 @@
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php81
+
+PKGNAMESUFFIX= -fileinfo
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/php81-fileinfo/files/patch-config.m4 b/sysutils/php81-fileinfo/files/patch-config.m4
new file mode 100644
index 000000000000..1348023ccf64
--- /dev/null
+++ b/sysutils/php81-fileinfo/files/patch-config.m4
@@ -0,0 +1,21 @@
+--- config.m4.orig 2010-09-07 15:45:30.000000000 +0200
++++ config.m4 2010-09-07 15:46:50.000000000 +0200
+@@ -4,6 +4,9 @@
+ PHP_ARG_ENABLE(fileinfo, for fileinfo support,
+ [ --disable-fileinfo Disable fileinfo support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir FILEINFO: pcre install prefix], no, no)
++
+ if test "$PHP_FILEINFO" != "no"; then
+
+ libmagic_sources=" \
+@@ -13,6 +16,8 @@
+ libmagic/is_tar.c libmagic/magic.c libmagic/print.c \
+ libmagic/readcdf.c libmagic/readelf.c libmagic/softmagic.c"
+
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++
+ PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
+ PHP_ADD_BUILD_DIR($ext_builddir/libmagic)
+