aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pipemeter
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-17 17:15:22 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-17 17:15:22 +0000
commit1de20ae5444502e747469f600ef8a25d3a834318 (patch)
treefa6835285d8ea43793fab6e9371a741f916f5ff8 /sysutils/pipemeter
parentcc0a90e2ad5d4da2c4e43804d164f73995faf5e2 (diff)
Notes
Diffstat (limited to 'sysutils/pipemeter')
-rw-r--r--sysutils/pipemeter/Makefile31
-rw-r--r--sysutils/pipemeter/distinfo1
-rw-r--r--sysutils/pipemeter/pkg-descr10
-rw-r--r--sysutils/pipemeter/pkg-plist5
4 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/pipemeter/Makefile b/sysutils/pipemeter/Makefile
new file mode 100644
index 000000000000..ecb86c2a0d51
--- /dev/null
+++ b/sysutils/pipemeter/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: pipemeter
+# Date created: 2003-12-02
+# Whom: Len Sassaman
+#
+# $FreeBSD$
+#
+
+PORTNAME= pipemeter
+PORTVERSION= 0.8.3
+CATEGORIES= sysutils
+MASTER_SITES= http://ports.abditum.com/pipemeter/ \
+ http://spamaps.org/files/pipemeter/
+
+MAINTAINER= rabbi@abditum.com
+COMMENT= Measure speed of data going through a pipe
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= pipemeter.1
+DOCS= Changelog README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pipemeter ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pipemeter.1 ${MAN1PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/pipemeter/distinfo b/sysutils/pipemeter/distinfo
new file mode 100644
index 000000000000..f7f88376b878
--- /dev/null
+++ b/sysutils/pipemeter/distinfo
@@ -0,0 +1 @@
+MD5 (pipemeter-0.8.3.tar.gz) = 3ecfb96bffbb3025124b72759026da2f
diff --git a/sysutils/pipemeter/pkg-descr b/sysutils/pipemeter/pkg-descr
new file mode 100644
index 000000000000..4d4215740895
--- /dev/null
+++ b/sysutils/pipemeter/pkg-descr
@@ -0,0 +1,10 @@
+pipemeter - measure speed of data going through a pipe/redirection
+
+Features:
+- Shows speed of data moving from input to output
+- Shows percentage complete if regular file specified
+- Allows tuning of block size and display interval
+- Support for dd style block size specification
+
+Author: Clint Byrum <cbyrum@spamaps.org>
+WWW: http://spamaps.org/pipemeter.php
diff --git a/sysutils/pipemeter/pkg-plist b/sysutils/pipemeter/pkg-plist
new file mode 100644
index 000000000000..2c99750e01e0
--- /dev/null
+++ b/sysutils/pipemeter/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+bin/pipemeter
+%%PORTDOCS%%%%DOCSDIR%%/Changelog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%