aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pmt
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-01-05 20:02:37 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-01-05 20:02:37 +0000
commit853c0e778f9a22c0fc75184dd016452477cfb2d2 (patch)
treebff828411d02791838e8cc76aed5552314d9bcfc /sysutils/pmt
parente350196de95cb936df2d757379bf0bcbfa9f91cb (diff)
downloadports-853c0e778f9a22c0fc75184dd016452477cfb2d2.tar.gz
ports-853c0e778f9a22c0fc75184dd016452477cfb2d2.zip
Notes
Diffstat (limited to 'sysutils/pmt')
-rw-r--r--sysutils/pmt/Makefile25
-rw-r--r--sysutils/pmt/distinfo3
-rw-r--r--sysutils/pmt/pkg-descr22
3 files changed, 50 insertions, 0 deletions
diff --git a/sysutils/pmt/Makefile b/sysutils/pmt/Makefile
new file mode 100644
index 000000000000..3f7859a60a72
--- /dev/null
+++ b/sysutils/pmt/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: pmt
+# Date created: 2010-01-05
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pmt
+PORTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://hansmi.ch/download/pmt/ \
+ LOCAL/glarkin
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= A small collection of filters which can be added to UNIX pipes
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/pmt
+
+do-install:
+ @${CP} ${WRKSRC}/pmt ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/pmt/distinfo b/sysutils/pmt/distinfo
new file mode 100644
index 000000000000..dbf250c8b2bd
--- /dev/null
+++ b/sysutils/pmt/distinfo
@@ -0,0 +1,3 @@
+MD5 (pmt-0.2.tar.bz2) = 0a1d005f853ae403e60a618eeda83729
+SHA256 (pmt-0.2.tar.bz2) = 8a07f9708bc11e96896c0875e521641e2e844e3d495b3309ba38a8b8aa841246
+SIZE (pmt-0.2.tar.bz2) = 6810
diff --git a/sysutils/pmt/pkg-descr b/sysutils/pmt/pkg-descr
new file mode 100644
index 000000000000..428f16422a68
--- /dev/null
+++ b/sysutils/pmt/pkg-descr
@@ -0,0 +1,22 @@
+The Pipe Magic Tools (PMT) are a small collection of filters which
+can be added to UNIX pipes. The filters include:
+
+speed
+ Measures the speed of the data flowing through the pipe
+
+throttle
+ Controls the speed of the data flowing through the pipe
+
+rot13
+ The famous rot13 algorithm
+
+rot47
+ The not-so-famous rot47 algorithm
+
+tolower
+ Converts all alphabetic characters to lower case
+
+toupper
+ Converts all alphabetic characters to upper case
+
+WWW: http://hansmi.ch/software/pipe-magic-tools