aboutsummaryrefslogtreecommitdiff
path: root/sysutils/policykit
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2009-09-06 21:18:50 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2009-09-06 21:18:50 +0000
commit80ce349ead781fafb5528d69310848254d4afbf8 (patch)
tree9e4543908f3bf06a3af78267b4523928d41925b9 /sysutils/policykit
parent082f117cfc49edb878d4e17e43719ab6e461af0b (diff)
downloadports-80ce349ead781fafb5528d69310848254d4afbf8.tar.gz
ports-80ce349ead781fafb5528d69310848254d4afbf8.zip
Notes
Diffstat (limited to 'sysutils/policykit')
-rw-r--r--sysutils/policykit/Makefile5
-rw-r--r--sysutils/policykit/pkg-install27
2 files changed, 4 insertions, 28 deletions
diff --git a/sysutils/policykit/Makefile b/sysutils/policykit/Makefile
index c784bead4d8d..a43749208604 100644
--- a/sysutils/policykit/Makefile
+++ b/sysutils/policykit/Makefile
@@ -8,7 +8,7 @@
PORTNAME= policykit
PORTVERSION= 0.9
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= sysutils gnome
MASTER_SITES= http://hal.freedesktop.org/releases/
DISTNAME= PolicyKit-${PORTVERSION}
@@ -19,6 +19,9 @@ COMMENT= Framework for controlling access to system-wide components
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
expat.6:${PORTSDIR}/textproc/expat2
+USERS= polkit
+GROUPS= polkit
+
USE_GNOME= gnomehack glib20 intlhack
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/sysutils/policykit/pkg-install b/sysutils/policykit/pkg-install
index 132e98e9f5a5..3fbb00c5f1fb 100644
--- a/sysutils/policykit/pkg-install
+++ b/sysutils/policykit/pkg-install
@@ -4,33 +4,6 @@ case $2 in
POST-INSTALL)
USER=polkit
GROUP=${USER}
- UID=562
- GID=${UID}
- PW=/usr/sbin/pw
-
- if ${PW} group show "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if ${PW} groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
- fi
-
- if ${PW} user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if ${PW} useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -d "/nonexistent" -s /sbin/nologin -c "PolicyKit Daemon User"
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
- fi
/usr/bin/install -d -o root -m 0770 -g ${GROUP} /var/run/PolicyKit
/usr/bin/install -d -o root -m 0770 -g ${GROUP} /var/lib/PolicyKit