aboutsummaryrefslogtreecommitdiff
path: root/sysutils/polkit-kde
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-05-11 12:46:44 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-05-11 12:46:44 +0000
commit40d79f981e9dd594d4da1839865d2b827ced6be9 (patch)
tree59bf71e6c9bd3799630a3add2a82e4f5f7229aa4 /sysutils/polkit-kde
parent22f5d84c0345afcf7f19685197ffd18bfe60df15 (diff)
downloadports-40d79f981e9dd594d4da1839865d2b827ced6be9.tar.gz
ports-40d79f981e9dd594d4da1839865d2b827ced6be9.zip
Notes
Diffstat (limited to 'sysutils/polkit-kde')
-rw-r--r--sysutils/polkit-kde/Makefile43
-rw-r--r--sysutils/polkit-kde/distinfo3
-rw-r--r--sysutils/polkit-kde/pkg-descr3
-rw-r--r--sysutils/polkit-kde/pkg-plist15
4 files changed, 64 insertions, 0 deletions
diff --git a/sysutils/polkit-kde/Makefile b/sysutils/polkit-kde/Makefile
new file mode 100644
index 000000000000..aed6bdba22a3
--- /dev/null
+++ b/sysutils/polkit-kde/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: PolKit-kde
+# Date created: 2009-12-25
+# Whom: Dima Panov <fluffy@Fluffy.Khv.RU>
+#
+# $FreeBSD$
+#
+
+PORTNAME= polkit-kde
+PORTVERSION= 0.95.1
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/apps/KDE4.x/admin/
+DISTNAME= polkit-kde-1-${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE4 frontend to PolKit-1.
+
+LIB_DEPENDS= polkit-qt-agent-1.0:${PORTSDIR}/sysutils/polkit-qt
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib dbus gui network svg xml \
+ qmake_build moc_build rcc_build uic_build
+USE_CMAKE= yes
+
+USE_KDE4= kdelibs kdeprefix automoc4
+
+CMAKE_ARGS+= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib"
+CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH:STRING="${LOCALBASE}/include"
+CMAKE_ARGS+= -DCMAKE_EXE_LINKER_FLAGS:STRING="-L${LOCALBASE}/lib"
+CMAKE_ARGS+= -DCMAKE_SHARED_LINKER_FLAGS:STRING="-L${LOCALBASE}/lib"
+CMAKE_ENV+= XDG_CONFIG_DIRS="${PREFIX}/etc/xdg/autostart"
+
+
+post-extract:
+ ${REINPLACE_CMD} -e 's|$${LIB_INSTALL_DIR}/pkgconfig|libdata/pkgconfig|' \
+ ${WRKSRC}/CMakeLists.txt
+# ${REINPLACE_CMD} -e 's|/etc/xdg|${PREFIX}/etc/xdg|' \
+# ${WRKSRC}/agent/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/sysutils/polkit-kde/distinfo b/sysutils/polkit-kde/distinfo
new file mode 100644
index 000000000000..6996b7ddb013
--- /dev/null
+++ b/sysutils/polkit-kde/distinfo
@@ -0,0 +1,3 @@
+MD5 (polkit-kde-1-0.95.1.tar.bz2) = 68e40d2a43335cb5876a1c8bc51c461b
+SHA256 (polkit-kde-1-0.95.1.tar.bz2) = 3a16fdc80a57efd4713c12b04762f1dca5e6b58bd61b9ef0cdc89619d7e8d98a
+SIZE (polkit-kde-1-0.95.1.tar.bz2) = 21345
diff --git a/sysutils/polkit-kde/pkg-descr b/sysutils/polkit-kde/pkg-descr
new file mode 100644
index 000000000000..d52f7ad295c7
--- /dev/null
+++ b/sysutils/polkit-kde/pkg-descr
@@ -0,0 +1,3 @@
+KDE44 frontend to PolicyKit.
+
+WWW: http://www.kde.org/
diff --git a/sysutils/polkit-kde/pkg-plist b/sysutils/polkit-kde/pkg-plist
new file mode 100644
index 000000000000..a5781ad2c164
--- /dev/null
+++ b/sysutils/polkit-kde/pkg-plist
@@ -0,0 +1,15 @@
+etc/xdg/autostart/polkit-kde-authentication-agent-1.desktop
+lib/kde4/libexec/polkit-kde-authentication-agent-1
+share/locale/da/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+share/locale/en_GB/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+share/locale/et/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+share/locale/gl/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+share/locale/lt/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+share/locale/nl/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+share/locale/pt/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+share/locale/pt_BR/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+share/locale/sk/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+share/locale/sv/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+share/locale/uk/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+share/locale/zh_TW/LC_MESSAGES/polkit-kde-authentication-agent-1.mo
+@dirrmtry etc/xdg/autostart \ No newline at end of file