aboutsummaryrefslogtreecommitdiff
path: root/sysutils/polkit
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /sysutils/polkit
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.32/ This will be the last release of the GNOME 2.x series, mainly a bugfix and bridge release to the first release of the GNOME 3.x series. This release features commits by avl, marcus, mezz and myself. The FreeBSD GNOME Team would like to thank the following contributors and testers for there help with this release: Zane C.B. <vvelox@vvelox.net> romain@ Olaf Seibert <O.Seibert@cs.ru.nl> DomiX Bapt <baptiste.daroussin@gmail.com> jsa@ miwi@ Sergio de Almeida Lenzi <lenzi.sergio@gmail.com> Maxim Samsonov <xors@mne.ru> Kris Moore And pav@ for 2 exp-runs PR: ports/152255 ports/143260 ports/141033 ports/149629 ports/150350 ports/151523 With hat: gnome@
Notes
Notes: svn path=/head/; revision=264837
Diffstat (limited to 'sysutils/polkit')
-rw-r--r--sysutils/polkit/Makefile9
-rw-r--r--sysutils/polkit/distinfo6
-rw-r--r--sysutils/polkit/files/patch-src_polkitd_gposixsignal.c40
-rw-r--r--sysutils/polkit/pkg-plist7
4 files changed, 50 insertions, 12 deletions
diff --git a/sysutils/polkit/Makefile b/sysutils/polkit/Makefile
index c9441d0595c0..e1fcbac4cf51 100644
--- a/sysutils/polkit/Makefile
+++ b/sysutils/polkit/Makefile
@@ -3,12 +3,11 @@
# Whom: Koop Mast<kwm@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/polkit/Makefile,v 1.5 2009/11/26 14:22:58 mezz Exp $
+# $MCom: ports/sysutils/polkit/Makefile,v 1.10 2010/09/16 02:09:43 avl Exp $
#
PORTNAME= polkit
-PORTVERSION= 0.96
-PORTREVISION= 2
+PORTVERSION= 0.99
CATEGORIES= sysutils gnome
MASTER_SITES= http://hal.freedesktop.org/releases/
@@ -54,11 +53,11 @@ post-patch:
post-install:
${MKDIR} ${PREFIX}/etc/dbus-1/system.d/
if [ ! -f ${PREFIX}/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf ]; then \
- ${INSTALL_DATA} ${WRKSRC}/data/org.freedesktop.PolicyKit1.conf \
+ ${INSTALL_DATA} ${WRKSRC}/data/org.freedesktop.PolicyKit1.conf \
${PREFIX}/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf ; \
fi
${INSTALL_DATA} ${WRKSRC}/data/org.freedesktop.PolicyKit1.conf \
- ${PREFIX}/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf.dist
+ ${PREFIX}/etc/dbus-1/system.d/org.freedesktop.PolicyKit1.conf.dist
.if !defined(PACKAGE_BUILDING)
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
diff --git a/sysutils/polkit/distinfo b/sysutils/polkit/distinfo
index 628723b6c799..edf3d2550267 100644
--- a/sysutils/polkit/distinfo
+++ b/sysutils/polkit/distinfo
@@ -1,3 +1,3 @@
-MD5 (polkit-0.96.tar.gz) = e0a06da501b04ed3bab986a9df5b5aa2
-SHA256 (polkit-0.96.tar.gz) = 3426ca917210b2a5525732559368c18f983a4c39a6a55c5dddba26071bd8054a
-SIZE (polkit-0.96.tar.gz) = 1034210
+MD5 (polkit-0.99.tar.gz) = fcc4d7b19c08ad54d3ce0eae0ab12398
+SHA256 (polkit-0.99.tar.gz) = f612c7c26ec822f67751420057a4ae113fc50ab51070758faacf2ad30bb3583f
+SIZE (polkit-0.99.tar.gz) = 1042461
diff --git a/sysutils/polkit/files/patch-src_polkitd_gposixsignal.c b/sysutils/polkit/files/patch-src_polkitd_gposixsignal.c
new file mode 100644
index 000000000000..4fb366f4f2de
--- /dev/null
+++ b/sysutils/polkit/files/patch-src_polkitd_gposixsignal.c
@@ -0,0 +1,40 @@
+--- src/polkitd/gposixsignal.c.orig 2010-08-29 20:05:07.000000000 -0400
++++ src/polkitd/gposixsignal.c 2010-08-29 20:13:20.000000000 -0400
+@@ -23,7 +23,13 @@
+ #include "config.h"
+
+ #include <unistd.h>
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <sys/event.h>
++#include <sys/time.h>
++#else
+ #include <sys/signalfd.h>
++#endif
+ #include <signal.h>
+
+ #include "gposixsignal.h"
+@@ -83,6 +89,9 @@ _g_posix_signal_source_new (gint signum)
+ gint fd;
+ GSource *_source;
+ _GPosixSignalSource *source;
++#ifdef __FreeBSD__
++ struct kevent ev;
++#endif
+
+ _source = NULL;
+
+@@ -92,7 +101,13 @@ _g_posix_signal_source_new (gint signum)
+ if (sigprocmask (SIG_BLOCK, &sigset, NULL) == -1)
+ g_assert_not_reached ();
+
++#ifdef __FreeBSD__
++ fd = kqueue ();
++ EV_SET (&ev, signum, EVFILT_SIGNAL, EV_ADD, 0, 0, NULL);
++ kevent (fd, &ev, 1, NULL, 0, NULL);
++#else
+ fd = signalfd (-1, &sigset, SFD_NONBLOCK | SFD_CLOEXEC);
++#endif
+
+ _source = g_source_new (&_g_posix_signal_source_funcs, sizeof (_GPosixSignalSource));
+ source = (_GPosixSignalSource *) _source;
diff --git a/sysutils/polkit/pkg-plist b/sysutils/polkit/pkg-plist
index 9c707ff65eb9..5f7672022836 100644
--- a/sysutils/polkit/pkg-plist
+++ b/sysutils/polkit/pkg-plist
@@ -18,6 +18,7 @@ include/polkit-1/polkit/polkitenumtypes.h
include/polkit-1/polkit/polkiterror.h
include/polkit-1/polkit/polkitidentity.h
include/polkit-1/polkit/polkitimplicitauthorization.h
+include/polkit-1/polkit/polkitpermission.h
include/polkit-1/polkit/polkitprivate.h
include/polkit-1/polkit/polkitsubject.h
include/polkit-1/polkit/polkitsystembusname.h
@@ -28,18 +29,16 @@ include/polkit-1/polkit/polkitunixprocess.h
include/polkit-1/polkit/polkitunixsession.h
include/polkit-1/polkit/polkitunixuser.h
include/polkit-1/polkitagent/polkitagent.h
+include/polkit-1/polkitagent/polkitagentenumtypes.h
include/polkit-1/polkitagent/polkitagentlistener.h
include/polkit-1/polkitagent/polkitagentsession.h
include/polkit-1/polkitagent/polkitagenttypes.h
+include/polkit-1/polkitagent/polkitagenttextlistener.h
include/polkit-1/polkitbackend/polkitbackend.h
include/polkit-1/polkitbackend/polkitbackendactionlookup.h
-include/polkit-1/polkitbackend/polkitbackendactionpool.h
include/polkit-1/polkitbackend/polkitbackendauthority.h
-include/polkit-1/polkitbackend/polkitbackendconfigsource.h
include/polkit-1/polkitbackend/polkitbackendinteractiveauthority.h
include/polkit-1/polkitbackend/polkitbackendlocalauthority.h
-include/polkit-1/polkitbackend/polkitbackendlocalauthorizationstore.h
-include/polkit-1/polkitbackend/polkitbackendsessionmonitor.h
include/polkit-1/polkitbackend/polkitbackendtypes.h
lib/girepository-1.0/Polkit-1.0.typelib
lib/libpolkit-agent-1.a